package postgresql-client-9.1 9.1.5-1 failed to install/upgrade: trying to overwrite '/usr/share/postgresql/9.1/man/man1/pg_basebackup.1.gz', which is also in package postgresql-9.1 9.1.5-0ubuntu12.04

Bug #1043449 reported by mezclatebrother! on 2012-08-29
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
postgresql-9.1 (Ubuntu)
High
Martin Pitt
Quantal
High
Martin Pitt

Bug Description

Updating to quantal

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: postgresql-client-9.1 9.1.5-0ubuntu12.04
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.5.1-0ubuntu3
Architecture: i386
Date: Wed Aug 29 17:42:36 2012
ErrorMessage: intentando sobreescribir `/usr/share/postgresql/9.1/man/man1/pg_basebackup.1.gz', que está también en el paquete postgresql-9.1 9.1.5-0ubuntu12.04
SourcePackage: postgresql-9.1
Title: package postgresql-client-9.1 9.1.5-0ubuntu12.04 failed to install/upgrade: intentando sobreescribir `/usr/share/postgresql/9.1/man/man1/pg_basebackup.1.gz', que está también en el paquete postgresql-9.1 9.1.5-0ubuntu12.04
UpgradeStatus: Upgraded to quantal on 2011-10-28 (305 days ago)

Related branches

mezclatebrother! (prueboblog) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in postgresql-9.1 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2012-08-30
Changed in postgresql-9.1 (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → High
status: Confirmed → In Progress
Changed in postgresql-9.1 (Ubuntu Quantal):
milestone: none → ubuntu-12.10-beta-1
summary: - package postgresql-client-9.1 9.1.5-0ubuntu12.04 failed to
- install/upgrade: intentando sobreescribir
- `/usr/share/postgresql/9.1/man/man1/pg_basebackup.1.gz', que está
- también en el paquete postgresql-9.1 9.1.5-0ubuntu12.04
+ package postgresql-client-9.1 9.1.5-1 failed to install/upgrade: trying
+ to overwrite '/usr/share/postgresql/9.1/man/man1/pg_basebackup.1.gz',
+ which is also in package postgresql-9.1 9.1.5-0ubuntu12.04
Martin Pitt (pitti) wrote :

Fixed in packaging bzr.

Changed in postgresql-9.1 (Ubuntu Quantal):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-9.1 - 9.1.5-2

---------------
postgresql-9.1 (9.1.5-2) unstable; urgency=low

  * debian/rules: Re-enable hardening functions (regression from 9.1.3-2 when
    hardening-wrapper is not installed). Use "hardening=all", but disable
    "pie" (as that's not compatible with -fPIC) and add -pie to CFLAGS
    explicitly. Also drop the explicit "-Wl,-z,now" linker option, as this is
    now implied with "all". (LP: #1039618)
  * Fix upgrades from older 9.1 releases in stable Ubuntu -updates/-security
    releasese. The strict "<< 9.1.4-2~" check for moving pg_basebackup.1.gz is
    not sufficient, as Ubuntu stables have newer upstream releases by now.
    - debian/control: Move Breaks/Replaces: from static version to
      ${binary:Version}.
    - debian/postgresql-9.1.preinst: Also fix the alternatives when upgrading
      from a -0something version.
    - (LP: #1043449)

 -- Martin Pitt <email address hidden> Fri, 31 Aug 2012 09:54:27 +0200

Changed in postgresql-9.1 (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers