QT Creator does not build any projects on default install

Bug #521409 reported by Mike Rose on 2010-02-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-8.4 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qtcreator

Fresh install of qtcreator (at the same time as qt-designer). go to open an example project (any) and try to build and the little build progress bar at the left gets approx 10% and nothing happens. Any created project does not build either.

Running qtcreator from the commandline reveals the following cryptic errors:

Could not detect ToolChain for "/usr/share/qt4/mkspecs/linux-g++"
Qt Creator doesn't know about the system includes, nor the systems defines.

Both g++ and qt4-dev-tools are installed. I thought perhaps it was because yacc and flex were not installed, but installing these does not fix the error.

I have both the files
/usr/share/qt4/mkspecs/linux-g++/qmake.conf
/usr/share/qt4/mkspecs/linux-g++/qplatformdefs.h

I can paste the contents if it helps, but I haven't modified anything from what I was given from the repos.

ProblemType: Bug
Architecture: amd64
Date: Sun Feb 14 02:43:08 2010
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: qtcreator 1.2.1-3ubuntu1
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-20.57-generic
SourcePackage: qtcreator
Uname: Linux 2.6.31-20-generic x86_64

Mike Rose (mr79) wrote :
Mike Rose (mr79) wrote :

Further investigation:
qtcreator does not depend on libqt4-dev (!)
Tried installing libqt4-dev however it depends on libpq-dev
libpq-dev can't be installed due to it depending on a different version of libpq5 (8.4.2-0ubuntu9.10) than is what was installed (8.4.2-1~jaunty1)

Fix: Forced downgrade of libpq5 to 8.4.2-0ubuntu9.10, installed libpq-dev and libqt4-dev

Everything works now. Changing package to libpq5

Mike Rose (mr79) wrote :

Cannot change 'affects' package. Any help? How do i get this bug in the hands of the repo maintainers?

Rohan Garg (rohangarg) wrote :

Hi
Since the problem seems to be with libpq5 im changing the Affects field

affects: qtcreator (Ubuntu) → postgresql-8.4 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers