package postgresql-8.4 8.4.2-0ubuntu9.10 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #498719 reported by Jacob on 2009-12-20
82
This bug affects 18 people
Affects Status Importance Assigned to Milestone
postgresql-8.4 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: postgresql-8.4

Ubuntu - Karmic Koala (9.10)
I was invited to install these updates by the update manager.

$ apt-cache policy postgresql
postgresql:
  Installed: 8.4.2-0ubuntu9.10
  Candidate: 8.4.2-0ubuntu9.10
  Version table:
 *** 8.4.2-0ubuntu9.10 0
        500 http://us.archive.ubuntu.com karmic-proposed/main Packages
        100 /var/lib/dpkg/status
     8.4.1-1 0
        500 http://us.archive.ubuntu.com karmic/main Packages

================
The error messages I encountered are nearly identical to those in bugs 496854 and 488278. Here is the complete text from the various display boxes. The main difference is that my boxes do not display the complete version of the PosgreSQL modules but stop at the 8.4 .

From the "Update complete" window:
Errors were encountered while processing:
 postgresql-8.4
 postgresql
 postgresql-contrib-8.4
 postgresql-plperl-8.4
 postgresql-plpython-8.4
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up postgresql-8.4 (8.4.2-0ubuntu9.10) ...
 * Starting PostgreSQL 8.4 database server
 * The PostgreSQL server failed to start. Please check the log output:
2009-12-20 02:41:47 EST LOG: invalid IP mask "trust": Name or service not known
2009-12-20 02:41:47 EST CONTEXT: line 110 of configuration file "/etc/postgresql/8.4/main/pg_hba.conf"
2009-12-20 02:41:47 EST FATAL: could not load pg_hba.conf
   ...fail!
invoke-rc.d: initscript postgresql-8.4, action "start" failed.
dpkg: error processing postgresql-8.4 (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql-contrib-8.4:
 postgresql-contrib-8.4 depends on postgresql-8.4; however:
  Package postgresql-8.4 is not configured yet.
dpkg: error processing postgresql-contrib-8.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql-plpython-8.4:
 postgresql-plpython-8.4 depends on postgresql-8.4; however:
  Package postgresql-8.4 is not configured yet.
dpkg: error processing postgresql-plpython-8.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql-plperl-8.4:
 postgresql-plperl-8.4 depends on postgresql-8.4; however:
  Package postgresql-8.4 is not configured yet.
dpkg: error processing postgresql-plperl-8.4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql:
 postgresql depends on postgresql-8.4; however:
  Package postgresql-8.4 is not configured yet.
dpkg: error processing postgresql (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 postgresql-8.4
 postgresql-contrib-8.4
 postgresql-plpython-8.4
 postgresql-plperl-8.4
 postgresql
===================
From the Error box:
E: postgresql-8.4: subprocess installed post-installation script returned error exit status 1
E: postgresql: dependency problems - leaving unconfigured
E: postgresql-contrib-8.4: dependency problems - leaving unconfigured
E: postgresql-plperl-8.4: dependency problems - leaving unconfigured
E: postgresql-plpython-8.4: dependency problems - leaving unconfigured
=========================================================================

ProblemType: Package
Architecture: i386
Date: Sun Dec 20 02:41:05 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
Package: postgresql-8.4 8.4.2-0ubuntu9.10
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: postgresql-8.4
Title: package postgresql-8.4 8.4.2-0ubuntu9.10 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-17-generic i686

Jacob (jakesalomon) wrote :
iheartubuntu (iheartubuntu) wrote :

Im getting this error message after every update I do.

Download full text (4.9 KiB)

what's worse, completely uninstalling postgrsql 8.4 and all common and
client files, and reinstalling postgresql 8.3, the error messages continue.
It's as if putting in 8.4 clobbers the machine so it can't run from Ubuntu
packaged postgresql.

I had to compile, install and configure tar.gz of 8.4 from postgresql site.
At least I can run postgresql now

On Thu, Jan 14, 2010 at 4:01 PM, mrandrzejak <email address hidden> wrote:

> Im getting this error message after every update I do.
>
> --
> package postgresql-8.4 8.4.2-0ubuntu9.10 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> https://bugs.launchpad.net/bugs/498719
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “postgresql-8.4” package in Ubuntu: New
>
> Bug description:
> Binary package hint: postgresql-8.4
>
> Ubuntu - Karmic Koala (9.10)
> I was invited to install these updates by the update manager.
>
> $ apt-cache policy postgresql
> postgresql:
> Installed: 8.4.2-0ubuntu9.10
> Candidate: 8.4.2-0ubuntu9.10
> Version table:
> *** 8.4.2-0ubuntu9.10 0
> 500 http://us.archive.ubuntu.com karmic-proposed/main Packages
> 100 /var/lib/dpkg/status
> 8.4.1-1 0
> 500 http://us.archive.ubuntu.com karmic/main Packages
>
> ================
> The error messages I encountered are nearly identical to those in bugs
> 496854 and 488278. Here is the complete text from the various display boxes.
> The main difference is that my boxes do not display the complete version of
> the PosgreSQL modules but stop at the 8.4 .
>
> >From the "Update complete" window:
> Errors were encountered while processing:
> postgresql-8.4
> postgresql
> postgresql-contrib-8.4
> postgresql-plperl-8.4
> postgresql-plpython-8.4
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> A package failed to install. Trying to recover:
> Setting up postgresql-8.4 (8.4.2-0ubuntu9.10) ...
> * Starting PostgreSQL 8.4 database server
> * The PostgreSQL server failed to start. Please check the log output:
> 2009-12-20 02:41:47 EST LOG: invalid IP mask "trust": Name or service not
> known
> 2009-12-20 02:41:47 EST CONTEXT: line 110 of configuration file
> "/etc/postgresql/8.4/main/pg_hba.conf"
> 2009-12-20 02:41:47 EST FATAL: could not load pg_hba.conf
> ...fail!
> invoke-rc.d: initscript postgresql-8.4, action "start" failed.
> dpkg: error processing postgresql-8.4 (--configure):
> subprocess installed post-installation script returned error exit status 1
> dpkg: dependency problems prevent configuration of postgresql-contrib-8.4:
> postgresql-contrib-8.4 depends on postgresql-8.4; however:
> Package postgresql-8.4 is not configured yet.
> dpkg: error processing postgresql-contrib-8.4 (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configuration of postgresql-plpython-8.4:
> postgresql-plpython-8.4 depends on postgresql-8.4; however:
> Package postgresql-8.4 is not configured yet.
> dpkg: error processing postgresql-plpython-8.4 (--configure):
> dependency problems - leaving unconfigured
> dpkg: dependency problems prevent configur...

Read more...

Mark Lassau (mlassau) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers