postgrsesql service fails to start with 2.6.31-15-generic-pae

Bug #487675 reported by Seth Rosenblum on 2009-11-24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-8.4 (Ubuntu)

Bug Description

Binary package hint: postgresql-8.4

I received the following error when attempting to start postgresql-8.4 after installing the recent kernel update:

$ sudo service postgresql-8.4 start
[sudo] password for [username]:
 * Starting PostgreSQL 8.4 database server * The PostgreSQL server failed to start. Please check the log output:
2009-11-24 10:59:05 EST FATAL: could not create shared memory segment: Invalid argument
2009-11-24 10:59:05 EST DETAIL: Failed system call was shmget(key=5432001, size=36880384, 03600).
2009-11-24 10:59:05 EST HINT: This error usually means that PostgreSQL's request for a shared memory segment exceeded your kernel's SHMMAX parameter. You can either reduce the request size or reconfigure the kernel with larger SHMMAX. To reduce the request size (currently 36880384 bytes), reduce PostgreSQL's shared_buffers parameter (currently 4096) and/or its max_connections parameter (currently 103).
 If the request size is already small, it's possible that it is less than your kernel's SHMMIN parameter, in which case raising the request size or reconfiguring SHMMIN is called for.
 The PostgreSQL documentation contains more information about shared memory configuration.

relevant kernel information:
$ uname -a
Linux srosenblum-wks 2.6.31-15-generic-pae #50-Ubuntu SMP Tue Nov 10 16:12:10 UTC 2009 i686 GNU/Linux
$ sysctl kernel.shmmax
kernel.shmmax = 33554432

default configuration of postgresql.conf:
# - Memory -

shared_buffers = 32MB # min 128kB
     # (change requires restart)

I assume this is just a kernel change that needs to be accounted for, but clearly pg should be able to start by default with this kernel.

Thanks all

ProblemType: Bug
Architecture: i386
Date: Tue Nov 24 11:31:27 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: postgresql 8.4.1-1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.31-15.50-generic-pae
SourcePackage: postgresql-8.4
Uname: Linux 2.6.31-15-generic-pae i686
 (gnome-settings-daemon:1717): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1852): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1814): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Seth Rosenblum (ricklerre) wrote :
Mike Longer (andylonger1984) wrote :

I has the same type of Problem. Anybody has the solution. Please check below for More details.

Distributor ID: Ubuntu
Description: Ubuntu 8.04.4 LTS
Release: 8.04
Codename: hardy

I have ebox for the file sharing in the office, this morning it got updated and now PostgreSQL doesn't start.
I have tried all the forums and tried changing the memory on the kernal.shmmax and even reducing the shared_memory on PostgreSQL to 24MB, but it wont work. Can somebody please advice me what to do . Because of this, now there is no file sharing in the office and i'm getting screwed from my boss.

kernel.shmmax = 209715200
kernel.shmall = 2097152
kernel.shmmni = 4096

Please somebody help me with a solution

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers