New upstream bug fix releases 8.3.5/8.2.11/8.1.15

Bug #293758 reported by Martin Pitt on 2008-11-04
6
Affects Status Importance Assigned to Milestone
postgresql-8.1 (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
postgresql-8.2 (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Unassigned
postgresql-8.3 (Ubuntu)
Undecided
Martin Pitt
Dapper
Undecided
Unassigned
Gutsy
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned
Jaunty
Undecided
Martin Pitt
Martin Pitt (pitti) on 2008-11-04
Changed in postgresql-8.1:
status: New → Invalid
Changed in postgresql-8.2:
status: New → Invalid
Changed in postgresql-8.1:
status: New → Invalid
Changed in postgresql-8.2:
status: New → Invalid
status: New → Invalid
Changed in postgresql-8.1:
status: New → Invalid
Changed in postgresql-8.2:
status: New → Invalid
Changed in postgresql-8.1:
status: New → Invalid
Changed in postgresql-8.3:
status: New → Invalid
status: New → Invalid
Martin Pitt (pitti) wrote :

Accepted into intrepid-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in postgresql-8.3:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

8.3.5-1 uploaded to Debian unstable, where it will be auto-synced to Jaunty once it opens.

Changed in postgresql-8.3:
assignee: nobody → pitti
status: New → Fix Committed
Martin Pitt (pitti) wrote :

postgresql-8.3/hardy-proposed uploaded.

Changed in postgresql-8.3:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

postgresql-8.2/gutsy-proposed accepted.

Changed in postgresql-8.2:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

postgresql-8.1/dapper accepted into -proposed.

Changed in postgresql-8.1:
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Hello Launchpad developers,

we are currently updating PostgreSQL packages to the recently released new microreleases in all stable Ubuntu releases. So far I did the package updates, ran the upstream and postgresql-common testsuites, and supervised the upstream bug ML for regression reports, has been quiet so far.

Nevertheless, both for satisfying the SRU practice as well as exercising more widespread testing it would be great if some people could run -proposed on their boxes and check the new packages with some real-world tests like Launchpad.

Maybe someone can run the LP test suite with the -proposed packages?

Thanks a lot in advance!

Leonel Nunez (leonelnunez) wrote :

Testing Gutsy , Hardy

Martin Pitt (pitti) wrote :

Jaunty fixed during autosync:

postgresql-8.3 | 8.3.5-1 | jaunty | source, amd64, i386

Changed in postgresql-8.3:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Three weeks have passed without any regression reports upstream or in Launchpad. Copied to -updates.

Changed in postgresql-8.1:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.2 - 8.2.11-0ubuntu0.7.10

---------------
postgresql-8.2 (8.2.11-0ubuntu0.7.10) gutsy-proposed; urgency=low

  * New upstream bug fix release 8.2.11: (LP: #293758)
    - Fix GiST index corruption due to marking the wrong index entry
      "dead" after a deletion. This would result in index searches failing to
      find rows they should have found.
    - Fix backend crash when the client encoding cannot represent a
      localized error message.
    - Fix possible crash when deeply nested functions are invoked from a
      trigger.
    - Improve optimization of "expression" IN ("expression-list") queries.
      Cases in which there are query variables on the right-hand side had
      been handled less efficiently in 8.2.x and 8.3.x than in prior
      versions. The fix restores 8.1 behavior for such cases.
    - Fix mis-expansion of rule queries when a sub-SELECT appears in a
      function call in FROM, a multi-row VALUES list, or a RETURNING list.
      The usual symptom of this problem is an "unrecognized node type"
      error.
    - Fix memory leak during rescan of a hashed aggregation plan.
    - Ensure an error is reported when a newly-defined PL/pgSQL trigger
      function is invoked as a normal function.
    - Prevent possible collision of relfilenode numbers when moving a
      table to another tablespace with "ALTER SET TABLESPACE".
    - Fix incorrect tsearch2 headline generation when single query item
      matches first word of text.
    - Fix improper display of fractional seconds in interval values when
      using a non-ISO datestyle.
    - Ensure SPI_getvalue and SPI_getbinval behave correctly when the
      passed tuple and tuple descriptor have different numbers of columns.
      This situation is normal when a table has had columns added or
      removed, but these two functions didn't handle it properly. The
      only likely consequence is an incorrect error indication.
    - Fix ecpg's parsing of "CREATE ROLE".
    - Fix recent breakage of pg_ctl restart.
  * 03-gettext-domains.patch: Unfuzz for new release.

 -- Martin Pitt <email address hidden> Tue, 04 Nov 2008 21:22:42 +0100

Changed in postgresql-8.2:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.3 - 8.3.5-0ubuntu0.8.04

---------------
postgresql-8.3 (8.3.5-0ubuntu0.8.04) hardy-proposed; urgency=low

  * New upstream bug fix release: (LP: #293758)
    - Fix GiST index corruption due to marking the wrong index entry
      "dead" after a deletion. This would result in index searches failing to
      find rows they should have found.
    - Fix backend crash when the client encoding cannot represent a
      localized error message.
    - Fix possible crash in bytea-to-XML mapping.
    - Fix possible crash when deeply nested functions are invoked from a
      trigger.
    - Improve optimization of "expression" IN ("expression-list") queries.
    - Fix mis-expansion of rule queries when a sub-SELECT appears in a
      function call in FROM, a multi-row VALUES list, or a RETURNING list.
    - Fix Assert failure during rescan of an IS NULL search of a GiST
      index.
    - Fix memory leak during rescan of a hashed aggregation plan.
    - Ensure an error is reported when a newly-defined PL/pgSQL trigger
      function is invoked as a normal function.
    - Force a checkpoint before "CREATE DATABASE" starts to copy files.
      This prevents a possible failure if files had recently been deleted
      in the source database.
    - Prevent possible collision of relfilenode numbers when moving a
      table to another tablespace with "ALTER SET TABLESPACE". The command
      tried to re-use the existing filename, instead of picking one that is
      known unused in the destination directory.
    - Fix incorrect text search headline generation when single query
      item matches first word of text.
    - Fix improper display of fractional seconds in interval values when
      using a non-ISO datestyle.
    - Make ILIKE compare characters case-insensitively even when they're
      escaped.
    - Ensure "DISCARD" is handled properly by statement logging.
    - Fix incorrect logging of last-completed-transaction time during
      PITR recovery.
    - Ensure SPI_getvalue and SPI_getbinval behave correctly when the
      passed tuple and tuple descriptor have different numbers of columns.
      This situation is normal when a table has had columns added or
      removed, but these two functions didn't handle it properly. The
      only likely consequence is an incorrect error indication.
    - Mark SessionReplicationRole as PGDLLIMPORT so it can be used by
      Slony on Windows.
    - Fix small memory leak when using libpq's gsslib parameter.
      The space used by the parameter string was not freed at connection
      close.
    - Ensure libgssapi is linked into libpq if needed.
    - Fix ecpg's parsing of "CREATE ROLE".
    - Fix recent breakage of pg_ctl restart.
  * 03-gettext-domains.patch: Unfuzz for new upstream version.
  * debian/control: Add explicit dependency to ssl-cert and locales, to ensure
    that those packages are configured before postgresql-8.3. Otherwise, the
    server fails to start up when they are unpacked while postgresql-8.3 is
    configured. (see LP #280135)

 -- Martin Pitt <email address hidden> Tue, 04 Nov 2008 20:38:23 +0100

Changed in postgresql-8.3:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postgresql-8.3 - 8.3.5-0ubuntu8.10

---------------
postgresql-8.3 (8.3.5-0ubuntu8.10) intrepid-proposed; urgency=low

  * New upstream bug fix release: (LP: #293758)
    - Fix GiST index corruption due to marking the wrong index entry
      "dead" after a deletion. This would result in index searches failing to
      find rows they should have found.
    - Fix backend crash when the client encoding cannot represent a
      localized error message.
    - Fix possible crash in bytea-to-XML mapping.
    - Fix possible crash when deeply nested functions are invoked from a
      trigger.
    - Improve optimization of "expression" IN ("expression-list") queries.
    - Fix mis-expansion of rule queries when a sub-SELECT appears in a
      function call in FROM, a multi-row VALUES list, or a RETURNING list.
    - Fix Assert failure during rescan of an IS NULL search of a GiST
      index.
    - Fix memory leak during rescan of a hashed aggregation plan.
    - Ensure an error is reported when a newly-defined PL/pgSQL trigger
      function is invoked as a normal function.
    - Force a checkpoint before "CREATE DATABASE" starts to copy files.
      This prevents a possible failure if files had recently been deleted
      in the source database.
    - Prevent possible collision of relfilenode numbers when moving a
      table to another tablespace with "ALTER SET TABLESPACE". The command
      tried to re-use the existing filename, instead of picking one that is
      known unused in the destination directory.
    - Fix incorrect text search headline generation when single query
      item matches first word of text.
    - Fix improper display of fractional seconds in interval values when
      using a non-ISO datestyle.
    - Make ILIKE compare characters case-insensitively even when they're
      escaped.
    - Ensure "DISCARD" is handled properly by statement logging.
    - Fix incorrect logging of last-completed-transaction time during
      PITR recovery.
    - Ensure SPI_getvalue and SPI_getbinval behave correctly when the
      passed tuple and tuple descriptor have different numbers of columns.
      This situation is normal when a table has had columns added or
      removed, but these two functions didn't handle it properly. The
      only likely consequence is an incorrect error indication.
    - Mark SessionReplicationRole as PGDLLIMPORT so it can be used by
      Slony on Windows.
    - Fix small memory leak when using libpq's gsslib parameter.
      The space used by the parameter string was not freed at connection
      close.
    - Ensure libgssapi is linked into libpq if needed.
    - Fix ecpg's parsing of "CREATE ROLE".
    - Fix recent breakage of pg_ctl restart.
  * 03-gettext-domains.patch: Unfuzz for new upstream version.

 -- Martin Pitt <email address hidden> Tue, 04 Nov 2008 20:32:37 +0100

Changed in postgresql-8.3:
status: Fix Committed → Fix Released
Leonel Nunez (leonelnunez) wrote :

Gutsy worked fine ..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers