postgresql-13/14: Fail to build against OpenSSL 3.0

Bug #1946013 reported by Simon Chopin
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postgresql-13 (Ubuntu)
Won't Fix
High
Christian Ehrhardt 
postgresql-14 (Ubuntu)
Fix Released
High
Christian Ehrhardt 

Bug Description

Hello,

As part of a rebuild against OpenSSL3, this package failed to build on one or
several architectures. You can find the details of the rebuild at

https://people.canonical.com/~schopin/rebuilds/openssl-3.0.0-impish.html

or for the amd64 failed build, directly at

https://launchpad.net/~schopin/+archive/ubuntu/openssl-3.0.0/+build/22099285/+files/buildlog_ubuntu-impish-amd64.postgresql-13_13.4-1.0~ssl3ppa1.1_BUILDING.txt.gz

We're planning to transition to OpenSSL 3.0 for the 22.04 release, and consider
this issue as blocking for this transition.

You can find general migration informations at
https://www.openssl.org/docs/manmaster/man7/migration_guide.html
For your tests, you can build against libssl-dev as found in the PPA
schopin/openssl-3.0.0

There are some upstream patches in the pg-13 branch that might fix the failure:
https://github.com/postgres/postgres/commit/a69e1506f618d4577bf7fdbfea51924a44c6e7de
https://github.com/postgres/postgres/commit/135d8687adf12a0d4cd7c94d1095ed5a7a08f7ed
https://github.com/postgres/postgres/commit/8e7199453bf9fe142f3f4a5e17010320c24867e7

Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

Thanks Simon,
Postgres has regular stable releases and PG14 will be too late for the PG-ecosystem to adapt in time for 22.04. So I'd hope that a coming postgresql-13 13.5 will resolve that as it is already in their branches. And since we do regular updates of those we would pick it up naturally.

I see since the last time I asked openssl3 is now in https://discourse.ubuntu.com/t/jj-release-schedule/23906 so I assume it will be in -proposed to build against it rather soon after opneing 22.04 then.

Thanks!

Changed in postgresql-13 (Ubuntu):
status: New → Triaged
importance: Undecided → High
Bryce Harrington (bryce)
tags: added: server-next
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

FYI there is a chance that this will be handled indirectly via Postgresql-14
See bug 1949579

Furthermore on Postgresql-13 there is soon an upcoming v13.5 which will include the reported commits.

We need to try-build both against the PPA at
https://launchpad.net/~schopin/+archive/ubuntu/openssl-3.0.0
to see how they behave.

If they work we can set this fixed for PG-14 and tag the bug in the coming new postgresql-13 upload.

Changed in postgresql-13 (Ubuntu):
assignee: nobody → Christian Ehrhardt  (paelzer)
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

I have confirmed here
=> https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/4709/+packages

that 13.5 and 14.1 build fine against openssl 3.0.
The transitions might take a while, but I'd say postgresql is ready for this.

Changed in postgresql-14 (Ubuntu):
status: New → Fix Committed
Changed in postgresql-13 (Ubuntu):
status: Triaged → Fix Committed
Changed in postgresql-14 (Ubuntu):
assignee: nobody → Christian Ehrhardt  (paelzer)
summary: - postgresql-13: Fail to build against OpenSSL 3.0
+ postgresql-13/14: Fail to build against OpenSSL 3.0
Revision history for this message
Simon Chopin (schopin) wrote : Re: [Bug 1946013] Re: postgresql-13: Fail to build against OpenSSL 3.0

Neat, thanks!

Changed in postgresql-14 (Ubuntu):
importance: Undecided → High
Revision history for this message
Christian Ehrhardt  (paelzer) wrote :

FYI 14.1 is in Jammy now, and while held up by the long tail of the PG-14 migration we can consider this done. 13.x isn't fixed (13.5 would be, but not uploaded) but suspect to be removed at the end of the PG transition.

Changed in postgresql-13 (Ubuntu):
status: Fix Committed → Won't Fix
Changed in postgresql-14 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers