postconf can't open main.cf with the result that /etc/resolvconf/update-libc.d/postfix fails trying to copy /etc/resolv.conf onto itself

Bug #980682 reported by NoCarrier
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
postfix (Ubuntu)
Medium
LaMont Jones
Precise
Medium
LaMont Jones

Bug Description

Dont know what happened, it just crasched

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: bind9 1:9.8.1.dfsg.P1-3
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Date: Fri Apr 13 12:22:38 2012
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
RelatedPackageVersions:
 bind9utils 1:9.8.1.dfsg.P1-3
 apparmor 2.7.102-0ubuntu3
SourcePackage: bind9
Title: package bind9 1:9.8.1.dfsg.P1-3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
NoCarrier (thomas-nocarrier) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bind9 (Ubuntu):
status: New → Confirmed
Revision history for this message
Dario Bertini (berdario) wrote :

I got this as well, now apt and dpkg are completely unusable, I attached my last terminal session in which I tried to uninstall bind9 to get rid of the problem

Revision history for this message
Thomas Hood (jdthood) wrote :

It is postfix's resolvconf-hook-script (/etc/resolvconf/update-libc.d/postfix) which causes the failure. See also #437783.

affects: bind9 (Ubuntu) → postfix (Ubuntu)
Thomas Hood (jdthood)
summary: - package bind9 1:9.8.1.dfsg.P1-3 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ postconf can't open main.cf with the result that /etc/resolvconf/update-
+ libc.d/postfix fails trying to copy /etc/resolv.conf onto itself
Revision history for this message
LaMont Jones (lamont) wrote :

Bad code from 2007, I believe that simply making sure that the queue directory is non-null before copying will fix it.

Changed in postfix (Ubuntu):
assignee: nobody → LaMont Jones (lamont)
status: Confirmed → Fix Committed
James Page (james-page)
Changed in postfix (Ubuntu):
importance: Undecided → Medium
Revision history for this message
LaMont Jones (lamont) wrote :

Fixed in 2.9.1-5

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Hello NoCarrier, or anyone else affected,

Accepted postfix into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Steve Langasek (vorlon) wrote :

I've confirmed this fix here. Prior to upgrade, /var/log/upstart/resolvconf.log showed this error. After upgrade, the error is no longer happening.

Revision history for this message
Steve Langasek (vorlon) wrote :

(the error was reproducible for me because /usr is on a separate partition)

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postfix - 2.9.1-5

---------------
postfix (2.9.1-5) unstable; urgency=low

  [LaMont Jones]

  * do not try to copy /etc/resolv.conf onto itself. LP: #980682

  [localization folks]

  * l10n: updated Turkish debconf. Closes: #669095 (Atila KOÇ)
 -- LaMont Jones <email address hidden> Mon, 23 Apr 2012 05:33:41 -0600

Changed in postfix (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in postfix (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers