Postfix SASL authentication does not work with Dovecot SASL in default configuration

Bug #493667 reported by Michael Marley on 2009-12-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postfix (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: postfix

I am attempting to set up Postfix with SASL authentication on a server with 9.10. I have installed the dovecot-postfix package, and both incoming and outgoing email work. However, I cannot get SASL authentication to work. The /etc/postfix/main.cf file shows that Dovecot SASL authentication should be enabled, but when I telnet in and do a "ehlo", this is all I get:

michael@mamarley-laptop:~$ telnet mail.michaelmarley.com 25
Trying 66.26.248.238...
Connected to thefirstm.dyndns.org.
Escape character is '^]'.
220 michaelmarley.com ESMTP Postfix (Ubuntu)
ehlo michaelmarley.com
250-michaelmarley.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN

Nothing about "AUTH" appears, and sending the "AUTH" command results in:

503 5.5.1 Error: authentication not enabled

Other than this error, there is no other indication of the failure in any of the logs. I have posted my /etc/postfix/main.cf file. If you need any others, please tell me.

Revision history for this message
Michael Marley (mamarley) wrote :
Revision history for this message
Scott Kitterman (kitterman) wrote :

smtpd_tls_auth_only = yes means it will only offer auth if you connect vial TLS (which you aren't doing when you telnet) so it is correct to not offer it.

Changed in postfix (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments