postfix update-libc.d script tries to copy resolv.conf onto itself. This is also a link target for many duplicates of an unrelated bug: bind9 failed to start : resolvconf: Error: /etc/resolv.conf must be a symlink.

Bug #437783 reported by Philip Muškovac on 2009-09-27
168
This bug affects 28 people
Affects Status Importance Assigned to Milestone
bind9 (Ubuntu)
Medium
Unassigned
postfix (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: bind9

Setting up bind9 (1:9.6.1.dfsg.P1-3) ...
 * Stopping domain name service... bind9 [ OK ]
 * Starting domain name service... bind9 /usr/sbin/postconf: fatal: open /etc/postfix/main.cf: No such file or directory
cp: `/etc/resolv.conf' and `/etc/resolv.conf' are the same file
run-parts: /etc/resolvconf/update-libc.d/postfix exited with return code 1
run-parts: /etc/resolvconf/update.d/libc exited with return code 1
invoke-rc.d: initscript bind9, action "restart" failed.

After that it just stopped here, so I had to interrupt the process to continue.

ProblemType: Package
AptOrdering:
 bind9utils: Install
 bind9: Install
 bind9utils: Configure
 bind9: Configure
Architecture: amd64
Date: Sun Sep 27 21:07:06 2009
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script killed by signal (Interrupt)
NonfreeKernelModules: nvidia
Package: bind9 1:9.6.1.dfsg.P1-3
SourcePackage: bind9
Title: package bind9 1:9.6.1.dfsg.P1-3 [modified: usr/share/bind9/bind9-default.md5sum] failed to install/upgrade: subprocess installed post-installation script killed by signal (Interrupt)
Uname: Linux 2.6.30-02063003-generic x86_64

Philip Muškovac (yofel) wrote :
Chuck Short (zulcss) wrote :

Relevant error:

#

 * Starting domain name service... bind9  resolvconf: Error: /etc/resolv.conf must be a symlink

invoke-rc.d: initscript bind9, action "start" failed.

I was wondering if you were still having this problem?

Regards
chuck

Changed in bind9 (Ubuntu):
status: New → Incomplete
Philip Muškovac (yofel) wrote :

Yes, if resolv.conf is not a symlink then bind9 still refuses to start. And if I make resolv.conf a symlink then postfix barfes on the bind9 start. Right now I have resolv.conf as a symlink and removed the cp instruction from the postfix file so that bind9 works fine for me right now.

Changed in bind9 (Ubuntu):
status: Incomplete → New
Chuck Short (zulcss) on 2009-10-09
Changed in bind9 (Ubuntu):
importance: Undecided → Low
status: New → Triaged

Same error as bug #423653 ?

Philip Muškovac (yofel) wrote :

Yes, the postfix issue is indeed the same as in bug 423653 and copying main.cf[.debian] fixes it, but the main issue here that bin9 requires resolv.conf to be a symlink remaines.

LaMont Jones (lamont) wrote :

actually, it's resolvconf that's requiring it to be a symlink, I suspect - bind9 doesn't actually use resolv.conf

Jeffrey Baker (jwbaker) wrote :

Yeah, the problem here is that resolvconf and bind9 can't be installed in the same dpkg run. They install separately, but not together. Resolvconf 1.45ubuntu1 and bind9 1:9.7.0.dfsg.P1-1 on lucid.

tags: added: lucid
summary: - package bind9 1:9.6.1.dfsg.P1-3 [modified:
- usr/share/bind9/bind9-default.md5sum] failed to install/upgrade:
- subprocess installed post-installation script killed by signal
- (Interrupt)
+ bind9 failed to start : resolvconf: Error: /etc/resolv.conf must be a
+ symlink

With 19 people marking this as affecting them, and quite a few duplicates, I think this is worthy of raising the importance to Medium.

Changed in bind9 (Ubuntu):
importance: Low → Medium
LaMont Jones (lamont) wrote :

This sounds like 933723 will fix it.

Thomas Hood (jdthood) wrote :

The original problem was postconf failing to open main.cf and /etc/resolvconf/update-libc.d/postfix trying to copy /etc/resolv.conf onto itself at the line

    cp /etc/resolv.conf $(/usr/sbin/postconf -h queue_directory)/etc/resolv.conf

because "postconf -h queue_directory" returns a null string. The bug is still present in postfix 2.9.1-2 and has nothing to do with "resolvconf: Error: /etc/resolv.conf must be a symlink" which all the duplicates, except #511314, *do* involve.

Somehow or other this report, #437783, or a clone of it, should be detached from all the duplicates and assigned to postfix.

Thomas Hood (jdthood) wrote :

Now to address the bug which all the *duplicates*, except #511314 and #437783, are about, namely, that installing bind9 aborts with "resolvconf: Error: /etc/resolv.conf must be a symlink".

First, resolvconf in Precise no longer returns an error condition if /etc/resolv.conf is not a symlink, so the bind9 initscript will not abort any more once resolvconf has been upgraded.

Second, bind9 in Precise no longer defaults to registering 127.0.0.1 with resolvconf on start, so the new bind9 initscript will not abort.

I fear, however, that failures will still occur on upgrade when the bind9 preinst stops bind9 and neither bind9 nor resolvconf has been upgraded yet.

Thomas Hood (jdthood) wrote :

I said:
> Second, bind9 in Precise no longer defaults to registering 127.0.0.1 with resolvconf on start

This is not quite correct. LaMont Jones wrote on 2012-02-17 in #933723 "The next upload of bind9 will default to not enabling resolvconf" but this upload hasn't happened yet.

James Page (james-page) wrote :

1:9.8.1.dfsg.P1-3 contains this fix but has not been synced to precise.

Might be a late candidate pre-final freeze - I'll try to catch LaMont to discuss.

James Page (james-page) on 2012-04-12
Changed in postfix (Ubuntu):
importance: Undecided → Medium
Thomas Hood (jdthood) wrote :

Precise now has bind9 1:9.8.1.dfsg.P1-4 so bug #920061 et al (re: "/etc/resolv.conf must be a symlink") may now have been fixed.

As I mentioned earlier (in #10), *this* report, #437783, originally reported a distinct bug, namely that of postconf failing to open main.cf and consequently /etc/resolvconf/update-libc.d/postfix trying to copy /etc/resolv.conf onto itself. The bug is still present in postfix 2.9.1-4.

summary: - bind9 failed to start : resolvconf: Error: /etc/resolv.conf must be a
- symlink
+ postfix update-libc.d script tries to copy resolv.conf onto itself.
+ Also link target for many duplicates of an unrelated bug: bind9 failed
+ to start : resolvconf: Error: /etc/resolv.conf must be a symlink.
Changed in bind9 (Ubuntu):
status: Triaged → Fix Released
Changed in postfix (Ubuntu):
status: New → Confirmed
summary: postfix update-libc.d script tries to copy resolv.conf onto itself.
- Also link target for many duplicates of an unrelated bug: bind9 failed
- to start : resolvconf: Error: /etc/resolv.conf must be a symlink.
+ This is also a link target for many duplicates of an unrelated bug:
+ bind9 failed to start : resolvconf: Error: /etc/resolv.conf must be a
+ symlink.
Thomas Hood (jdthood) wrote :

The failure originally reported here has been reported again at #980682 so #980682 can be used to track the bug in postfix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions