After upgrading postfix in dapper, it no longer starts

Bug #29661 reported by Steve Peters on 2006-01-25
6
Affects Status Importance Assigned to Milestone
postfix (Ubuntu)
Medium
Unassigned

Bug Description

After the most recent update to postfix in Dapper, postfix will not start. In /var/log/mail.err, I see the following error message. I've not made any changes to /etc/postfix/master.cf, or other network configuration, so I'm suspecting the upgrade.

Jan 25 09:26:18 localhost postfix/master[8176]: fatal: /etc/postfix/master.cf: line 18: no valid IP address found: smtp

Revision history for this message
LaMont Jones (lamont) wrote :

I cannot reproduce this issue on any of my machines. What architecture is the machine, and what verison of postfix do you have?

Changed in postfix:
status: Unconfirmed → Needs Info
Revision history for this message
Steve Peters (steve-fisharerojo) wrote : Re: [Bug 29661] After upgrading postfix in dapper, it no longer starts

On Thu, Jan 26, 2006 at 04:31:07PM -0000, LaMont Jones wrote:
> Public bug report changed:
> https://launchpad.net/malone/bugs/29661
>
> Task: ubuntu postfix
> Status: Unconfirmed => Needs Info
>
> Comment:
> I cannot reproduce this issue on any of my machines. What architecture
> is the machine, and what verison of postfix do you have?

steve@kirk:~$ uname -a
Linux kirk 2.6.15-13-386 #1 PREEMPT Thu Jan 19 16:24:40 UTC 2006 i686 GNU/Linux
steve@kirk:~$ dpkg -l postfix
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii postfix 2.2.8-6 A high-performance mail transport agent

Revision history for this message
claes (claes-backstrom) wrote :

I have the exact same problem. I use network-manager to handle my ip configuration. It might be that? I tried to start postfix after network-manager have configured my interface but still the same problem.

Revision history for this message
claes (claes-backstrom) wrote :

I have solved my problem.
By some reason my loopback device didn't come up. I had 2 lines in my /etc/network/interfaces reading: "auto eth1" and that stopped the loopback device from working. I removed one of the lines started lo with: sudo ifup lo and it come up. Restarted postfix and everything worked. Not sure why I had 2 lines with auto eth1. But now it seems to work as it should.

Revision history for this message
Steve Peters (steve-fisharerojo) wrote :

OK, that must have been what fixed it for me too then. In my /etc/networking/interfaces I saw:

auto eth0 lo
...
auto eth0

I commented out the second one, but it did not seem to have a direct effect. I upgraded ifupdown, rebooted, and everything was working again. I'll go with your explanation that the "auto eth0" in /etc/networking/interfaces is the problem

Changed in postfix:
status: Needs Info → Confirmed
Revision history for this message
Steve Peters (steve-fisharerojo) wrote :

The fixes to /etc/networking/interfaces fixed my problems.

Changed in postfix:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers