postfix-doc postinst fails if no /etc/postfix/main.cf is on the system

Bug #203849 reported by Michael Vogt on 2008-03-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
postfix (Ubuntu)
High
Michael Vogt

Bug Description

Binary package hint: postfix

During a upgrade test from dapper->hardy the following problem occurred:

[71.4563] postfix: Configuring postfix
Postfix was not set up. Start with ^M
  cp /usr/share/postfix/main.cf.debian /etc/postfix/main.cf^M
. If you need to make changes, edit^M
/etc/postfix/main.cf (and others) as needed. To view Postfix configuration^M
values, see postconf(1).^M
^M
After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.^M
^M
in master.cf:^M
  adding missing entry for retry service^M
[71.4609] postfix: Installed postfix
...
[85.7169] postfix-doc: Configuring postfix-doc
postconf: fatal: open /etc/postfix/main.cf for reading: No such file or directory^M
dpkg: error processing postfix-doc (--configure):^M
 subprocess post-installation script returned error exit status 1^M

Debug output of the failed script:
+ set -e
+ [ -x /usr/sbin/postconf ]
+ postconf -e readme_directory=/usr/share/doc/postfix html_directory=/usr/share/doc/postfix/html
postconf: fatal: open /etc/postfix/main.cf for reading: No such file or directory
['/bin/sh', '-ex', '/var/lib/dpkg/info//postfix-doc.postinst', 'configure', '2.2.10-1ubuntu0.1']

Michael Vogt (mvo) wrote :

This seems to be somewhat difficult to reproduce, but it looks like its dependant on the unpack/configure order that apt is selecting. postfix copies the file in place in the postinst. If both are unapcked and the postinst of postfix-doc is run before the one postfix then this error can happen (that is my current theory :)

Michael Vogt (mvo) wrote :
Changed in postfix:
assignee: nobody → mvo
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postfix - 2.5.1-1ubuntu1

---------------
postfix (2.5.1-1ubuntu1) hardy; urgency=low

  * postfix-doc.postinst:
    - run postconf only if there is a main.cf available (LP: #203849)
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Michael Vogt <email address hidden> Wed, 19 Mar 2008 10:32:44 +0100

Changed in postfix:
status: In Progress → Fix Released

I'm a newbie and did a clean install on HH 8.04 server, with desktop loaded on top (for gui interface) and I'm trying to see a windows computer, unsuccessfully so far. Can I ignore this error? This is what I get back

kenneth@ubuntu:~$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces... RTNETLINK answers: No such process
postconf: fatal: open /etc/postfix/main.cf: No such file or directory
SIOCDELRT: No such process
postconf: fatal: open /etc/postfix/main.cf: No such file or directory

any help is greatly appreciated

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers