postfix package produces errors in ubuntu-bug

Bug #1222180 reported by Daniel Barrett
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
postfix (Ubuntu)
Medium
Unassigned
Saucy
Medium
Unassigned

Bug Description

$ ubuntu-bug postfix
ERROR: hook /usr/share/apport/package-hooks/postfix.py crashed:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport/report.py", line 197, in _run_hook
    symb['add_info'](report, ui)
  File "/usr/share/apport/package-hooks/postfix.py", line 50, in add_info
    for k,v in extra_info.iteritems():
AttributeError: 'dict' object has no attribute 'iteritems'

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: postfix 2.10.0-3
ProcVersionSignature: Ubuntu 3.8.0-30.44-generic 3.8.13.6
Uname: Linux 3.8.0-30-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
Date: Sat Sep 7 11:27:09 2013
InstallationDate: Installed on 2013-08-31 (6 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: postfix
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Daniel Barrett (dbarrett-m) wrote :
Revision history for this message
Scott Kitterman (kitterman) wrote :

Caused by the switch to python3. "2to3-3.3 -w postfix.apport" in the relevant directory will fix this.

Changed in postfix (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
milestone: none → ubuntu-13.10
Revision history for this message
LaMont Jones (lamont) wrote :

Fixed in 2.10.2-1

Changed in postfix (Ubuntu Saucy):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package postfix - 2.10.2-1

---------------
postfix (2.10.2-1) unstable; urgency=low

  [Wietse Venema]

  * New upstream release

  [LaMont Jones]

  * drop bad diffs from review
  * python 2to3 migration for apport. LP: #1222180

 -- LaMont Jones <email address hidden> Sun, 08 Sep 2013 19:24:46 -0600

Changed in postfix (Ubuntu Saucy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers