Ubuntu

package portmap 6.0.0-1ubuntu1 failed to install/upgrade:

Reported by Noel J. Bergman on 2010-01-05
104
This bug affects 15 people
Affects Status Importance Assigned to Milestone
portmap (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: portmap

During Hardy -> Lucid updates ...

ProblemType: Package
Architecture: amd64
Date: Tue Jan 5 00:49:41 2010
DistroRelease: Ubuntu 10.04
ErrorMessage:
 ErrorMessage: subprocess installed post-installation script returned error exit status 1
Package: portmap 6.0.0-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: portmap
Tags: lucid
Title: package portmap 6.0.0-1ubuntu1 failed to install/upgrade:
Uname: Linux 2.6.31-16-generic x86_64

Noel J. Bergman (noeljb) wrote :
Steve Langasek (vorlon) wrote :

The error in the logs is:

Setting up portmap (6.0.0-1ubuntu1) ...
portmap start/running, process 22762
There are RPC services which were registered with the portmapper
before the configuration was changed.
You need to manually restart them in order for the changes to take effect.
Current registered services:
------------------------------------------------
dpkg: error processing portmap (--configure):
 subprocess installed post-installation script returned error exit status 1

So the first call to rpcinfo in the postinst apparently returned something of interest, and the second call failed.

Could you run the following command and paste the output?:

$ rpcinfo -p 2>/dev/null | grep "tcp\|udp" | grep -v portmapper

Changed in portmap (Ubuntu):
status: New → Confirmed
Steve Langasek (vorlon) on 2010-01-05
Changed in portmap (Ubuntu):
importance: Undecided → High
Björn Tillenius (bjornt) wrote :

My rpcinfo -p output can be found in bug 545083.

Jean-Baptiste Lallement (jibel) wrote :

From 545083
----
I got this error when upgrading from karmic to lucid.

rpcinfo -p gives this output:

   program vers proto port
    100000 2 tcp 111 portmapper
    100000 2 udp 111 portmapper
    100024 1 udp 47160 status
    100024 1 tcp 33268 status

tags: added: dist-upgrade
Richard Sellam (richard-sellam) wrote :

I have the same error upgrading from lucid to maverick (6.0.0-2ubuntu1.1).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers