popt download location broken

Bug #1838436 reported by Andreas Baumann
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
popt (Debian)
Fix Released
Unknown
popt (Ubuntu)
Low
Unassigned

Bug Description

rpm5.org disappeared, with download area, home page and CVS repo.

See also https://bugs.archlinux.org/task/62888?project=1&string=popt

Revision history for this message
Bryce Harrington (bryce) wrote :

Debian sees the problem too, at least since mid-June:

    http://duck.debian.net/static/sp/p/popt.html

    https://tracker.debian.org/pkg/popt

The domain name is still registered, through next year:

    https://whois.gandi.net/en/results?search=rpm5.org

From debian/changelog, looks like the last major release, 1.16, was back in 2010.

The project's devel mailing list had discussion activity within the last couple years, but not very much, and nothing to explain what's going on.:

    https://<email address hidden>/maillist.html

It looks like the problem isn't merely a stale link, but that the activity level of the upstream project has dropped - unfortunately not something really addressable at the distro level. Depending on what you need from the upstream website, you might try reaching out to individuals from that mailing list discussion.

Are you spotting any secondary issues being caused by the offline rpm5.org website, within Ubuntu or the Ubuntu project infrastructure? If there isn't, then I think since Ubuntu has been simply syncing this package from Debian, I think we just follow their lead on what to do packaging-wise.

Changed in popt (Ubuntu):
status: New → Incomplete
Revision history for this message
Andreas Baumann (andreasbaumann) wrote :

For Archlinux32 I decided to go via the Debian link for now:

https://git.archlinux32.org/archlinux32/packages/src/branch/master/core/popt/PKGBUILD

source=("${pkgname}-${pkgver}.tar.gz::https://deb.debian.org/debian/pool/main/p/${pkgname}/${pkgname}_${pkgver}.orig.tar.gz")

Revision history for this message
Paride Legovini (paride) wrote :

I filed a bug in Debian. FIY the original source code is also available via Git here:

  https://salsa.debian.org/debian/popt/

in the upstream/latest branch.

Changed in popt (Ubuntu):
importance: Undecided → Low
status: Incomplete → Triaged
Changed in popt (Debian):
status: Unknown → New
Changed in popt (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.