some pages display blank with pdf from Rite in the Rain

Bug #817626 reported by Brian Murray
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Poppler
Fix Released
Medium
poppler (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

I was trying to view the pdf linked to from http://www.riteintherain.com/ItemForm.aspx?item=512&Category=44524971-e812-49fe-9335-29d84920693b only to discover that most of the pages appear as blank pages or take a long time to load. They are viewable in acroread without any problems.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: libpoppler13 0.16.7-2ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-6.7-generic 3.0.0-rc7
Uname: Linux 3.0.0-6-generic x86_64
Architecture: amd64
CheckboxSubmission: fee5e196cb921cbd36888f428b38b488
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Thu Jul 28 09:43:24 2011
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: poppler
UpgradeStatus: Upgraded to oneiric on 2011-07-27 (1 days ago)

Revision history for this message
Brian Murray (brian-murray) wrote :
Revision history for this message
Brian Murray (brian-murray) wrote :

Here is the pdf in case it disappears.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugs.freedesktop.org/show_bug.cgi?id=39637

Changed in poppler (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in poppler:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in poppler:
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

The bug was fixed in that commit in the unstable serie of poppler:
http://cgit.freedesktop.org/poppler/poppler/commit/?id=378fc06c574b85b5c003ca842aa743f0ffe5587e

Changed in poppler (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Sebastien Bacher (seb128) wrote :

The commit should probably apply to the stable serie and could be backported to oneiric if somebody wants to work on that

Revision history for this message
madbiologist (me-again) wrote :

The fix referred to above is included in the upstream release of Poppler 0.17.2 (0.18 Beta 2).

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poppler - 0.18.2-0ubuntu1

---------------
poppler (0.18.2-0ubuntu1) precise; urgency=low

  * New upstream version, bugs fixed in the new version (lp: #869850):
    - lines and graphics wrongly rendered (lp: #603929) (lp: #780169)
    - rendering issues on some documents (lp: #784154)
    - some pages are displayed blank (lp: #817626)
  * debian/control, debian/rules:
    - updated for the libpoppler and libpoppler-glib soname changes
  * drop patches included in the new version
  * debian/libpoppler-glib-dev.install:
    - drop deprecated test-poppler-glib
  * debian/rules:
    - drop deprecated qt3 and abiword configure options
 -- Sebastien Bacher <email address hidden> Mon, 05 Dec 2011 17:23:02 +0100

Changed in poppler (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

it seems unlikely that the new version can be backported to oneiric and there has not been lot of demand for individual bug fixes, closing as wontfix in oneiric, the issue is fixed in precise though

Changed in poppler (Ubuntu Oneiric):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.