konqueror hangs forever when opening pdf (nondeterministic)

Bug #74653 reported by Georg Sauthoff on 2006-12-06
4
Affects Status Importance Assigned to Milestone
KDE Base
Invalid
Medium
kdegraphics (Ubuntu)
Undecided
Richard Johnson
poppler (Ubuntu)
Low
Richard Johnson

Bug Description

Binary package hint: konqueror

Hi,

I am using kubuntu edgy edge (6.10). I observed that konqueror hangs forever (no screen updates, no user input possible) when I click on a pdf file.

Normally when I click on a pdf file, it is displayed inside konqueror (via the kpdf kpart).

This issue is not deterministic reproducible. I.e. it is not observable at every pdf file and it is hard to reproduce.

This time the konqueror process was runnung a long time (>10 days including suspend-to-ram periods) and I have opened > 15 tabs).

An attached strace shows me only:
futex(0x85e39dc, FUTEX_WAIT, 2, NULL <unfinished ...>

I made a short and a full gdb backtrace (with -dbg packages installed). I will try to attach the short backtrace log to this bug - if you need the full backtrace, I can send it, too.

Also, I have a manually generated core file available - thus, I am able to issue some gdb commands to it.

Best regards

Georg Sauthoff (g-sauthoff) wrote :

gdb commands: attach, info threads, bt, detach

Georg Sauthoff (g-sauthoff) wrote :

I observed another konqueror freeze/hang while clicking on a pdf link from a web page.

This time the konqueror process was running ~2h and only 2 tabs were open.

A gdb backtrace is attached.

Georg Sauthoff (g-sauthoff) wrote :

I reported it at the kde bug tracker, too. It looks like the problem is specific to (K)ubuntu, because Ubuntu uses a patched kpdf - which uses libpoppler. And the kpdf kpart hangs in libpoppler.

This wrote Pino Toscano as a comment:
http://bugs.kde.org/show_bug.cgi?id=139877#c3

Ok, how do I annotate this bug report, that it affects kpdf and libpoppler?

upstream says this crash is in poppler.

to attach, hit "also effects...upstream" and enter the URL.

Changed in kdebase:
status: Unknown → Unconfirmed
Changed in kdebase:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

Could you try if the issue is still there on gutsy or hardy?

Changed in poppler:
importance: Undecided → Low
status: New → Incomplete
Richard Johnson (nixternal) wrote :

I am fix releasing this since I cannot recreate the issue at all with KDE 3.5.8, KDE 3.5.9, nor KDE 4.0.1, and also due to the fact that the reporter hasn't responded. Thanks!

Changed in kdegraphics:
assignee: nobody → nixternal
status: New → Fix Released
Changed in poppler:
assignee: nobody → nixternal
status: Incomplete → Fix Released
Changed in kdebase:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.