Evince doesn't open PDF file (3D model) exported by SolidWorks 2009 with 3D option enabled.

Bug #501284 reported by chricco on 2009-12-29
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
poppler (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

1) Ubuntu 9.10
2) Document Viewer 2.28.1
3) I need to view a 3D model in the PDF file. With Adobe acrobat reader 8, I can view (rotate, zoom, etc.) the model.
4) Evince show a box contains the message "Enable 3D View"

ProblemType: Bug
Architecture: amd64
Date: Tue Dec 29 12:37:40 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.28.1-0ubuntu1.2
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: evince
Uname: Linux 2.6.31-16-generic x86_64

chricco (chricco) wrote :
madbiologist (me-again) wrote :

With Adobe Acrobat Reader 5 I also see the box containing the message "Enable 3D View". According to http://en.wikipedia.org/wiki/PDF , Acrobat Reader 5 only supports version 1.4 of the PDF standard. I believe that poppler (use by Evince to render PDF's) only suppors version 1.5 of the PDF standard (and possibly parts of version 1.6). Support for embedded 3D drawings was introduced in version 1.6 of the PDF standard.

The latest poppler package currently available in Karmic Koala 9.10 is 0.12.0-0ubuntu2.1. The current development version of the upcoming Lucid Lynx 10.04 currently contains poppler 0.12.2-2.1ubuntu3. Hopefully it will pick up poppler 0.12.3 (released Dec 24, 2009), once it reaches Debian-testing. You can follow this at https://launchpad.net/ubuntu/+source/poppler

madbiologist (me-again) wrote :

Hmm, according to pdfinfo, your file is PDF version 1.4. Nevertheless, I think embedded 3D drawings are from a later PDF version which the poppler version in Karmic 9.10 does not support.

Typing "evince Telaio_2.PDF" at the command prompt (without the quotes) gives:

** (evince:2100): WARNING **: Unimplemented annotation: POPPLER_ANNOT_3D, please post a bug report in Evince bugzilla (http://bugzilla.gnome.org) with a testcase.

affects: evince (Ubuntu) → poppler (Ubuntu)
Brian Murray (brian-murray) wrote :

Looking at the attachments in this bug report, I noticed that "Telaio_2.PDF" was flagged as a patch. A patch contains changes to an Ubuntu package that will resolve a bug, since this was not one I've unchecked the patch flag for it. In the future keep in mind the definition of a patch. You can learn more about what qualifies as a patch at https://wiki.ubuntu.com/Bugs/Patches. Thanks!

madbiologist (me-again) wrote :

Same behaviour as comment #3 with Lucid Lynx 10.04 alpha 2 updated to poppler 0.12.3-0ubuntu1.

madbiologist (me-again) on 2010-02-17
Changed in poppler (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

As said by a commenter , the bug needs to be filed upstream.

Changed in poppler (Ubuntu):
importance: Undecided → Low
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
chricco (chricco) wrote :

I'm sorry for 'mistake, I was wrong to attach the file.
I have not "patch" to attach.
How can I correct the bug report?

Sorry for the inconvenience.

madbiologist (me-again) wrote :

Still occurring on Ubuntu 10.10 alpha 2 updated to the latest versions of poppler and Evince.

Uname: Linux 2.6.35-6-generic i686
Packages:
    evince 2.30.3-1ubuntu2
    poppler 0.14.1-0ubuntu1

phil (fongpwf) wrote :

Has anyone filed the upstream bug?
A quick search reveals two possible ones:
https://bugzilla.gnome.org/show_bug.cgi?id=514312
https://bugzilla.gnome.org/show_bug.cgi?id=642521

summary: - Evince don't open PDF file (3D model) exported by SolidWorks 2009 with
- 3D option enabled.
+ Evince doesn't open PDF file (3D model) exported by SolidWorks 2009
+ with 3D option enabled.
madbiologist (me-again) wrote :

Still occurring on Ubuntu 12.04 "Precise Pangolin" beta 1.

Packages: evince 3.3.90-0ubuntu2
                   libpoppler19 0.18.4-1ubuntu1

According to http://en.wikipedia.org/wiki/Universal_3D , the 3D content in PDFs is U3D. The specification seem to be available for everyone.

madbiologist (me-again) wrote :

Still occurring on Ubuntu 13.04 "Raring Ringtail".

Packages: evince 3.6.1-1ubuntu3
          libpoppler28 0.20.5-1ubuntu3

madbiologist (me-again) wrote :

This is still occurring on Ubuntu 14.04 "Trusty Tahr".

evince 3.10.3-0ubuntu10
poppler 0.24.5-2ubuntu4

tags: added: karmic maverick precise raring trusty
madbiologist (me-again) wrote :

Still occurring on Ubuntu 16.04 "Xenial Xerus".

evince 3.18.2-1ubuntu4
poppler 0.41.0-0ubuntu1.1

tags: added: xenial
madbiologist (me-again) wrote :

Still occurring on Ubuntu 18.04 "Bionic Beaver".

evince 3.28.4-0ubuntu1
poppler 0.57.0-2ubuntu5

tags: added: bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.