pdftopdf crashes

Bug #488752 reported by Olivier Blanc on 2009-11-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Poppler
Invalid
Undecided
Unassigned
poppler (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: cups

Ubuntu Release : Ubuntu lucid (development branch)
Release: 10.04

 apt-cache policy cups
cups:
  Installé : 1.4.2-1git1
  Candidat : 1.4.2-1git1
 Table de version :
 *** 1.4.2-1git1 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

pdftopdf crashes with the following error :
$ ./pdftopdf
./pdftopdf: symbol lookup error: ./pdftopdf: undefined symbol: _ZN13GfxColorSpace5parseEP6Object

Related branches

Anton Anikin (anton-anikin) wrote :

I have the same problem!
Can't print onany printer now, always get this error in cups error_log

Changed in cups (Ubuntu):
status: New → Confirmed
Anton Anikin (anton-anikin) wrote :

It seems I have got this problem after last update of libpoppler5 and poppler-utils

Anton Anikin (anton-anikin) wrote :

I can confirm this now,
I have downgraded to libpoppler5_0.12.0-0ubuntu2_amd64.deb and problem gone.
I think this bug should be moved to the poppler package https://bugs.launchpad.net/ubuntu/+source/poppler/+bugs?field.status:list=NEW

Changed in poppler:
status: New → Confirmed
affects: cups (Ubuntu) → ubuntu
affects: ubuntu → poppler (Ubuntu)
knarf (launchpad-ubuntu-f) wrote :

<mode profile="AOL">Me Too!</mode>

Demangled the missing function is GfxColorSpace::parse(Object*, Gfx*)

This seems to have been introduced by this patch: http://lists.freedesktop.org/archives/poppler/2009-October/005198.html

knarf (launchpad-ubuntu-f) wrote :

This is not a bug in poppler. It is a bug in pdftopdf as bundled with cups. Currently cups can not be compiled with the latest libpoppler because the interface to iccColorSpaceCache (in libpoppler) has changed as can be seen in the patch linked to above.

Sebastien Bacher (seb128) wrote :

Thank you for looking at the issue, there was no need to open a new bug though you could have reassigned this one to cups, closing the bug since that's not a poppler bug, upstream only enforce stable abi for the glib library not the base one...

Changed in poppler:
status: Confirmed → Invalid
Changed in poppler (Ubuntu):
importance: Undecided → Low
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers