PDF form fields are not displayed

Bug #458459 reported by Nicola Jelmorini on 2009-10-22
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
poppler (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: evince

I attach to this bug report three files:
1) Kuendigungsvorlage_an_Kabelnetzunternehmen_it.pdf ==> original PDF document with form fields
2) PDF_form_displayed_with_Acrobat_Windows.png ==> screen-shot of the PDF opened in Acrobat under Windows XP
3) PDF_form_displayed_with_Evince_Ubuntu_9.04.png ==> scree-shot of the PDF opened with Evince under Ubuntu 9.04

The problem is clear watching the two screen-shots: with Evince no fields are displayed.
I have tried to open the same PDF under Ubuntu 9.10, but the result is the same.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: evince 2.26.1-0ubuntu1
ProcEnviron:
 LANG=it_CH.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux 2.6.28-15-generic x86_64

Nicola Jelmorini (jelmorini) wrote :
Chris Schoonbee (cmschoonbee) wrote :

Marking as confirmed. In fact when I view the pdf attachment using Evince 2.28.1 on Karmic I see even less than the 9.04 screenshot attached . All I see is a blank grey button. The odd thing is that if I select all the text, (Ctrl-A), the text areas are highlighted and I can copy the text into say gedit.

I have a similar problem with a simpler PDF which I attach. Acroread 9 displays the file just fine.

Changed in evince (Ubuntu):
status: New → Confirmed
Changed in evince (Ubuntu):
importance: Undecided → Low
affects: evince (Ubuntu) → poppler (Ubuntu)
madbiologist (me-again) wrote :

The field are there and can be typed into. They are just not highlighted, which make thing very awkward and confusing for the user.

Nicola Jelmorini (jelmorini) wrote :

I have installed the new Ubuntu 10.04 LTS and tried again to open with Evince the pdf document I have attached here, but the problem is still present. The form fields are displayed only if I select all the content of the PDF.

madbiologist (me-again) wrote :

Still occurring on Ubuntu 10.10 alpha 2 updated to the latest versions of poppler and Evince. However the attachment in comment #4 looks OK now.

Uname: Linux 2.6.35-6-generic i686
Packages:
    evince 2.30.3-1ubuntu2
    poppler 0.14.1-0ubuntu1

madbiologist (me-again) wrote :

This is still occurring on Ubuntu 12.04 "Precise Pangolin" beta 1.

Packages: evince 3.3.90-0ubuntu2
          libpoppler19 0.18.4-1ubuntu1
          libcairo2 1.10.2-6.1ubuntu2

Nicola Jelmorini (jelmorini) wrote :

I can confirm that the problem is still present. I have tried just now with my Ubuntu 12.04 installed on Virtualbox.
I opened this bug 3 years ago, and I think that for a "Precise" release, it would be amazing to have it eventually resolved :-)

madbiologist (me-again) wrote :

This is still occurring on Ubuntu 13.04 "Raring Ringtail".

madbiologist (me-again) wrote :

Still occurring on Ubuntu 16.04 "Xenial Xerus".

evince 3.18.2-1ubuntu4
poppler 0.41.0-0ubuntu1.1

tags: added: jaunty lucid maverick precise raring xenialamd64
removed: amd64
tags: added: amd64 xenial
removed: xenialamd64
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers