jaunty cups postscript failure (hardy success)

Bug #404214 reported by Patrick Welche on 2009-07-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Poppler
Fix Released
Medium
poppler (Ubuntu)
High
Martin Pitt
Lucid
High
Martin Pitt

Bug Description

Binary package hint: cups

In brief same file, same printer, same HP PPD, file prints on hardy, but doesn't with jaunty.

Grab a postscript level 2 file such as

http://www.cs.toronto.edu/~radford/ftp/mixmc.ps

Setup a HP LaserJet 4000N with default postscript driver:
*FormatVersion: "4.3"
*FileVersion: "1.1.2 X"
*LanguageEncoding: ISOLatin1
*LanguageVersion: English
*PCFileName: "HP4000_5.PPD"
*Product: "(HP LaserJet 4000 Series)"
*ModelName: "HP LaserJet 4000 Series"
*ShortNickName: "HP LaserJet 4000 Series"
*NickName: "HP LaserJet 4000 Series Postscript (recommended)"
*PSVersion: "(2014.108) 1"
*Manufacturer: "HP"

/etc/cups/lpoptions contains:
Default is2/d
Dest is2/s sides=one-sided
Dest is2/d sides=two-sided-long-edge Duplex=DuplexNoTumble
Dest is2/b sides=two-sided-long-edge Duplex=DuplexNoTumble number-up=2 page-border=single
as on hardy sides=two-sided-long-edge is recognised, but not on jaunty where the Duplex=DuplexNoTumble is necessary (the two should be equalivent, no?)

Now lpr -P is2/b mixmc.ps. Under hardy 8.04.3 (32-bit i386 desktop), you get a copy of an interesting paper.
Under jaunty 9.04 (tried 32-bit desktop and 64-bit server) you get

ERROR: undefined
OFFENDING COMMAND: \

STACK:

/
/bracketleft
...

(all updates current of today on all systems involved, i.e., default versions)
(other postscript files work for both - on jaunty this postscript file appears correct when viewed with gs and gv)

Related branches

Please run the following command on your jaunty system for some usefull printing related debugging info:
apport-collect -p cups 404214

Also provide a complete cups error_log from jaunty showing the error as described here: https://wiki.ubuntu.com/DebuggingPrintingProblems#cupserrorlog

Changed in cups (Ubuntu):
status: New → Incomplete

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: cups 1.3.9-17ubuntu3.2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/tcsh
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-13-generic i686
UserGroups: admin

Patrick Welche (prlw1) wrote :
Patrick Welche (prlw1) wrote :

Pascal, I wonder however whether you have read the bug report. Your comment looks like a knee-jerk reaction. The error is what comes out of the printer, not what cupsd writes in the error log. Thinking about it, next time I am in the lab, I should try raw printing. The question really is, if the file is correct postscript, what is cups doing to it? It must be changing what is sent to the printer, otherwise all systems be they hardy or jaunty should behave in the same way (as it is the same printer with its postscript interpreter and the same postscript file in all cases).

The attached PDF file after conversion to PS using pdftops fails to print on a LaserJet 4050. The printer error message is:

ERROR: undefined
OFFENDING COMMAND: \

The problem is the use of the '\' character in PostScript names. The Type 3 font contains a definition for each ASCII character with the name '/x' where 'x' is the ASCII character. Printing fails to the '/\' name for the backslash character. The backslash should be escaped.

Created an attachment (id=33589)
PDF file

Created an attachment (id=33590)
Patch to fix this bug

Patch to fix this bug.

I can reproduce this bug on Karmic using my LaserJet 4050. I have found the cause to be a bug in poppler (when using the pdftops command).

I've opened a poppler bug and attached a patch to fix the bug at:

https://bugs.freedesktop.org/show_bug.cgi?id=26776

affects: cups (Ubuntu) → poppler (Ubuntu)
Changed in poppler (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.04-beta-1
status: Incomplete → Triaged

Thanks will be in next 0.13.x version (probably released today/tomorrow)

Changed in poppler:
status: Unknown → Fix Released
Martin Pitt (pitti) on 2010-03-05
Changed in poppler (Ubuntu Lucid):
status: Triaged → Fix Committed
Steve Langasek (vorlon) wrote :

Martin, you marked this 'fix committed' two weeks ago - where is the fix committed, and when can we expect it in the archive?

Changed in poppler (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Martin Pitt (pitti) wrote :

We won't upgrade lucid to the 0.13.x series any more, since the 0.14 release is past lucid's release date. I backported the patch, sitting in unapproved now.

Changed in poppler (Ubuntu Lucid):
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poppler - 0.12.4-0ubuntu2

---------------
poppler (0.12.4-0ubuntu2) lucid; urgency=low

  * Add psname-escape-backslash.patch: Don't use '\' character in PostScript
    names. Patch backported from 0.13.1. (LP: #404214)
 -- Martin Pitt <email address hidden> Fri, 19 Mar 2010 13:51:55 +0100

Changed in poppler (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in poppler:
importance: Unknown → Medium
Changed in poppler:
importance: Medium → Unknown
Changed in poppler:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.