poor rendering

Bug #20310 reported by Trouilliez vincent
12
Affects Status Importance Assigned to Milestone
Evince
Fix Released
Unknown
poppler (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I have got lots of technical documents/datasheets in PDF format, and evince is
painfully slow to display the first page when I open a document, and trying to
access a random page (not contiguous to the page currently on screen ie) is very
slow too.
Also, the quality of the rendering is poor : I often can't even read the small
characters in diagrams.

I attached a (small...) data-sheet as an example. On this file, evince shows me
a blank page for what seems like ages, before displaying the page, yet as I
said, despite such a long wait, the text in the diagram is not even clean/sharp.

I tried with Acrobat Reader, and oh my god, I thought I was on another planet
altogether : it's simply lightening fast, absolutely blindingly quick, and the
quality of the rendering is very good too, diagrams are perfectly readable.
Accessing any page anywhere in the document is extremely fast too.
Okay, Acrobat is closed source, so maybe they use some magic that is patented
and/or too difficult to reverse engineer.

Soooo, I tried another OSS pdf reader...Kpdf, and was very pleased to see that
despite running in Gnome instead of KDE, hence not really 'at home' so to speak,
it was A LOT faster/livelier than evince, not as fast as Acrobat but not far
either, and the quality of the rendering of text in the diagrams was as good as
Acrobat.

All tests were done with the apps' windows maximized, and the zoom factor set to
'fit width'.

So, I would sell my kingdom to see evince use whatever backend/algorythm Kpdf
uses...

https://bugs.freedesktop.org/show_bug.cgi?id=4420: https://bugs.freedesktop.org/show_bug.cgi?id=4420

Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

Created an attachment (id=3359)
sample datasheet

Revision history for this message
Sebastien Bacher (seb128) wrote :

not sure of what kpdf uses, but new versions will likely use poppler like
evince. How slow is it and what kind of box do you use? it takes less than 1s to
display the page here. what version of libcairo2 do you use?

Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

> not sure of what kpdf uses but new versions will likely use poppler like
> evince.

According to the 'info" box, Kpdf uses Xpdf. If newer versions don't use Xpdf
anymore, then the Breezy repos are outdated ;-)

> How slow is it

Huuuu, Seb, what did yo do to it, it's much faster today ! Not as fast as
Acrobat, but fast enough for the purpose.

> and what kind of box do you use?

A decently (3 year) modern machine, nForce motherboard + Athlon XP 1.45GHz
("1700+") and 768MB of PC2100 DDR RAM, plus a 7200 IDE drive that manages about
40MB/s. It's alwyas plenty fast enough for me to know that when it's slow during
normal desktop use, something is wrong somewhere ! ;-)

> it takes less than 1s to display the page here. what version of libcairo2 do
you use?

It now takes only 2 seconds or so, the first time. and random access is fast
now. No problem anymore there then.
Is that because cairo ? Did you update some cairo related files in the last 48
hours since ? I think I saw some cairo stuff recently in the update- manager...

So it's fast enough now, however, the problem with poor rendering is still there
sadly :o( The small characters in most diagams, are not very sharp/neat/clean,
very difficult to read.
Kpdf (hence XPdf ?) and Acrobat don't have this problem, they load the page with
crap small text lie Evince, but half a second later, it redraws the page with
much improved graphics&text.

So about the cairo version, well I use whatever Breezy uses as I am rigthing
this, as I update Breezy at least once a day.

Revision history for this message
Sebastien Bacher (seb128) wrote :

(In reply to comment #3)
> > not sure of what kpdf uses but new versions will likely use poppler like
> > evince.
>
> According to the 'info" box, Kpdf uses Xpdf. If newer versions don't use Xpdf
> anymore, then the Breezy repos are outdated ;-)

"will", not "is" ... the is a difference between both

> Is that because cairo ? Did you update some cairo related files in the last 48
> hours since ? I think I saw some cairo stuff recently in the update- manager...

maybe the cairo update form yesterday

> So it's fast enough now, however, the problem with poor rendering is still there
> sadly :o( The small characters in most diagams, are not very sharp/neat/clean,
> very difficult to read.

can you make a screenshot of the issue on the example pdf you put with this bug?

Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

Created an attachment (id=3395)
Evince next to Kpdf

Revision history for this message
Trouilliez vincent (vincent-trouilliez-modulonet) wrote :

> can you make a screenshot of the issue on the example pdf you put with this bug?

I just made one. It's page 10 of the document. Evince is on top, and Kpdf at the
bottom. I adjusted the page width so that the zoom factor in both apps is
exactly the same, as this obviously affect anti-aliasing/rendering.
The interesting part is the small characters in the diagram on the right part of
the page. Evince at first might appear cleared to you, because the line look
"thiner". However there are many missing pixels, that make it hard to read, and
force me to "guess" what's writen. Data sheets are there to provide reference
information, "guessing" is not good at all, you must sure of what you are
reading. Now with Kpdf, it's the other way around : it may appear more "blurry"
to you a t first (I think obvjectively it is, in some places), but the advantage
is that there is no mising pixels, and that ALL the text inthe diagram is
actually readable without effort, whereas with Evince some characters may be
clear, but many aren't. Kpdf is more "consistent", the text will always be
complete and readable.

Revision history for this message
Sebastien Bacher (seb128) wrote :

I've forwarded the issue upstream: https://bugs.freedesktop.org/show_bug.cgi?id=4420

Changed in evince:
status: Unconfirmed → Confirmed
Changed in evince:
status: Confirmed → Rejected
Changed in evince:
assignee: seb128 → desktop-bugs
status: Unconfirmed → Confirmed
Changed in evince:
status: Rejected → In Progress
Revision history for this message
Tino Meinen (a-t-meinen) wrote :

The related bug is fixed upstream.
I checked with the latest version of evince in gutsy on 06-08-2007 (version 0.9.3, with poppler 0.5.9) and the rendering is fast and flawless.
I think this bug can be closed as FIXED

Revision history for this message
David Freitas (jddcef) wrote :

This pdf:
http://www.inference.phy.cam.ac.uk/mackay/network.pdf
displays poorly in "Evince 0.8.1, poppler 0.5.4 (cairo)".

See here (duplicate bug):
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/138651
for more info.

The datasheet "sample datasheet"pdf attached in the first comment of this bug displays fine for me, except the diagrams text is slightly dotty, but not near as bad as all the text of http://www.inference.phy.cam.ac.uk/mackay/network.pdf

-----------
Fixing linux for the desktop; one bug at a time.

Revision history for this message
Tino Meinen (a-t-meinen) wrote :

Yes, if you look closely xpdf does seem to render things a tiny bit better than evince does.
At least speed is no longer an issue, because evince renders very vast. (especially the latest 2.19.9x series with poppler 0.6).
But looking at the specific location pointed out by the screenshot, with the diagram and the captions that go with it, you can see a difference. The difference is more pronounced on LCD screens than on CRT screens. Not a large difference, but a little difference non the less where evince/poppler looses out shlightly on xpdf.

Changed in evince:
status: In Progress → Confirmed
Changed in evince:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.