[hardy] severe memory leak opening PDF

Bug #195183 reported by Gavin McCullagh on 2008-02-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Poppler
Fix Released
Medium
poppler (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evince

I've just downloaded a PDF to the desktop. When I open it with evince, evince's RAM usage spirals rapidly until I needed to kill it.

By comparison xpdf, while not terribly quick opening it, works fine.

libby@hector:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
libby@hector:~$ apt-cache policy evince
evince:
  Installed: 2.21.91-0ubuntu1
  Candidate: 2.21.91-0ubuntu1
  Version table:
 *** 2.21.91-0ubuntu1 0
        500 http://ie.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: i386
Date: Sun Feb 24 20:38:34 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: ath_hal
Package: evince 2.21.91-0ubuntu1
PackageArchitecture: i386
ProcCwd: /home/libby
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_IE.UTF-8
SourcePackage: evince
Uname: Linux hector 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux

Created an attachment (id=2774)
pdf which causes the problem

Attached pdf

hits drawImageMask a lot of times

Same problem here with the following Pdf file:

http://mct.sbb.ch/mct/fr/print/parkandrail.pdf

Created an attachment (id=3216)
generated postscript

The postscript file which results from printing within evince.

Big sorry, the postscript above has nothing to do with this bug (but rather with
3391), but I don't know how to delete an entry? Thanks

Created an attachment (id=3218)
pdf which causes the problem (example 2)

Attached the second pdf document to show the problem, and obsoleted the wrong
attachement.

I using poppler-0.5.4 an have the same Problem
Viewing 20 pages takes about ~512MB

File:
http://www.itu.int/rec/dologin_pub.asp?lang=e&id=T-REC-H.222.0-200002-I!!PDF-E&type=items

Gavin McCullagh (gmccullagh) wrote :

Binary package hint: evince

I've just downloaded a PDF to the desktop. When I open it with evince, evince's RAM usage spirals rapidly until I needed to kill it.

By comparison xpdf, while not terribly quick opening it, works fine.

libby@hector:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
libby@hector:~$ apt-cache policy evince
evince:
  Installed: 2.21.91-0ubuntu1
  Candidate: 2.21.91-0ubuntu1
  Version table:
 *** 2.21.91-0ubuntu1 0
        500 http://ie.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: i386
Date: Sun Feb 24 20:38:34 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: ath_hal
Package: evince 2.21.91-0ubuntu1
PackageArchitecture: i386
ProcCwd: /home/libby
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_IE.UTF-8
SourcePackage: evince
Uname: Linux hector 2.6.24-8-generic #1 SMP Thu Feb 14 20:40:45 UTC 2008 i686 GNU/Linux

Gavin McCullagh (gmccullagh) wrote :
Gavin McCullagh (gmccullagh) wrote :

credit should go to Dr. Elizebeth Turner for discovering this bug :-)

TerryG (tgalati4) wrote :

Works fine under Gutsy and evince 2.20.1, so this would be a regression.

Changed in evince:
status: New → Confirmed

I can confirm this, I tried it with other pdfs as well, all resulted in massive memory usage up to 450 MB memory for a 2 MB pdf while xpdf uses less than 10 MB.

Pedro Villavicencio (pedro) wrote :

I've added the pdf to bug https://bugs.freedesktop.org/show_bug.cgi?id=3394 ; thanks for reporting.

Changed in evince:
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in poppler:
status: Unknown → Confirmed
TerryG (tgalati4) wrote :

Document still opens fine without memory leaks under latest poppler (2.06) on Gutsy with all updates.

Pedro Villavicencio (pedro) wrote :

the bug is about the hardy version not the gutsy one, thanks.

Seems to be related to 16878

This appears to be fixed in evince 2.22.2. These pdfs still take some time to render, but they no longer chew through huge amounts of memory to do so.

Changed in poppler:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

this is fixed now, it takes a few time to load but it doesn't leak.

Changed in poppler:
status: Triaged → Fix Released
Changed in poppler:
importance: Unknown → Medium
Changed in poppler:
importance: Medium → Unknown
Changed in poppler:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.