Merge poppler 0.44.0-3 (main) from Debian unstable (main)

Bug #1591528 reported by Jeremy Bicha
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
poppler (Ubuntu)
Wishlist
Unassigned

Bug Description

Please merge poppler 0.44.0-3 (main) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
===============================
  * Updated for soname change libpoppler58 -> 61
  * New upstream version (soname update 57->58)
  * debian/patchres/revert_api_change.patch:
    - revert upstream commit that removed an enum, they claim it's
      not an abi change because it's unused, but other packages (bindings)
      rely on it to build still, we can drop the patch later once the
      redpends have been updated
  * Updated for soname change libpoppler56 -> 57
  * Updated for soname change libpoppler52 -> 56
  * Set hardening flags to "+all,-pie" to build with all hardening flags
    except -fPIE.
  * New upstream release (LP: #1449991)
  * Rename packages according to the new SONAMEs:
    - libpoppler49 -> libpoppler52
  * debian/libpoppler-glib8.symbols.in:
  * debian/libpoppler-qt4-4.symbols.in:
  * debian/libpoppler-qt5-1.symbols.in:
    - Updated
  * Explicitly pass --disable-libopenjpeg now - this support was auto-disabled
    before but now configure fails without this flag.
  * Rename packages according to the new SONAMEs:
    - libpoppler47 -> libpoppler49
  * Resynchronise with Debian, remaining changes:
    - Drop libopenjpeg-dev build depends, it is in universe.
    - Lower poppler-data to Suggests, it is too big for CD images,
      handled by language-selector.

All of that is in the Debian package except for these:
====================================
1. Drop libopenjpeg-dev build-depends, it is in universe
- We still need this dropped, except it is now libopenjp2-7-dev
2. Use --disable-libopenjpeg
- Still needed
3. debian/patches/revert_api_change.patch:
- Not needed, see test build results below
4. Lower poppler-data to Suggests since it's too big for CD images
- Since we aren't as concerned about 1 or 2 MBs since we do DVDs instead
of CDs, this seems like an obsolete change. See bug 893920 where we have
language-selector install this for everyone after install anyway.

$ apt show poppler-data
Installed-Size: 12.4 MB
Download-Size: 1,495 kB

Changelog entries since current yakkety version 0.44.0-0ubuntu1:
=================

poppler (0.44.0-3) unstable; urgency=medium

  * Switch from OpenJPEG 1.x to 2.x: (Closes: #826825)
    - replace the libopenjpeg-dev build dependency with libopenjp2-7-dev
    - pass --enable-libopenjpeg=openjpeg2 to configure, to be sure OpenJPEG 2.x
      is used

 -- Pino Toscano <email address hidden> Thu, 09 Jun 2016 23:14:49 +0200

poppler (0.44.0-2) unstable; urgency=medium

  * Upload to unstable. (See #823667)

 -- Pino Toscano <email address hidden> Fri, 27 May 2016 22:13:46 +0200

poppler (0.44.0-1) experimental; urgency=medium

  * New upstream release.
  * Rename packages according to the new SONAMEs:
    - libpoppler60 -> libpoppler61
  * Update copyright.

 -- Pino Toscano <email address hidden> Sun, 22 May 2016 08:46:59 +0200

poppler (0.43.0-1) experimental; urgency=medium

  * New upstream release: (Closes: #822644)
    - fixes pdfinfo man page (Closes: #813500)
    - fixes build with GCC 6 (Closes: #811901)
  * Rename packages according to the new SONAMEs:
    - libpoppler57 -> libpoppler60
  * Update copyright.
  * Update symbols files:
    - adapt to the different internal symbols with GCC 6
  * Update build dependencies:
    - add zlib1g-dev for Flate compression
    - add libnss3-dev for signature handling
  * Mention pdfsig in the description of poppler-utils.

 -- Pino Toscano <email address hidden> Sun, 01 May 2016 09:31:22 +0200

poppler (0.38.0-3) unstable; urgency=medium

  * Backport upstream commit b3425dd3261679958cd56c0f71995c15d2124433 to fix
    a crash on invalid files, reported also as CVE-2015-8868; patch
    upstream_Do-not-crash-on-invalid-files.patch. (Closes: #822578)
  * Update Vcs-* fields.
  * Bump Standards-Version to 3.9.8, no changes required.

 -- Pino Toscano <email address hidden> Mon, 25 Apr 2016 16:51:07 +0200

poppler (0.38.0-2) unstable; urgency=medium

  * Upload to unstable. (See #807089)

 -- Pino Toscano <email address hidden> Wed, 09 Dec 2015 20:21:27 +0100

poppler (0.38.0-1) experimental; urgency=medium

  * New upstream release:
    - fixes an initialized value in Splash (Closes: #777250)
  * Rename packages according to the new SONAMEs:
    - libpoppler47 -> libpoppler57
  * Update copyright.
  * debian/patches:
    - qt-visibility.diff: refresh
  * Update symbols files.
  * Merge changes from 0.26.5-3 and 0.26.5-4.

 -- Pino Toscano <email address hidden> Sun, 29 Nov 2015 19:42:03 +0100
poppler (0.26.5-4) unstable; urgency=medium

  * Handle the new libstc++ ABI of GCC 5 on libpoppler-cpp: (Closes: #796919)
    - rename libpoppler-cpp0 to libpoppler-cpp0v5
    - make libpoppler-cpp0v5 conflict/replace libpoppler-cpp0

 -- Pino Toscano <email address hidden> Sat, 29 Aug 2015 11:11:46 +0200

poppler (0.26.5-3) unstable; urgency=medium

  * Replace "xpdf-utils (<< 3.02-2~)" with
    "xpdf-utils (<< 1:0), xpdf-common" to cleanup the old packages.
    (Closes: #774949)
  * Disable pie for now, as there seems to be an incompatibility between Qt5
    and GCC >= 5. (Closes: #792592)
  * Tighten dependencies on the libpopplerN package to the exact binary
    version in other library packages and poppler-utils. (Closes: #767659)
  * control: rename XS-Testsuite to Testsuite.
  * autopkgtest tests: remove the realpath dependency, as the version of
    coreutils in stable provides the realpath binary.

 -- Pino Toscano <email address hidden> Sat, 25 Jul 2015 20:01:57 +0200

Test build
==========
https://launchpad.net/~jbicha/+archive/ubuntu/arch/+packages
I did a test build of all of poppler reverse build-dependencies.
- twidge is a haskell package so it's currently unbuildable
- cirkuit unrelated longstanding ftbfs, filed bug 1591557
- gle-graphics FTBFS on armhf - longstanding bug 940842
- calibre FTBFS on arm64 - unrelated qt issue?

- Note that python-poppler did need to be fixed (bug 1528489) but this was done in Debian 2 weeks ago and auto-synced.
- poppler-sharp rebuilt fine but still references the removed POPPLER_ORIENTATION_* enums. This is because it wasn't actually building bindings for the current API, but building for the last time poppler-sharp was updated upstream (poppler 0.18!).
https://github.com/jacintos/poppler-sharp/pull/7
I'll follow up with Debian too.

python-poppler and poppler-sharp are the only 2 of the packages I built to have results when I rgrepped "POPPLER_ORIENTATION" in their source code.

Note for sponsors
=================
boomaga and pdfgrep will need a rebuild after this upload because Debian renamed libpoppler-cpp0 > libpoppler-cpp0v5

Jeremy Bicha (jbicha)
Changed in poppler (Ubuntu):
status: New → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Jeremy Bicha (jbicha)
description: updated
Revision history for this message
Jeremy Bicha (jbicha) wrote :
description: updated
Revision history for this message
Jeremy Bicha (jbicha) wrote :
Changed in poppler (Ubuntu):
assignee: Jeremy Bicha (jbicha) → nobody
status: In Progress → New
Jeremy Bicha (jbicha)
description: updated
tags: added: patch yakkety
Mathew Hodson (mhodson)
Changed in poppler (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Martin Pitt (pitti) wrote :

Sponsored, thank you!

Changed in poppler (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poppler - 0.44.0-3ubuntu1

---------------
poppler (0.44.0-3ubuntu1) yakkety; urgency=medium

  * Merge with Debian. (LP: #1591528) Remaining changes:
    - debian/control:
      + Don't build-depend on libopenjp2-7-dev since it's in universe
    - debian/rules:
      + Use --disable-libopenjpeg
  * Dropped changes:
    - Only suggest poppler-data since it's too big for CDs and
      language-selector automatically installs it after install
    - debian/patches/revert_api_change.patch:
      + revert upstream commit that removed an enum, they claim it's
        not an abi change because it's unused, but other packages (bindings)
        rely on it to build still, we can drop the patch later once the
        rdepends have been updated

poppler (0.44.0-3) unstable; urgency=medium

  * Switch from OpenJPEG 1.x to 2.x: (Closes: #826825)
    - replace the libopenjpeg-dev build dependency with libopenjp2-7-dev
    - pass --enable-libopenjpeg=openjpeg2 to configure, to be sure OpenJPEG 2.x
      is used

 -- Jeremy Bicha <email address hidden> Sat, 11 Jun 2016 18:16:34 -0400

Changed in poppler (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers