pdfimages extracts black rectangles instead of the images

Bug #1506612 reported by Chelmite on 2015-10-15
This bug affects 2 people
Affects Status Importance Assigned to Milestone
poppler (Ubuntu)

Bug Description

When I run pdfimages -f 1 -l 1 -png Z.pdf z-pdfimages, I get 5 images, two of which are black rectangles.

If I run pdftocairo -png Z.pdf z-pdftocairo, I get one image that looks correct.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: poppler-utils 0.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-31.36-generic 3.19.8-ckt7
Uname: Linux 3.19.0-31-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1.5
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Oct 15 12:36:10 2015
InstallationDate: Installed on 2013-05-02 (896 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
SourcePackage: poppler
UpgradeStatus: No upgrade log present (probably fresh install)

Chelmite (steve-kelem) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in poppler (Ubuntu):
status: New → Confirmed
Karl Kastner (kastner-karl) wrote :

I can reproduce this for certain files in xenial. Most of these files are pdf files that were converted from ps format.

madbiologist (me-again) on 2018-02-14
tags: added: bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers