evince crashed with SIGSEGV in TextLine::visitSelection()

Bug #145602 reported by FrejSoya on 2007-09-27
70
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Poppler
Fix Released
Medium
poppler (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: evince

Reading a pdf :) (Either resize window or going to next page)

ProblemType: Crash
Architecture: i386
Date: Thu Sep 27 13:33:48 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: fglrx ath_hal
Package: evince 2.20.0-0ubuntu1
PackageArchitecture: i386
ProcCmdline: evince file:///home/frej/Downloads/particle(1).pdf
ProcCwd: /home/frej
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_DK.UTF-8
Signal: 11
SourcePackage: evince
StacktraceTop:
 TextLine::visitSelection () from /usr/lib/libpoppler.so.2
 TextBlock::visitSelection () from /usr/lib/libpoppler.so.2
 TextPage::visitSelection () from /usr/lib/libpoppler.so.2
 TextPage::getSelectionRegion ()
 TextOutputDev::getSelectionRegion ()
Title: evince crashed with SIGSEGV in TextLine::visitSelection()
Uname: Linux soya 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip fax floppy kvm lpadmin plugdev pulse pulse-access pulse-rt scanner tape video

FrejSoya (frej) wrote :

Binary package hint: evince

Reading a pdf :) (Either resize window or going to next page)

ProblemType: Crash
Architecture: i386
Date: Thu Sep 27 13:33:48 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: fglrx ath_hal
Package: evince 2.20.0-0ubuntu1
PackageArchitecture: i386
ProcCmdline: evince file:///home/frej/Downloads/particle(1).pdf
ProcCwd: /home/frej
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_DK.UTF-8
Signal: 11
SourcePackage: evince
StacktraceTop:
 TextLine::visitSelection () from /usr/lib/libpoppler.so.2
 TextBlock::visitSelection () from /usr/lib/libpoppler.so.2
 TextPage::visitSelection () from /usr/lib/libpoppler.so.2
 TextPage::getSelectionRegion ()
 TextOutputDev::getSelectionRegion ()
Title: evince crashed with SIGSEGV in TextLine::visitSelection()
Uname: Linux soya 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip fax floppy kvm lpadmin plugdev pulse pulse-access pulse-rt scanner tape video

FrejSoya (frej) wrote :

StacktraceTop:TextBlock::visitSelection (this=0x865e240, visitor=0xbfa89308, selection=0xbfa892a0,
TextPage::visitSelection (this=0x83d3db8, visitor=0xbfa89308, selection=0xbfa89388,
TextPage::getSelectionRegion (this=0x83d3db8, selection=0xbfa89388,
TextOutputDev::getSelectionRegion (this=0x8566568, selection=0xbfa89388,
poppler_page_get_selection_region (page=0x8348878, scale=1.6341818571090698,

Changed in evince:
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugs.freedesktop.org/show_bug.cgi?id=12589. Does it happen every time with this example, could you attach it to the bug?

Changed in evince:
status: New → Triaged
Changed in poppler:
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :

Do you still get the issue? Do you have an example?

FrejSoya (frej) wrote :

Sorry - can't reproduce for now. Seems text selection in evince/poppler got more crash resistant. Ok to close :/

hrushikesh (hrushikesh) wrote :

Just got this on Intrepid with evince version 2.24.0 while doing nothing at all! The window was in background.

George Pollard (porges) wrote :

Got this as well, same circumstances as hrushikesh.

PDF was open in Firefox using Evince under mozplug.

Aleksander Sumowski (sumek) wrote :

Another case... Intrepid, Evince 2.24.0. Not inside FF.

Johan Gunnarsson (johang) wrote :

Got it in Intrepid while selecting text in Evince. Backtrace identical to the one in Bugzilla pasted above.

tc (tconst) wrote :

I get this in hardy, Evince 2.22.2 all the time when randomly clicking/highlighting text.

Just happened to me while selecting some text that includes LaTeX'ed math.

You can get a testcase here (economics lesson :-) ):
http://ledezma.ivan.googlepages.com/4thSession.pdf

Select text repeatedly with the mouse in Evince, on page 13 for example, and you'll soon get the crash (fully reproducible but somewhat random).

Please just ask if you need more informations.

Can you try with poppler 0.10.3?

Not for now: I'll be able to try it around April, when Ubuntu 9.04 is released. Can't you try the testcase? :-p

I don't have evince installed

I can't reproduce it with the Fedora 9 evince (Evince Document Viewer 2.22.2, claims to be using poppler 0.8.7 (cairo).

Brad Hards: This is strange, because I remember having experienced this problem for some time (i.e. sooner than 2.24) - though maybe with other documents than this one.

Anyway, I've installed poppler 0.10.3 and evince 2.25 with development packages (and several missing dependencies), and the bug has disappeared! I rather feared that missing libraries would make it crash all the time on my system... So it looks like you have silently fixed that in some way, which is great!

Thanks, and keep up the good work!

I've tried reproducing this problem with a testcase document with Jaunty packages (Evince 2.25 and poppler 0.10.3), and I'm glad to tell you the bug seems to be fixed. So I close it for now, but please reopen it if you are still able to reproduce this crash when Jaunty is released.

Changed in poppler:
status: Triaged → Fix Released
Changed in poppler:
status: Confirmed → Fix Released
Changed in poppler:
importance: Unknown → Medium
Changed in poppler:
importance: Medium → Unknown
Changed in poppler:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.