evince is excruciatingly slow on some documents

Bug #1325899 reported by Florian Hars on 2014-06-03
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Poppler
Invalid
Medium
poppler (Ubuntu)
Undecided
Unassigned

Bug Description

Evince is excruciatingly slow when displaying the book available for download at http://www.safetty.net/publications/pttes
Scrolling can take several seconds and will often just display empty pages. (And it is even worse with the 2009 version of the book you can still find on several places on the internet), while xpdf has no problems at all with instantly switching to the next page.

madbiologist (me-again) wrote :

The file that you linked to renders pretty quickly (including scrolling) on my old system running Ubuntu 14.04 "Trusty Tahr".

Can you please tell us the following?

- what version of Ubuntu you are using
- the output of uname -srm
- what version of evince you are using
- what version of poppler you are using
- what version of libcairo2 you are using
- the output of cat /proc/cpuinfo
- how much RAM is in your system

Changed in evince (Ubuntu):
status: New → Incomplete

Hi,

I am not the original poster, but I am affected by this bug too. I opened the file suggested by Florian, and evince as able to render it absolutely perfectly, and with no lag (I was also able to scroll with no problem).

However, some files are still extremely slow to be rendered. I have attached an example. If you flip from page to page it might be OK, but if you start flipping quickly, it's extremely slow (I sometimes have to wait for 3+ seconds for a single page to be rendered). Please note that even Firefox (with its built-in PDF viewer) renders it in no time.

So let me answer your questions for my system instead:
- what version of Ubuntu you are using
      14.04 64-bit, fully updated as of this post
- the output of uname -srm
      Linux 3.13.0-29-generic x86_64
- what version of evince you are using
      3.10.3
- what version of poppler you are using
      0.24.5-2ubuntu4
- what version of libcairo2 you are using
      1.13.0~20140204-0ubuntu1
- the output of cat /proc/cpuinfo
      (see next attachment)
- how much RAM is in your system
      6GB, 4 of which are currently free

Thanks alot for looking into this.

Hi again, sorry if I'm bothering, but I wouldn't want this bug to expire. What else do we need to provide in order for this bug to be confirmed, triaged, etc?

Since there is no answer from anyone, and I can independently confirm what was reported by Florian Hars, I will mark this bug as Confirmed. Note that it is not "Incomplete" anymore, as I provided myself the necessary "missing" information.

Changed in evince (Ubuntu):
status: Incomplete → Confirmed
Kabanov Dmitry (kabanovdmitry) wrote :

I confirm that the PDF provided by OP is extremely slow. Scrolling is very sluggish, and it takes several seconds to render a page.

Actually, I came to this bug page to say that Evince is sluggish on many documents. Scrolling with mouse is uncomfortable even in the thumbnails area.

I use Ubuntu 14.04.

Hi,

madbiologist:
 - Do you mind telling us if anything else is necessary, or if we have to file this bug against a different package?

I have to look at dozens of PDFs every day, and this bug slows me down a lot (and overheats my system for no reason).

Kabanov:
 - I don't have the same problem as you with the PDF mentioned by the OP. What CPU/graphics do you have? I have Intel sandybridge mobile graphics/CPU. Ubuntu 14.04 64-bit.
 - Do you find the PDF I uploaded before is slow for you? Not when you look at a single page, but if you try to flip through pages quickly. In 12.04 there was no lag whatsoever. Now it can take a few seconds per page, which is a lot when yoou have to look at dozens of pages...

madbiologist (me-again) wrote :

Sorry for taking so long to get back to this bug. Thanks for setting the status to "Confirmed" in my absence. The PDF file attached to comment #2 renders slowly when flipping rapidly between pages on my newish system (a different system to the one I mentioned in comment #1). This is on Trusty 14.04 with the update to libpoppler44 0.24.5-2ubuntu4.1.

I have changed the package to poppler. Does this still occur on Ubuntu 14.10 "Utopic Unicorn" which contains poppler 0.26.5-0ubuntu1?

affects: evince (Ubuntu) → poppler (Ubuntu)
Changed in poppler (Ubuntu):
status: Confirmed → Incomplete

Hi, thanks for looking into this.

I just tried Utopic to see how it goes. It is still very slow (I am referring to the attachment in #2, which is a very light file). As I said before, even Firefox renders it instantly. I know I am repeating myself, but just to be clear:
  - this happens when flipping quickly through many pages.
  - the document the original poster referred to renders very quickly on my system (sandybridge, i5-2450M).

And to confirm:

Package: libpoppler46
Priority: optional
Section: libs
Installed-Size: 2660
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Loic Minier <email address hidden>
Architecture: amd64
Source: poppler
Version: 0.26.5-0ubuntu1

madbiologist: should I mark it as "Confirmed", or will you do something else?

Thank you!

madbiologist (me-again) wrote :

Thanks for testing. Now that this bug is reconfirmed, the next step is to file an upstream bug against poppler at https://bugs.freedesktop.org/ and then link it to this bug report by clicking on "Also affects project" above this bug's description.

Changed in poppler (Ubuntu):
status: Incomplete → Confirmed

Created attachment 110276
Small file with several pages to flick through

Evince is extremely slow on some files, especially if it contains images or graphs.
I'm running Ubuntu 14.04 (libpoppler 0.24.5-2ubuntu, but it also affects Ubuntu 14.10 with libpoppler0.26.5). In earlier versions, the test pdf attached would render each page almost instantaneously, it now takes several seconds per page. Even Firefox (with the built-in PDF renderer, HTML5) can render this much more quickly.
In order to test this, it is not enough to look at a single page, but you need to quickly flick through several pages. Note that the file itself is pretty light.
I'm using Sandybridge integarted graphics, i5-2450M.

I have filed the upstream bug report (https://bugs.freedesktop.org/show_bug.cgi?id=86884).

It seems that there were some duplicated (https://bugs.freedesktop.org/show_bug.cgi?id=85766 and https://bugs.freedesktop.org/show_bug.cgi?id=76821) but I reported this mentioning the two versions of libpoppler mentioned earllier in this tracker.

I don't see any page being slow when using glib/demo/poppler-glib-demo nor qt4/tests/test-poppler-qt4

It would be useul if you could compile poppler from source use these apps and tell us which page you find to be slow.

Changed in poppler:
importance: Unknown → Medium
status: Unknown → Confirmed

Thank you Albert for looking into this. I have to say I quickly tried to do what you suggested, but didn't succeed. Unfortunately I don't have the time to look into this in such detail.
The other information I can provide you with is:

1. Bug tracker in Launchpad: https://bugs.launchpad.net/poppler/+bug/1325899 . The rendering issue has been verified by other users.
2. The latest instruction was to submit a bug report upstream (this one) against poppler.
3. This problem does not arise when using xpdf (instead of evince) on my system.

Cheers

I'm getting fast render times in Evince for this document with 34 pages of graphs. I think it was fixed by poppler bug 33364. Please try to use poppler 0.28 or later.

*** This bug has been marked as a duplicate of bug 33364 ***

Changed in poppler:
status: Confirmed → Invalid
madbiologist (me-again) wrote :

Poppler 0.28.1-1ubuntu1 is now available in Ubuntu 15.04 "Vivid Vevet" development version.

madbiologist (me-again) on 2015-03-09
Changed in poppler (Ubuntu):
status: Confirmed → Fix Released
cro (cro) wrote :

This appears to have been regressed somewhere. 15.04 with libpoppler 0.30 - a PDF that used to render instantly (and renders instantly using muPDF) now takes on average 10-15s to render a single page using Evince or Atril, or longer if focus is missing.

As the behaviour is the same in both Evince and Atril, my assumption is that the issue is in poppler somewhere - PDF renderers that do not use poppler are ultrafast, those that use it are ultra slow.

madbiologist (me-again) wrote :

cro - Can you reproduce this slowness with either of the PDF files attached to this bug report? If not, slowness with a different PDF would indicate a different bug and you should run ubuntu-bug to file a new bug report.

Zwinkau (qznc) wrote :

Might also be affected by https://bugzilla.gnome.org/show_bug.cgi?id=691448

Is it better, if sidepane is hidden (hit F9)?

sfornengo (sfornengo) wrote :

On Ubuntu 16.04 64bits, I can confirm that evince is very very slow with the following attached PDF (several minutes for opening).
Using firefox pdf.js open it without difficulties.

shankao (shankao) wrote :

It'd be better to open a new bug to increase visibility. This one was dealing with a different / older problem that was already fixed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.