evince:10312: POPPLER_ACTION_UNKNOWN

Bug #125498 reported by obobu84 on 2007-07-12
14
Affects Status Importance Assigned to Milestone
Poppler
Fix Released
Medium
poppler (Ubuntu)
Low
Unassigned

Bug Description

when i read a pdf, but this happens only with a specific pdf, i receive the following warning:

** (evince:10312): WARNING **: Unimplemented action: POPPLER_ACTION_UNKNOWN, please post a bug report with a testcase.

so i followed the suggestion and reported the bug.

Created an attachment (id=5877)
File causing the WARNING

obobu84 (lucaborzani) wrote :

when i read a pdf, but this happens only with a specific pdf, i receive the following warning:

** (evince:10312): WARNING **: Unimplemented action: POPPLER_ACTION_UNKNOWN, please post a bug report with a testcase.

so i followed the suggestion and reported the bug.

Harrison Conlin (harrisony) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in evince

Áron Sisak (asisak) wrote :

Thanks for reporting this bug. Please attach the pdf in question so that we can reproduce this issue and send to the poppler developers.

Changed in evince:
assignee: nobody → asisak
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

What version of Ubuntu do you use?

Sorry for the delay. I was in holiday.

i use ubuntu feisty 7.04 coming direclty from an upgrade of ubuntu edgy. amd64 version

On Mon, 06 Aug 2007 14:25:33 -0000
Sebastien Bacher <email address hidden> wrote:

> What version of Ubuntu do you use?
>
> --
> evince:10312: POPPLER_ACTION_UNKNOWN
> https://bugs.launchpad.net/bugs/125498
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Luca Borzani <email address hidden>

Sebastien Bacher (seb128) wrote :

could you attach an example to the bug?

obobu84 (lucaborzani) wrote :

as soon as I can reproduce the bug i will submit an example. At the moment I can't beacause i don't remember how to reproduce it

On Thu, 30 Aug 2007 16:56:09 -0000
Sebastien Bacher <email address hidden> wrote:

> could you attach an example to the bug?
>
> --
> evince:10312: POPPLER_ACTION_UNKNOWN
> https://bugs.launchpad.net/bugs/125498
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Luca Borzani <email address hidden>

Andrea Bocci (fwyzard) wrote :

Hi,
I'm getting the same message with Ubuntu 7.10 (devel) as of September 10, using evince 2.19.92-0ubuntu1 and libpoppler2 0.6-0ubuntu1.

The one pdf giving the message (twice) is at http://www.nbc.com/Heroes/novels/downloads/Heroes_novel_049.pdf .

Áron Sisak (asisak) wrote :

Reassigning, confirming.

Changed in evince:
assignee: asisak → nobody
status: Incomplete → Confirmed

The file http://johannes.sipsolutions.net/files/uspat20030042984a1.pdf causes the same message to be printed out but obviously there's no telling whether the same action is unimplemented or not (some sort of number might be good).

The file was obtained via depatisnet.de's full pdf link.

Still happens with evince 0.8.3 and poppler 0.5.4 on Gentoo.

There's also an ubuntu bug about this with test cases here: https://bugs.launchpad.net/poppler/+bug/125498

Pedro Villavicencio (pedro) wrote :

another test file coming from a dup :

"Binary package hint: evince

 evince Squid26.pdf

** (evince:25620): WARNING **: Unimplemented action: POPPLER_ACTION_UNKNOWN, please post a bug report with a testcase.

file is http://www.visolve.com/squid/squid26/Squid26.pdf"

Changed in poppler:
status: Confirmed → Triaged
Changed in poppler:
status: Unknown → Confirmed

Created an attachment (id=12623)
Another file causing the warning

Here's another testcase with the same warning. Error is seen in poppler-0.6.2, evince-2.20.1 (on Gentoo).

Hi,

This comes from the fact that the index has entries which do not point
to page numbers. For ex. in the first attached doc, the problem comes
from the last entry, Stichwortverzeichnis. In the 2nd, from CERIAS...

To check this, you can put before line glib/poppler-document.cc:1054
(from trunk) the line:
     printf ("alfa title=%s, link_action=%p\n", title, link_action);
you will see that link_action is null for the titles I specify above.

I do not know if this is a document error, I am trying to read the pdf
reference. I ask myself if the index is found in the pdf file, or it
is automatically generated by poppler, in the latter case being a bug of
poppler. Do someone know the answer?

Greetings,
Eugen Dedu

Created an attachment (id=15060)
Include the NONE action/dest

Please check if this patch/fix is correct.

Hi,

In the two documents attached, there is an index/outline item which has no destination.

From pdf reference v.1.7 (http://www.adobe.com/devnet/acrobat/pdfs/pdf_reference.pdf), section 8.2.2, page 586, the destination (the actions too) is optional for outline items and annotations, but required for actions and remote actions, so no warning should be displayed for outline items (such as the two documents attached).

So poppler should return no action when the dest/action is optional and is not present in the pdf file, but POPPLER_ACTION_NONE (for ex.) does not exist.

(By the way, I notice that PopplerDestType is not used, the destinations being considered as actions. For ex., a "grep -r PopplerDestType ." shows no usage of this type. Also, poppler/Outline.cc:78:
     78 if (!dict->lookup("Dest", &obj1)->isNull()) {
     79 action = LinkAction::parseDest(&obj1);
     80 } else {
     81 obj1.free();
     82 if (!dict->lookup("A", &obj1)->isNull()) {
     83 action = LinkAction::parseAction(&obj1);
     84 }
shows that destinations and actions are treated in the same manner, as actions.)

Therefore, I propose the attached patch in my previous comment. I do not know well the poppler application, so please check if I modified all the needed files.

Cheers,
Eugen Dedu

Hi,

Has anyone any comment on my previous patch? Is it good for you?

Cheers,
Eugen Dedu

I've just applied the patch, removing the POPPLER_DEST_NONE thing since I don't think it's really needed.

Thank you very much for the patch.

Thank you.

IMO this means that the API of poppler has changed: any application (its developers) using it should be informed that another type has been added. For ex., evince should use
    case ...NONE:
        break; // instead of printing a warning/error
or something like this.

Also, imagine an application which uses :
    if (action != ...UNKNOWN)
        ...

Let me know what do you think: is this important?

Cheers,
Eugen Dedu

All docs mentioned in this bug report don't show the warning anymore. Closing.

Changed in poppler:
importance: Unknown → Medium
status: Confirmed → Fix Released
Changed in poppler:
importance: Medium → Unknown
Changed in poppler:
importance: Unknown → Medium
Sebastien Bacher (seb128) wrote :

the issue doesn't show in recent versions, closing the bug

Changed in poppler (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.