Update poppler to 0.22.4

Bug #1135995 reported by Rohan Garg on 2013-02-28
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
poppler (Ubuntu)
Wishlist
Unassigned

Bug Description

Could someone please sponsor a upload of the new poppler ? I have it packaged over here https://launchpad.net/~rohangarg/+archive/experimental/+files/poppler_0.22.1-0ubuntu1~ppa2.dsc

Major Notes :

* so name bumped : libpoppler28 -> libpoppler34
* Fixed symbols

Rohan Garg (rohangarg) on 2013-02-28
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for the bug report and the work.

Did you check that all the rdepends build fine with the new version or will patching be needed over the archive? (we often have issues with cups and such)

With the archive work done this cycle the only way for a soname change to land the archive is to have all its reverse-depends transition, are you wanting to help on getting the transition through if it's started?

What's the main motivation for the update? We should better evaluate the cost/benefit ratio at this point of the cycle before starting a transition

Changed in poppler (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Rohan Garg (rohangarg) wrote :

Hi Sebastien
I am afraid I have not checked, is there a way I can do that? ( Some automated script that I can run ) . I would indeed require help with the transition, which is one of the reasons I filed a bug to track this so I get more pointers on how to do this the right way :)

The motivation being this bug : https://bugs.kde.org/show_bug.cgi?id=315031

I talked to upstream and they've asked me to update to the latest poppler.

Sebastien Bacher (seb128) wrote :

There is no standard tools for those transitions

you can basically
- run "apt-cache rdepends libpoppler28" or look at http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.raring/rdepends/poppler/libpoppler-dev to have an idea of the software concerned
- apt-get source those sources
- try to rebuild them

we might look at updating poppler but those are usually non trivial transition and need plannification and time

tags: added: upgrade-software-version
Rohan Garg (rohangarg) wrote :

Thanks!

I vaguely recall that there was a ubuntu transitioning team where one could upload all the reverse depends. Would it be possible to add me to that team?

Sebastien Bacher (seb128) wrote :

there is an "ubuntu+1" team (https://wiki.ubuntu.com/PlusOneMaintenanceTeam/Basics) but that's not a formal launchpad team, it's just made from people for opt-in to help. I will probably use this bug as a tracker for the transition, when I start looking at it (I will try to have a look next week), so you should get updates about what's happening

Rohan Garg (rohangarg) wrote :

Hi Sebastien
Any updates on this?

Sebastien Bacher (seb128) wrote :

that got deferred to next cycle, raring is frozen at this point and that's too much of a change for after feature freeze

Dmitry Shachnev (mitya57) wrote :

I've uploaded poppler 0.22.3 and some rdepends to ppa:mitya57/gnome-test, let's see how it goes (there is indeed a ~ubuntu-rebuilds team, but I'm not yet member of it). Not uploaded libreoffice, texlive and inkscape yet.

Dmitry Shachnev (mitya57) wrote :

Looks like all packages build fine:

- okular and inkscape had unrelated failures, fix branches are linked to this bug;
- libreoffice compiles fine, but has some test failures, looks unrelated to poppler, will leave that to Sweetshark.

Seb, will you sponsor the transition? Three branches are linked, for other packages only a changelog entry is needed (can do branches if you want).

Rohan Garg (rohangarg) wrote :

Since symbols were removed from okular, won't that require an ABI bump?

Dmitry Shachnev (mitya57) wrote :

Yes, you are right. But I have no idea of why these symbols got removed, will investigate later.

Sebastien Bacher (seb128) wrote :

@Dmitry: I can sponsor/help for the transition, but probably not this week, maybe it would be a good idea to start by preparing it in a ppa somewhere meanwhile?

I have already uploaded/copied all reverse dependencies to
ppa:mitya57/gnome-test, but they have a ~ppaX suffix. Should I remove the
suffix?

Sebastien asked me to subscribe ubuntu-sponsors, so here is a state of things for who will be sponsoring this:

- poppler: a branch is linked;

other packages need to be uploaded after poppler is published:

- okular, inkscape: need minor fixes, branches are linked (no need to bump okular abi version);

- cups-filters, evince, libreoffice, luatex, nepomuk-core, pdf2djvu, texlive-bin: need no-change rebuilds, take a changelog entry from okular for example.

summary: - Update poppler to 0.22.1
+ Update poppler to 0.22.3

Thanks for the work Dmitry!. The package should be ready to update, but it will be blocked until libreoffice rebuilds ... or as usual the new toolchain breaks the libreoffice builds, so I'm going to wait on the libreoffice guys to sort that to upload poppler so we don't get stucked.

summary: - Update poppler to 0.22.3
+ Update poppler to 0.22.4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package poppler - 0.22.4-0ubuntu1

---------------
poppler (0.22.4-0ubuntu1) saucy; urgency=low

  * New upstream release 0.22.4 (LP: #1135995).
    - Should fix the text selection problems (LP: #39890).
    - Should fix issues with PDF forms (LP: #1153517).
  * Drop all upstream patches and refresh other patches.
  * Change the soname version in package name: libpoppler28 -> libpoppler37.
  * Update symbols files.
  * Update debian/copyright (taken from Debian packaging Git).
 -- Dmitry Shachnev <email address hidden> Fri, 17 May 2013 17:07:14 +0400

Changed in poppler (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.