Sync pootle 2.0.0-2 (universe) from Debian testing (main)

Bug #501582 reported by Charlie_Smotherman on 2009-12-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pootle (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync pootle 2.0.0-2 (universe) from Debian testing (main)

Explanation of the Ubuntu delta and why it can be dropped:
Upstream now uses dh7 and python-central for the python2.6
transition.

Changelog entries since current lucid version 1.2.1-3ubuntu1:

pootle (2.0.0-2) unstable; urgency=low

  * debian/rules: Removed language ca@valencia. It currently blocks upgrades.

 -- Nicolas FRANCOIS (Nekral) <email address hidden> Sun, 13 Dec 2009 22:26:07 +0100

pootle (2.0.0-1) unstable; urgency=low

  [ Nicolas François ]
  * New upstream release
  * debian/rules: Cleanup. Removed commented code.
  * debian/contrib/cPootle: Removed. It does not apply anymore to the new
    version of Pootle.
  * debian/pootle.example: Removed debian/pootle.conf. The apache
    configuration should be updated.

  [ Rail Aliev ]
  Changes introduced in 1.3.0~beta4-1~ppa1:
  * debian/compat: Bumped to 7
  * debian/control:
    - Drop python-kid dependency.
    - Depend on libjs-jquery instead of internal one.
    - Updated debhelper build dependency
    - Depend on ${misc:Depends}
  * debian/rules:
    - Use debhelper 7 features to simplify the rules.
    - Remove upstream INSTALL file.
    - Remove duplicated COPYING file.
    - Use symlinked jquery.min.js from libjs-jquery instead of internal.
    - Remove unused debian/pootle.lintian-overrides and not needed
      debian/pootle.docs files.
  * debian/copyright: Do not mention where the license is located in the
    source package.
  * debian/pootle.dirs: Removed usr/share/lintian/overrides

 -- Nicolas FRANCOIS (Nekral) <email address hidden> Sun, 13 Dec 2009 14:12:44 +0100

pootle (2.0.0~rc2-1) UNRELEASED; urgency=low

  * New upstream release
  * debian/control: Updated version dependency of translate-toolkit to 1.5.0
  * debian/patches/packaging_install_outside_rootdir.patch: Disabled. The
    patched code was commented out upstream.

 -- Nicolas FRANCOIS (Nekral) <email address hidden> Sun, 06 Dec 2009 17:01:12 +0100

pootle (2.0.0~rc1-1) UNRELEASED; urgency=low

  * New upstream release
  * debian/patches/import_old_config.patch: Disabled. Bug fixed upstream and
    import of activation keys is not necessary.
  * debian/pootle.postinst: Fix import of project. The project directories
    need to be moved from /var/lib/pootle to /var/lib/pootle/po
  * debian/NEWS: Warn about this move of data files.

 -- Nicolas FRANCOIS (Nekral) <email address hidden> Sun, 06 Dec 2009 16:33:13 +0100

pootle (1.3.0~beta3-1) UNRELEASED; urgency=low

  * New beta upstream release
  * debian/control: Depend on python-django instead of python-jtoolkit
  * debian/control: python-django is a Pre-Depends since it is needed to
    configure the database.
  * debian/pootle.examples: The new configuration is localsettings.py. Removed
    Pootle/pootle.prefs and Pootle/users.prefs.
  * debian/patches/series:
    + debian/patches/debian_system_installation.patch: Removed. Another Debian
      customization might be needed, but it will be very different.
    + packaging_install_outside_rootdir.patch: When installing in a temporary
      root directory to prepare a package, the paths in localsettings.py are
      invalid. (--prefix should be checked.
    + debian/patches/import_old_config.patch: activationcode is now
      activation_key and is in the profile table, not user.
    + removed all patches. They should be re-checked.
  * debian/pootle.docs: There is no Pootle directory anymore.
  * debian/pootle.init: With the new version, start-stop-daemon needs to do
    the daemonization and creation of the pidfile.
  * debian/rules
    + new setup file
    + Cleanup should be updated
    + The new setup rules install files in the expected locations.
    + There is no Pootle directory anymore.
    + Run dh_pycentral with --noscripts because some code is needed between
      the dh_pycentral and dh_installinit blocks in the postinst script.
  * debian/pootle.postinst: Updated to the new /var/lib layout
  * debian/pootle.postinst: Configure the pootle database on installation and
    try to import users during updates.
  * debian/README.Debian: Update some Debian specific documentation.

 -- Nicolas FRANCOIS (Nekral) <email address hidden> Sat, 12 Sep 2009 01:12:43 +0200

pootle (1.2.1-4) unstable; urgency=low

  * debian/patches/translate_toolkit_1_4.patch: Fix failures with the new
    translate toolkit version (1.4).
  * debian/control: Standards-Version bumped to 3.8.3.
  * debian/pootle.dirs: do not distribute var/run/pootle. This is created by
    the init script.

 -- Nicolas FRANCOIS (Nekral) <email address hidden> Wed, 02 Sep 2009 21:07:46 +0200

Changed in pootle (Ubuntu):
importance: Undecided → Wishlist
Michael Bienia (geser) wrote :

Sync request ACKed.

Changed in pootle (Ubuntu):
status: New → Confirmed
Benjamin Drung (bdrung) wrote :

package builds, sync request ACK'd

tags: added: sync
James Westby (james-w) wrote :

[Updating] pootle (1.2.1-3ubuntu1 [Ubuntu] < 2.0.0-2 [Debian])
 * Trying to add pootle...
  - <pootle_2.0.0.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <pootle_2.0.0-2.dsc: downloading from http://ftp.debian.org/debian/>
  - <pootle_2.0.0-2.diff.gz: downloading from http://ftp.debian.org/debian/>
I: pootle [universe] -> pootle_1.2.1-3ubuntu1 [universe].

Changed in pootle (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers