/usr/bin/pollinate uses xxd but does not depend on vim-common

Bug #1656484 reported by Ivan Kozik on 2017-01-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pollinate (Ubuntu)
Low
Unassigned
Trusty
Low
Unassigned
Xenial
Low
Unassigned
Yakkety
Low
Unassigned
Zesty
Low
Unassigned

Bug Description

== SRU Impact ==

Pretty minimal, adding a dependency to a shell script.

== Regression Potential ==

xxd has presumably already available on machines that have pollinate, or it'd have been reported by now. VIM is rather ubiquitous... So, this is unlikely to have any effect for most users.

For the rest, things are a little more fun:
vim-common Recommends: vim | vim-gnome | vim-gtk | vim-gtk3 | vim-athena | vim-nox | vim-tiny
So, upgraders will get a full-blown vim pulled in. They'll also get a working pollinate.

== Test Case ==

In a minimal chroot, without vim-common & xxd:

# pollinate

BAD:
<13>Jan 14 03:34:27 pollinate[9317]: client sent challenge to [https://entropy.ubuntu.com/]
<13>Jan 14 03:34:28 pollinate[9317]: client verified challenge/response with [https://entropy.ubuntu.com/]
/usr/bin/pollinate: 79: /usr/bin/pollinate: xxd: not found

GOOD:
<13>Jan 14 03:49:29 pollinate[22771]: client sent challenge to [https://entropy.ubuntu.com/]
<13>Jan 14 03:49:31 pollinate[22771]: client verified challenge/response with [https://entropy.ubuntu.com/]
<13>Jan 14 03:49:31 pollinate[22771]: client hashed response from [https://entropy.ubuntu.com/]
<13>Jan 14 03:49:31 pollinate[22771]: client successfully seeded [/dev/urandom]

== Original report ==

# journalctl | grep pollinate
Jan 13 10:48:21 plato pollinate[1601]: client sent challenge to [https://entropy.ubuntu.com/]
Jan 13 10:48:22 plato pollinate[1626]: client verified challenge/response with [https://entropy.ubuntu.com/]
Jan 13 10:48:22 plato pollinate[1564]: /usr/bin/pollinate: 80: /usr/bin/pollinate: xxd: not found
Jan 13 10:48:22 plato systemd[1]: pollinate.service: Main process exited, code=exited, status=127/n/a
Jan 13 10:48:22 plato systemd[1]: pollinate.service: Unit entered failed state.
Jan 13 10:48:22 plato systemd[1]: pollinate.service: Failed with result 'exit-code'.

# dpkg -l | grep pollina
ii pollinate 4.23-0ubuntu1~16.04 all seed the pseudo random number generator

# lsb_release -rd
Description: Ubuntu 16.04.1 LTS
Release: 16.04

Related branches

description: updated
no longer affects: pollinate (Ubuntu Yakkety)
description: updated
Stefano Rivera (stefanor) wrote :
description: updated
Stefano Rivera (stefanor) wrote :
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pollinate - 4.24-0ubuntu2

---------------
pollinate (4.24-0ubuntu2) zesty; urgency=medium

  * Add missing dependency on xxd. (LP: #1656484)

 -- Stefano Rivera <email address hidden> Sat, 14 Jan 2017 14:41:35 +1100

Changed in pollinate (Ubuntu Zesty):
status: New → Fix Released

Hello Ivan, or anyone else affected,

Accepted pollinate into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pollinate/4.23-0ubuntu1~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pollinate (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Changed in pollinate (Ubuntu Yakkety):
status: New → Fix Committed
Chris J Arges (arges) wrote :

Hello Ivan, or anyone else affected,

Accepted pollinate into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pollinate/4.23-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Ivan Kozik (ludios) wrote :

I tested pollinate 4.23-0ubuntu1~16.04.1 in xenial-proposed and it seems to be working fine now.

tags: added: verification-done-xenial
Mathew Hodson (mathew-hodson) wrote :

The Trusty package that was uploaded references the wrong bug number.

That's why this bug wasn't automatically updated. That also means it isn't properly tracked on http://people.canonical.com/~ubuntu-archive/pending-sru.html. That report is used by the SRU team to determine which packages to add to -updates.

Changed in pollinate (Ubuntu Trusty):
importance: Undecided → Low
status: New → Fix Committed
Changed in pollinate (Ubuntu Xenial):
importance: Undecided → Low
Changed in pollinate (Ubuntu Yakkety):
importance: Undecided → Low
Changed in pollinate (Ubuntu Zesty):
importance: Undecided → Low
tags: added: packaging
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pollinate - 4.23-0ubuntu1~16.04.1

---------------
pollinate (4.23-0ubuntu1~16.04.1) xenial; urgency=medium

  * Add missing dependency on vim-common, for xxd. (LP: #1656484)

 -- Stefano Rivera <email address hidden> Sat, 14 Jan 2017 14:52:03 +1100

Changed in pollinate (Ubuntu Xenial):
status: Fix Committed → Fix Released
Jon Grimm (jgrimm) on 2017-03-02
tags: added: verification-needed-trusty verification-needed-yakkety
removed: verification-needed
Steve Langasek (vorlon) wrote :

Hello Ivan, or anyone else affected,

Accepted pollinate into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pollinate/4.23-0ubuntu1~14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Verified on yakkety.

tags: added: verification-done-yakkety
removed: verification-needed-yakkety
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pollinate - 4.23-0ubuntu1.1

---------------
pollinate (4.23-0ubuntu1.1) yakkety; urgency=medium

  * Add missing dependency on vim-common, for xxd. (LP: #1656484)

 -- Stefano Rivera <email address hidden> Sat, 14 Jan 2017 14:52:03 +1100

Changed in pollinate (Ubuntu Yakkety):
status: Fix Committed → Fix Released

As part of a recent change in the Stable Release Update verification policy we would like to inform that for a bug to be considered verified for a given release a verification-done-$RELEASE tag needs to be added to the bug where $RELEASE is the name of the series the package that was tested (e.g. verification-done-xenial). Please note that the global 'verification-done' tag can no longer be used for this purpose.

Thank you!

Scott Moser (smoser) wrote :

Below I launch a
 a.) trusty lxd container,
 b.) enable proposed
 c.) install pollinate from proposed
 d.) attempt to remove the package that provides /usr/bin/xxd

The output of 'd' shows that removal of vim-common would also
remove pollinate, showing that the dependency is correct.

$ name="t-1656484"
$ lxc launch ubuntu-daily:trusty t-1656484
Creating t-1656484
Starting t-1656484

$ sleep 10 # let it boot
$ mirror=http://archive.ubuntu.com/ubuntu
$ plist="/etc/apt/sources.list.d/proposed.list"
$ echo deb $mirror trusty-proposed main | lxc exec $name tee $plist
$ lxc exec "$name" sh -c "
   echo deb $mirror \$(lsb_release -sc) main > $plist"
$ lxc exec "$name" -- apt-get update -q
$ lxc exec "$name" -- apt-get install -q pollinate
...
Unpacking pollinate (4.23-0ubuntu1~14.04.2) over (4.23-0ubuntu1~14.04) ...
...
Setting up pollinate (4.23-0ubuntu1~14.04.2) ...

$ lxc exec "$name" -- which xxd
/usr/bin/xxd
$ lxc exec "$name" -- dpkg -S /usr/bin/xxd
vim-common: /usr/bin/xxd

$ lxc exec "$name" -- apt-get --dry-run remove vim-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libfreetype6 os-prober
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  pollinate ubuntu-minimal vim vim-common vim-tiny
0 upgraded, 0 newly installed, 5 to remove and 2 not upgraded.
Remv pollinate [4.23-0ubuntu1~14.04.2]
Remv ubuntu-minimal [1.325]
Remv vim [2:7.4.052-1ubuntu3.1]
Remv vim-tiny [2:7.4.052-1ubuntu3.1]
Remv vim-common [2:7.4.052-1ubuntu3.1]

tags: added: verification-done-trusty
removed: verification-needed-trusty
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pollinate - 4.23-0ubuntu1~14.04.2

---------------
pollinate (4.23-0ubuntu1~14.04.2) trusty; urgency=medium

  * Add missing dependency on vim-common, for xxd. (LP: #1656484)

 -- Steve Langasek <email address hidden> Thu, 30 Mar 2017 21:53:05 -0700

Changed in pollinate (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for pollinate has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers