Merge pollen from Debian unstable for 22.04

Bug #1946887 reported by Bryce Harrington
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pollen (Ubuntu)
Undecided
Paride Legovini

Bug Description

Upstream: 4.21
Debian: 4.21-5
Ubuntu: 4.21-5ubuntu3

Debian typically updates pollen every 5 months on average, but it was last updated 20.03 and looks overdue. Check back in on this monthly.

No upstream release is expected for pollen this cycle, based on upstream's release history.

### New Debian Changes ###

pollen (4.21-5) unstable; urgency=medium

  * debian/control: use dh12
  * debian/control: set standard to 4.5.0
  * debian/control: add XS-Go-Import-Path:
  * debian/rules: export $HOME

 -- Thorsten Alteholz <email address hidden> Sat, 28 Mar 2020 19:02:52 +0100

pollen (4.21-4) unstable; urgency=medium

  * upload source package

 -- Thorsten Alteholz <email address hidden> Mon, 19 Aug 2019 22:02:52 +0000

pollen (4.21-3) unstable; urgency=medium

  * debian/control: add salsa VCS URLs

 -- Thorsten Alteholz <email address hidden> Thu, 28 Feb 2019 20:25:58 +0100

pollen (4.21-2) sid; urgency=medium

  * debian/control: add dependencies
  * debian/postinst: don't touch anymore

 -- Thorsten Alteholz <email address hidden> Tue, 07 Feb 2019 20:25:58 +0100

pollen (4.21-1) sid; urgency=medium

  * first upload to Debian
  * debian/control: use dh11
  * debian/control: set standard to 4.3.0
  * debian/control: remove anerd mentions
  * debian/copyright: use https for copyright-format-uri
  * debian/rules: dh11 does not allow '--with systemd'
  * remove deprecated upstart init files
  * remove unused overrides

 -- Thorsten Alteholz <email address hidden> Tue, 05 Feb 2019 18:25:58 +0100

pollen (4.21-0ubuntu1) yakkety; urgency=medium

  * check_pollen:
    - note the number of short bytes in the error log message

 -- Dustin Kirkland <email address hidden> Tue, 13 Oct 2015 10:25:58 -0700

pollen (4.20-0ubuntu1) wily; urgency=medium

  * debian/pollen.upstart: LP: #1505473
    - remove typo in the upstart config which was preventing the service from starting
  * rebuild the packages for upload

 -- Dustin Kirkland <email address hidden> Tue, 13 Oct 2015 10:25:54 -0700

pollen (4.19-0ubuntu1) wily; urgency=medium

  * debian/pollen.upstart: LP: #1505473
    - remove typo in the upstart config which was preventing the service from starting

 -- Dustin Kirkland <email address hidden> Tue, 13 Oct 2015 10:21:08 -0700

pollen (4.18-0ubuntu1) wily; urgency=medium

  * pollen.go:
    - add the 'available' word to the log

 -- Dustin Kirkland <email address hidden> Wed, 09 Sep 2015 15:22:56 -0500

pollen (4.17-0ubuntu1) unstable; urgency=medium

  * debian/pollen.postrm:
    - clear out certificates on purge
  * debian/pollen.default:
    - quote the variable definition, for consistency
  * debian/pollen.postinst:
    - fix ssl cert generation, country must be <2 chars
  * debian/pollen.service:
    - put braces around environment variables; required to work at all
  * pollen.go, usr.bin.pollen:
    - log the entropy bits before and after the transaction

 -- Dustin Kirkland <email address hidden> Sat, 02 May 2015 18:39:13 -0500

pollen (4.16-0ubuntu1) vivid; urgency=medium

  [ Matthias Klose ]
  * debian/control:
    - Build everywhere

 -- Dustin Kirkland <email address hidden> Wed, 25 Mar 2015 09:44:01 -0500

pollen (4.15-0ubuntu1) vivid; urgency=medium

  [ Didier Roche ]
  * debian/control, debian/pollen.service, debian/rules:
    - Add systemd unit, following similar restart on failure and device
    checking logic
    - Bump Standards-Version

### Old Ubuntu Delta ###

pollen (4.21-5ubuntu3) hirsute; urgency=medium

  * No-change rebuild using new golang

 -- Steve Langasek <email address hidden> Wed, 11 Nov 2020 22:22:09 +0000

pollen (4.21-5ubuntu2) groovy; urgency=medium

  * No-change rebuild using new golang

 -- Steve Langasek <email address hidden> Tue, 22 Sep 2020 08:53:45 +0000

pollen (4.21-5ubuntu1) focal; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - d/control: add breaks/replaces on pollinate 4.33-1 which is when the
      check_pollen script was added to pollinate. Case #9 of package transition.
      [Can be dropped after 20.04]

 -- Gianfranco Costamagna <email address hidden> Mon, 30 Mar 2020 09:26:30 +0200

Paride Legovini (paride)
Changed in pollen (Ubuntu):
assignee: nobody → Paride Legovini (paride)
Bryce Harrington (bryce)
description: updated
Changed in pollen (Ubuntu):
milestone: none → ubuntu-21.12
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers