policykit authorization in KDE Lucid systemsettings is absent

Bug #575428 reported by Brian Harkness on 2010-05-04
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
polkit-kde-1 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: policykit-1

Perhaps this is on purpose, but the "Policykit Authorizations" is completely absent from KDE SystemSettings >> Advanced and there seems to be no way to bring up the dialogue that was present under Karmic to grant user privileges to disks, kpackagekit updates/upgrades,etc. Lost functionality for regular users. Internal partitions must now be added to fstab if a user wants to avoid being prompted for password for every mount/unmount.

I have done extensive web searching and posted on Kubuntu forums. This seems like a bug because a functional interface to user policies is no longer available.

Fresh install of Lucid on 3 laptops.

Jonathan Thomas (echidnaman) wrote :

KDE did not offer a authorization module for System Settings for PolicyKit-1. There is nothing to be done with this until KDE 4.5, when hopefully the module in playground gets merged into KDE.

Brian Harkness (maestro-bwh) wrote :

Well this makes me sad. Is there a workaround? I decompressed policykit-1-gnome and then looked for the executables on my system and tried to run them but I got errors about not knowing what session I was running. I'd even settle for modifying some files.

Brian Harkness (maestro-bwh) wrote :

p.s. the gnome package is installed by default.

affects: policykit-1 (Ubuntu) → polkit-kde-1 (Ubuntu)
Paul Loughman (snowhog) wrote :

This comment from bcooksley, KDE Community Forums Administrator:

"I believe this was due to changes in upstream libpolkit policy. I would suggest filing a critical bug with your distribution, as the system should be automatically configured out of the box to permit devices to be connected, mounted and accessed without issue, including encrypted devices."

oshunluvr (stuartksmith) wrote :

So the KDE Team says it's Kubuntu Teams' fault and Kubuntu Team says it's KDE's???

Jonathan Thomas (echidnaman) wrote :

That comment from the forums is about something different, probably about requiring a password to mount disks, which is not handled by policykit at all.

Brian Harkness (maestro-bwh) wrote :

In Karmic, there was an icon SystemSettings >> Advanced .. Policykit Authorizations

There one could do several things which allowed users access to

Hard disk partitions
Various KPackageKit features

And when those items were "modified" using this "tool," one could circumvent a user from needing to put in a password for:

mounting internal partitions
updating the package list
upgrading packages
installing packages

So that is what I noted. I am not sure why it was removed.

Gnome kept a frontend for this. Either KDE or Kubuntu removed it, or something is not working correctly.

I hope this clarifies what the issue is. Is this a bug, or an intentional removal of a means of granting password-less access to certain items in KDE?

Jonathan Thomas (echidnaman) wrote :

KDE was not able to port the config module from policykit to policykit-1 for KDE 4.4. It's a manpower issue. As I mentioned in the first comment, a module is in progress but wasn't ready for KDE 4.4.

Brian Harkness (maestro-bwh) wrote :

I understand, but this seems to be generating dialogue so should we mark it as "invalid" because of that issue?

Or, is there a workaround?

mcguire (jonathand131-gmail) wrote :

KDE SC 4.6.2 is out and still no news about the KDE System settings policykit module ?

Jonathan Thomas (echidnaman) wrote :

Polkit-KDE releases separately from the KDE SC.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in polkit-kde-1 (Ubuntu):
status: New → Confirmed
Gert van Dijk (gertvdijk) wrote :

This is still affecting fully updated 12.04 and 12.10 Kubuntu versions. I would be very grateful if this is going to be addressed some time.

Upstream documentation of KDE refers to it being present in the very base of KDE workspace since 4.3, but it seems to be moved to a separate project: https://projects.kde.org/projects/extragear/base/polkit-kde-kcmodules-1

I think we should report this to the Debian package maintainers as a request-for-packaging, shouldn't we?

Adolfo Jayme (fitojb) on 2013-02-03
tags: added: regression-release
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers