[Jaunty] Unable to unmount CD-drive

Bug #366863 reported by Vlad on 2009-04-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
policykit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: policykit

Hardware: Samsung P28, external CD/DVD drive LG GSA-E60N
Distribution: Xubuntu 9.04

The error appears then I push eject button on drive:

Failed to eject "/org/freedesktop/Hal/devices/storage_serial_HL_DT_ST_DVD_RAM_GSA_E60N_P01080121063519_0_0".
Given device "/org/freedesktop/Hal/devices/storage_serial_HL_DT_ST_DVD_RAM_GSA_E60N_P01080121063519_0_0" is not a volume or drive.

But when I unmount cd using file manager option, cd ejecting without any problem.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. If it is still an issue, we would appreciate if you could upload updated logs by running

apport-collect 366863
if you are using Karmic Koala (9.10) or newer, or

apport-collect -p 366863
if you are using Jaunty Jackalope (9.04)

Changed in policykit (Ubuntu):
status: New → Incomplete

Architecture: amd64
DistroRelease: Ubuntu 9.04
MediaBuild: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
NonfreeKernelModules: nvidia
Package: policykit 0.9-2ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-18-generic x86_64
UserGroups: adm admin cdrom dialout dip fuse lpadmin netdev plugdev sambashare

Ilya Almametov (ilya-almametov) wrote :

BTW I believe that this bug is duplicate of bug #195649

Vlad (lortwer) wrote :

It's not an issue for me since I've upgraded to karmic koala, everything works just fine now. I'm agree with dicka, this is should be the same bug as #195649.

Charlie Kravetz (charlie-tca) wrote :

bug 195649 is shown as fixed-released. That means there is a fix out already. If this is a duplicate, I can close it also as fixed. Thank you very much.

This bug was fixed in the package exo - 0.3.102-1ubuntu3

---------------
exo (0.3.102-1ubuntu3) karmic; urgency=low

  * debian/patches/05_exo-alt-eject.patch: fix failure to eject video cd/dvd &
    data cd/dvd using button (LP: #195649), taken from Xfce #2968.

 -- Lionel Le Folgoc <email address hidden> Wed, 09 Sep 2009 22:21:03 +0200

Changed in policykit (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers