Policykit does not work when logged in as root over ssh

Bug #187585 reported by Yves Le Berre
10
Affects Status Importance Assigned to Milestone
policykit (Ubuntu)
Medium
Unassigned

Bug Description

Another try : After login as 'normal' admin user, i spawned the command
ssh -X -tt root@localhost 'gnome-terminal' and i tried admin commands in
this new terminal. I got this message :

** (admin command:pid): CRITICAL **: Unable to find session for cookie

The unlock button is disabled (not checked as for root session) and the
others button or selection list are not all OK and changes are not
permitted.

Revision history for this message
James Westby (james-w) wrote :

Hi,

I am unable to reproduce your problem in my environment.

There has been a new upload of policykit in to hardy, but
the change doesn't seem related to the issue you are seeing.
However, if you have the newer package installed it would
be good if you could test it again.

Is there anything else unusual in your setup that you could
tell us?

Is this a fresh install of hardy?

Thanks,

James

Revision history for this message
Yves Le Berre (yleberre) wrote : Re: [Bug 187585] Re: Policykit does not answer to gnome message

Le samedi 23 février 2008 à 20:40 +0000, James Westby a écrit :
> Hi,
>
> I am unable to reproduce your problem in my environment.
>
> There has been a new upload of policykit in to hardy, but
> the change doesn't seem related to the issue you are seeing.
> However, if you have the newer package installed it would
> be good if you could test it again.
>
> Is there anything else unusual in your setup that you could
> tell us?
>
> Is this a fresh install of hardy?
>
> Thanks,
>
> James
>

Hello,

The impossibility to access admin settings through admin tools (even
being root) was "the" problem with my version of Hardy.

I upgraded from Gutsy to Hardy alpha 1 and later updates seemed OK
(update manager or apt-get)

Nothing unusual in my setup (Gnome and KDE installed).

The problem disappears after a fresh install from ISO alpha 4.
I have no backup so i can not help in testing anymore.

Yves

Revision history for this message
James Westby (james-w) wrote :

On Sun, 2008-02-24 at 08:00 +0000, Yves Le Berre wrote:
> Le samedi 23 février 2008 à 20:40 +0000, James Westby a écrit :
> Hello,
>
> The impossibility to access admin settings through admin tools (even
> being root) was "the" problem with my version of Hardy.

Ah, you were trying this as root?

That was the issue that was fixed with the latest upload.

If you can confirm that you were trying as root, then we know why
this has been fixed, but as you confirm that it is fixed that should
be enough.

Thanks,

James

James Westby (james-w)
Changed in policykit:
status: New → Fix Released
Revision history for this message
Yves Le Berre (yleberre) wrote :

Le dimanche 24 février 2008 à 11:21 +0000, James Westby a écrit :
> On Sun, 2008-02-24 at 08:00 +0000, Yves Le Berre wrote:
> > Le samedi 23 février 2008 à 20:40 +0000, James Westby a écrit :
> > Hello,
> >
> > The impossibility to access admin settings through admin tools (even
> > being root) was "the" problem with my version of Hardy.
>
> Ah, you were trying this as root?
>
> That was the issue that was fixed with the latest upload.
>
> If you can confirm that you were trying as root, then we know why
> this has been fixed, but as you confirm that it is fixed that should
> be enough.
>
> Thanks,
>
> James
>

Since i have installed Hardy ISO alpha 4, I log on the system as
'normal' admin user, (not root) and everything works OK in admin-tools
after unlocking and getting authorized.

After the last mail, i have authorized gdm access by root and i have
started a new root session. Idem, everything works OK in admin tools
Note: the unlock button is disabled (checked) but all the others are OK
and changes are permitted.
I was in this mode when i first reported the problem.
So, i think this issue is fixed.

Another try : After login as 'normal' admin user, i spawned the command
ssh -X -tt root@localhost 'gnome-terminal' and i tried admin commands in
this new terminal. I got this message :

** (admin command:pid): CRITICAL **: Unable to find session for cookie

The unlock button is disabled (not checked as for root session) and the
others button or selection list are not all OK and changes are not
permitted.

Yves

yleberre@9online.fr
<email address hidden>

Revision history for this message
James Westby (james-w) wrote :

On Sun, 2008-02-24 at 13:07 +0000, Yves Le Berre wrote:
> Another try : After login as 'normal' admin user, i spawned the command
> ssh -X -tt root@localhost 'gnome-terminal' and i tried admin commands in
> this new terminal. I got this message :
>
> ** (admin command:pid): CRITICAL **: Unable to find session for cookie
>
> The unlock button is disabled (not checked as for root session) and the
> others button or selection list are not all OK and changes are not
> permitted.

I think this is a separate issue then. I'm unsure about what would
be different in the ssh session to cause this.

Thanks,

James

description: updated
Revision history for this message
Yves Le Berre (yleberre) wrote : Re: Policykit does not work when logged in a root over ssh

similar to ssh try but with another message

When logged as 'normal' admin user, in a gnome-terminal, i became root with 'sudo -s' and tried admin commands. I got this message :

** (admin command:pid): CRITICAL **: Unable to lookup session information for process 'pid'

Changed in policykit:
status: Fix Released → New
Revision history for this message
Chris Roemmich (croemmich) wrote :

I am also having problems with this, only through a NoMachine session, which uses SSH sessions. View http://ubuntuforums.org/showthread.php?t=712006 for more information on the problem. I think this has to deal with the same bug.

Revision history for this message
ToddBrandt (todd-e-brandt) wrote :

I've just reproduced the same problem while running gnome-system-tools-2.22.0 time-admin from an ssh connection. Here are the relevant package versions:

consolekit 0.2.3-3ubuntu5
policykit 0.7-2ubuntu7
gnome-system-tools 2.22.0-0ubuntu9
system-tools-backends 2.6.0-0ubuntu7

I found the bug running on a samsung Q1 ultra with the latest ubuntu-mobile hardy ppa build. I'm in the midst of trying to fix the bug with the moblin-time application (a slimmed down version of time-admin) and it seems that time-admin doesn't work a whole lot better.

When I run from the terminal on the device or setup a desktop shortcut, it works the first time, then all subsequent times fail. I think this behavior is related to https://bugs.launchpad.net/ubuntu/+source/gnome-system-tools/+bug/188349

James Westby (james-w)
Changed in policykit:
importance: Undecided → Medium
Revision history for this message
goto (gotolaunchpad) wrote :

any work arout ive had to restart too many times to count
???

Revision history for this message
Marcelo Boveto Shima (marceloshima) wrote :

This bug is related/duplicated to bug https://bugs.edge.launchpad.net/policykit/+bug/221363

An workaround is available. See the Description.

Revision history for this message
jdege (jdege) wrote :

"An workaround is available. See the Description."

The same problem exists when remoting in via VNC or ssh -X.

The related/duplicated bug provides a workaround only for NX.

Changed in policykit (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers