Cannot install click packages on ISO installs of Ubuntu

Bug #1396611 reported by Michael Zanetti on 2014-11-26
88
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
policykit-unity8 (Ubuntu)
High
Ted Gould
unity8-desktop-session (Ubuntu)
Undecided
Unassigned

Bug Description

Installing packages from the Ubuntu Store fails under unity8-desktop-session mir.

The error can be reproduced using pkcon:

mzanetti@noneyet ~/.local/share/ubuntu-download-manager $ pkcon install-local Downloads/com.ubuntu.developer.robert-ancell.dotty_2_all.click
Installing files [=========================]
Loading cache [=========================]
Resolving dependencies [=========================]
Finished [=========================]
Installing files [=========================]
Loading cache [=========================]
Resolving dependencies [=========================]
Waiting for authentication [=========================]
Loading cache [=========================]
Resolving dependencies [=========================]
Committing changes [=========================]
Finished [=========================]
(Reading database ... 588050 files and directories currently installed.)
Preparing to unpack .../com.ubuntu.developer.robert-ancell.dotty_2_all.click ...
Click packages may not be installed directly using dpkg.
Use 'click install' instead.
dpkg: error processing archive /home/mzanetti/.local/share/ubuntu-download-manager/Downloads/com.ubuntu.developer.robert-ancell.dotty_2_all.click (--install):
 subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
 /home/mzanetti/.local/share/ubuntu-download-manager/Downloads/com.ubuntu.developer.robert-ancell.dotty_2_all.click

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in click (Ubuntu):
status: New → Confirmed
Nicholas Skaggs (nskaggs) wrote :

As a workaround for now, you install the packages using click install as suggested. You will also then need to use click register to register them under your user.

Michał Sawicz (saviq) on 2016-02-02
summary: - Can't install click packages with pkcon
+ Can't install apps from the store on unity8 desktop session
summary: - Can't install apps from the store on unity8 desktop session
+ Can't install apps from the store under a unity8 desktop session

Caveat: maybe we need to add a OnlyShowIn=Unity8 or something, so the apps don't show up under unity7, where they would run unconfined.

description: updated
Changed in click (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
dobey (dobey) wrote :

This is on xenial? Or vivid?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
dinamic (dinamic6661) wrote :

same here, on Xenial

see this bug

Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) wrote :

@dobey either - pkgcon defaults to dpkg management so fails installing a .click file.

@Emanuele please don't add tasks to bugs if you don't know where the problem lies, especially when you can see we're already working on fixing it.

no longer affects: unity8 (Ubuntu)
dobey (dobey) wrote :

Well, Xenial is getting the new PackageKit which doesn't support additional plug-ins, so clicks will not be installable there, no matter what is done.

There is nothing unity-scope-click can do about the configuration of packagekit, either. If you want to install clicks on a traditional PC, you will need to alter the the configuration (or install whatever is included on the phone images, which performs that alteration for you).

Why did you mark this as Invalid in click and re-assign to the scope? If any package should do anything about this, it is click itself, not the scope.

no longer affects: unity-scope-click (Ubuntu)
Changed in click (Ubuntu):
status: Invalid → Confirmed
summary: - Can't install apps from the store under a unity8 desktop session
+ Cannot install click packages on ISO installs of Ubuntu
Colin Watson (cjwatson) wrote :

There's a branch which removes the PackageKit dependency, which really ought to be landed:

  https://code.launchpad.net/~mvo/click/native-dbus

Changed in canonical-devices-system-image:
importance: Undecided → High
Changed in click (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
milestone: none → ww08-2016
Alejandro J. Cura (alecu) wrote :

We will not support installing clicks in the desktop via pkcon, since the desktop is moving to PK 1.0 which no longer supports the click plugin.

Pkcon will remain supported on the phone overlay until the phone images move to snap packages.

Changed in canonical-devices-system-image:
status: Confirmed → Won't Fix
Changed in click (Ubuntu):
status: Confirmed → Won't Fix
Changed in canonical-devices-system-image:
milestone: ww08-2016 → none
Alejandro J. Cura (alecu) wrote :

We are considering alternate approaches for this bug, so I'm reopening it.

Changed in click (Ubuntu):
status: Won't Fix → New
assignee: nobody → Ted Gould (ted)
Ted Gould (ted) wrote :

Bringing the bug up to speed. It seems that Xenial is not getting package kit 1.0, so the 0.8 version that has a click backend can remain in Xenial and can be used. And it is in the Xenial archive. So we're all good as far as repositories are concerned. But it doesn't work by default.

This is related to the python3-aptdaemon.pkcompat getting installed, which makes aptdaemon act the PackageKit backend instead of PackageKit itself. You can fix an image by doing "apt install packagekit" which will cause it to be removed. Then PackageKit itself will handle the pkcon commands and install the package correctly.

So that is the first part of this bug, and results in a system that can install Click package correctly. We need to figure out which seeds/packages it makes sense to put the appropriate package dependencies in.

The second part is that by default on the desktop PackageKit is using PolicyKit for a privilege request. Unity8 doesn't currently have a PolicyKit handler. We'll need to add that to the system so that an appropriate prompt can be shown on install.

David Planella (dpm) on 2016-04-05
tags: added: unity8-desktop
kevin gunn (kgunn72) on 2016-04-05
Changed in canonical-devices-system-image:
status: Won't Fix → Confirmed
Changed in click (Ubuntu):
status: New → In Progress
Sebastien Bacher (seb128) wrote :

Xenial got this change

https://launchpad.net/ubuntu/+source/unity-scope-click/0.1.1+16.04.20160318-0ubuntu1

"unity-scope-click (0.1.1+16.04.20160318-0ubuntu1) xenial; urgency=medium

  * Add dependency on packagekit so install of clicks will work on PCs."

it means that installing unity8/unity-scope-click is installing packagekit now (and removing the aptdaemon compat layer) which should make things work. Unity8 still doesn't have the prompting capability needed though it seems, maybe one workaround would be to add a plka file allowing local users to install clicks without have to auth, since clicks don't have access to system directories it's less likely to damage the system so it might be an ok thing to do there?

On, and we still plan to update packagekit at some point (next cycle hopefully) so we still need to make click stop using the deprecated interface...

On Wed, 2016-04-06 at 06:33 +0000, Sebastien Bacher wrote:
> Unity8 still doesn't have the prompting capability needed though it
> seems, maybe one workaround would be to add a plka file allowing
> local users to install clicks without have to auth, since clicks
> don't have access to system directories it's less likely to damage
> the system so it might be an ok thing to do there?
Prompting support up for review:
https://code.launchpad.net/~ted/unity8-policy-kit/initial-work/+merge/2
91371
Security was pretty adamant that it should prompt on a multi-user
system.

Ted Gould (ted) on 2016-05-06
affects: click (Ubuntu) → policykit-unity8 (Ubuntu)
Changed in policykit-unity8 (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8-desktop-session (Ubuntu):
status: New → Confirmed
kevin gunn (kgunn72) on 2016-06-23
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in unity8-desktop-session (Ubuntu):
status: Confirmed → Opinion
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers