Policy Kit auth dialogue lists me as "${My Name},,,,"

Bug #201495 reported by Alexander Jones on 2008-03-12
66
This bug affects 3 people
Affects Status Importance Assigned to Milestone
PolicyKit
Invalid
Undecided
Unassigned
policykit-gnome
Fix Released
Medium
policykit-gnome (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: policykit-gnome

It seems it just uses the comment field in /etc/passwd

alex:x:1000:1000:Alexander Jones,,,,:/home/alex:/bin/bash

I think the commas delimit a list of other fields which "adduser" prompts you for:

Enter the new value, or press ENTER for the default
 Full Name []:
 Room Number []:
 Work Phone []:
 Home Phone []:
 Other []:

I am not sure if this comment field style is the default, or if I created it somehow.

Regardless, gnome-about-me correctly parses it and names me "Alexander Jones".

ProblemType: Bug
Architecture: i386
Date: Wed Mar 12 17:52:25 2008
DistroRelease: Ubuntu 8.04
Package: policykit-gnome 0.7-2
PackageArchitecture: i386
SourcePackage: policykit-gnome
Uname: Linux 2.6.24-11-386 i686

Alexander Jones (alex-weej) wrote :
Alexander Jones (alex-weej) wrote :
Ben (benc) wrote :

Confirmed.

  ben@dev:~$ grep ben /etc/passwd
  ben:x:1000:1000:ben,,,:/home/ben:/bin/bash

This is http://bugzilla.gnome.org/show_bug.cgi?id=541945, but I can't be bothered registering the project to link this properly.

James Westby (james-w) on 2008-09-10
Changed in policykit-gnome:
importance: Undecided → Low
status: New → Triaged
Changed in policykit:
status: Unknown → New
James Westby (james-w) on 2008-09-11
Changed in policykit:
importance: Unknown → Undecided
status: New → Invalid
Changed in policykit-gnome:
status: Unknown → New
Alec Wright (alecjw) wrote :

Confirmed in intrepid (see dupe: bug 286148)

Michael Terry (mterry) wrote :

Here's a Jaunty debdiff that contains the patch in the upstream bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package policykit-gnome - 0.9-1ubuntu3

---------------
policykit-gnome (0.9-1ubuntu3) jaunty; urgency=low

  * Add 05-no-commas.patch: Don't show excess commas when displaying user's
    real name. (LP: #201495)

 -- Michael Terry <email address hidden> Thu, 22 Jan 2009 15:20:33 -0500

Changed in policykit-gnome:
status: Triaged → Fix Released
Changed in policykit-gnome:
status: New → Fix Released
Michael Terry (mterry) on 2009-10-28
tags: added: oem-services
Changed in policykit-gnome:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.