"Authorizations" shows untranslated, but it's translated in Launchpad

Bug #199255 reported by Ricardo Pérez López on 2008-03-06
18
Affects Status Importance Assigned to Milestone
policykit-gnome (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: policykit-gnome

System->Administration->Authorizations shows untranslated in my Spanish desktop, but it is translated in Launchpad:

https://translations.launchpad.net/ubuntu/hardy/+source/policykit-gnome/+pots/policykit-gnome/es/+translate

And the .mo file is in my system:

ricardo@kadath:~$ locate PolicyKit-gnome
/usr/share/locale-langpack/es/LC_MESSAGES/PolicyKit-gnome.mo
ricardo@kadath:~$

It seems that the translations are not been used inside the application.

Ricardo Pérez López (ricardo) wrote :
Ricardo Pérez López (ricardo) wrote :

The problem is still present with the latest langpacks updates in Hardy (20080323).

Martin Pitt (pitti) on 2008-03-26
Changed in policykit-gnome:
assignee: nobody → pitti
status: New → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

Martin: Unless you have figured this out before, the policykit-gnome tries to erronously load translations from a "messages.mo" instead of "PolicyKit-gnome.mo". This bug is similar to bug 204155 where nm-editor is shown as completely untranslated currently.

Timo Jyrinki (timo-jyrinki) wrote :

Ok, got this one solved too, just a correct place for bindtextdomain needed to be found. .dsc at my PPA: http://ppa.launchpad.net/timo-jyrinki/ubuntu/pool/main/p/policykit-gnome/policykit-gnome_0.7-2ubuntu1.dsc

Debdiff attached. Please sponsor to get also Authorizations dialog translations to be shown...

Martin Pitt (pitti) wrote :

I wonder why this works with the current Hardy package when using da_DK.UTF-8 (the only translation which upstream ships)?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package policykit-gnome - 0.7-2ubuntu1

---------------
policykit-gnome (0.7-2ubuntu1) hardy; urgency=low

  * Add 03-fix_i18n.patch to set the translation domain. (LP: #199255)

 -- Timo Jyrinki <email address hidden> Sun, 06 Apr 2008 21:36:10 +0300

Changed in policykit-gnome:
status: In Progress → Fix Released
Ricardo Pérez López (ricardo) wrote :

Thanks a lot, but there are still some strings which shows untranslated:

No
Admin Authentication (one shot)
Admin Authentication
Admin Authentication (keep session)
Admin Authentication (keep indefinitely)
Authentication (one shot)
Authentication
Authentication (keep session)
Authentication (keep indefinitely)
Yes

These strings are translated in Launchpad:

https://translations.launchpad.net/ubuntu/hardy/+source/policykit-gnome/+pots/policykit-gnome/es/+translate?start=79

Ricardo Pérez López (ricardo) wrote :

It's almost fixed :)

Changed in policykit-gnome:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

Can someone please tell me what exactly Timo's patch achieved? I do not see *any* difference between the versions with and without the patch.

Martin Pitt (pitti) wrote :

Also, I just uploaded fresh language packs. They should now contain the latest translations from Launchpad. Please let me know how that goes. Thank you!

Changed in policykit-gnome:
status: In Progress → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

I think another bug should be filed for the remaining bugs.
The previous version did not have any translations, the new version has most as Ricardo's screen shot shows.

Many languages (like German) do not have any translation in Rosetta: https://translations.launchpad.net/ubuntu/hardy/+source/policykit-gnome/+pots/policykit-gnome

Changed in policykit-gnome:
status: Incomplete → Fix Released

Timo Jyrinki [2008-04-14 12:22 -0000]:
> Many languages (like German) do not have any translation in Rosetta:
> https://translations.launchpad.net/ubuntu/hardy/+source/policykit-
> gnome/+pots/policykit-gnome

I'm aware of that. I tested it under da_DK.UTF-8, since Danish has
(almost?) full translations upstream. I didn't see a difference,
Danish translations worked fine without your patch.

Timo Jyrinki (timo-jyrinki) wrote :

Martin: Are you sure you actually selected some of the items in the Authorizations tool? I just tested building without the 03 patch, and not even da_DK.UTF-8 translations work, if you select some item. Eg. those Action/Identifier/Description, everything on the right side of the screen when an item is selected.

Some texts in the list on the left side are translated without the patch, but none on the right side.

If using the packages now in the archive, one needs the corresponding language pack to be installed to test the translations.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers