Ubuntu

[regression] hibernate no longer works on natty

Reported by Jesse Michael on 2011-01-31
116
This bug affects 19 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
High
Unassigned
policykit-desktop-privileges (Ubuntu)
High
Martin Pitt
Natty
High
Martin Pitt

Bug Description

Binary package hint: pm-utils

Recently, my EeePc 1005HA running the latest version of Natty lost the ability to hibernate. The "hibernate" option was removed from the shutdown menu and pm-hibernate and pm-suspend-hybrid don't do anything now. pm-suspend still suspends the laptop, but there are a number of problems with the suspend approach that make it unusable for me.

I regularly hibernate my laptop with very little battery life left and then toss it in my bag for several hours. Depending on what I'm doing, it's common for me to leave one of my laptops hibernated without power for days at a time. When suspended, both my Sony and Lenovo laptops still generate a small amount of heat. It's not much, but it still makes me uncomfortable with leaving them in the laptop sleeve in my bag for hours at a time. Hibernate has also saved me in the past when I've forgotten my power cord somewhere.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: pm-utils 1.4.1-4
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic i686
Architecture: i386
Date: Mon Jan 31 09:24:07 2011
InstallationMedia: Ubuntu-Netbook-Remix 9.10 "Karmic Koala" - Release i386 (20091028.4)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
SourcePackage: pm-utils

Jesse Michael (jesse.michael) wrote :
Kees Cook (kees) wrote :

Saving current running state is sometimes more important than how long it takes to unhibernate vs fresh boot.

There are plenty of additional use-cases:
- swapping batteries while on long flights
- hibernating before switching OSes in a dual-boot environment
- moving state between hardware (swapping failing hardware for good)

affects: pm-utils (Ubuntu) → linux (Ubuntu)
tags: added: regression-release
summary: - hibernate no longer works on natty
+ [regression] hibernate no longer works on natty
Kees Cook (kees) on 2011-01-31
Changed in linux (Ubuntu Natty):
milestone: none → natty-alpha-3
status: New → Confirmed

The feature was not hidden because it had no benefits, but rather it has very high costs. A lot can and does go wrong with hibernate, and for many people, it just never works. It's worth exploring whether we can get by without the feature.

In the meantime, the GUI is hidden, but the feature is not removed. You can tweak:
/var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

To return the GUI for hibernating if it's very important to you.

Bryce Harrington (bryce) wrote :

I used to use hibernate a lot myself, mainly for saving state. But I don't use it much anymore, mainly because it's slow and seems really unreliable. For the reasons jesse and kees listed, I would love to have the feature again, but as long as it remains slow and buggy it's not really in a usable state so seeing the command be hidden in the menu might help steer users away from problems. Glad to hear it's still configurable to some degree.

Also please note that a decision has not been taken on whether to hide Hibernate permanently or not, it is under discussion, though.

Kees Cook (kees) wrote :

@Rick I think you're misunderstanding. There are two issues: GUI and kernel. The GUI is configurable (whew), but the major issues is that hibernation was removed from the kernel, and is the bigger problem:

http://kernel.ubuntu.com/git?p=ubuntu/ubuntu-natty.git;a=commitdiff;h=2e5f0ea801534914c6747e953ed277fa16081602

Andy Whitcroft (apw) on 2011-01-31
Changed in linux (Ubuntu Natty):
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) on 2011-01-31
Changed in linux (Ubuntu Natty):
status: Confirmed → In Progress

Not confused, just trying to seperate the issues. Currently Hibernate is turned off in two levels:
1. Policy Kit hides it in the UI
2. The kernel removed support.

Let's keep this bug to discuss and track #1
Let's use bug #710877 to track re-enabling Hibernate in the Kernel, #2

Changed in linux (Ubuntu Natty):
assignee: Andy Whitcroft (apw) → nobody
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)

moving to polkit, and tracking the kernel issue in a separate bug report

affects: linux (Ubuntu Natty) → policykit-desktop-privileges (Ubuntu Natty)
Changed in policykit-desktop-privileges (Ubuntu Natty):
status: In Progress → Confirmed
Changed in policykit-desktop-privileges (Ubuntu Natty):
importance: Undecided → High
Andy Whitcroft (apw) on 2011-01-31
Changed in policykit-desktop-privileges (Ubuntu Natty):
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
Martin Pitt (pitti) wrote :

I mainly did this by request of the OEM team, as they said they disable hibernate on pretty much every shipped box, and because the kernel team said that they get tons of bug reports with it.

But then again, if some people still actually use it, I guess we could turn it back on by default. It is very easy to disable after all, by merely dropping a file into /var/lib/polkit-1/localauthority/* (for OEM) or /etc/polkit-1/localauthority/ (for users).

Steve Magoun (smagoun) wrote :

@Martin - the OEM team doesn't disable hibernate on every system. Rather, we put in a great deal of effort to ensure that it *does* work on systems that we enable. Hibernate support is a requirement of many OEM team customers, in order to avoid data loss in low-battery situations.

The OEM team does require a way to disable hibernate at the OS level for those systems which do not/support hibernate for some reason.

One proposal from OEM is to keep hibernate enabled at the kernel level, retain an option in gnome-power-manager to put the system into hibernate on a critical battery event, and remove hibernate from the rest of the UI (the power menu + shutdown dialog).

pioruns (pioruns) wrote :

I'm using hibernation on my 2 machines and it works fine. On one of
them, restoring from hibernation is even *slower* than clean boot (lots
of RAM).
But - nobody can measure my time of opening all my applications again,
with specific ones, which cannot be saved to restore as it was.
That's why i'm using hibernation: I don't need to care about all my
documents, games, web pages, terminal sessions. If I will loose that
long login session with weeks of uptime, I will be really confused. I
can't imagine at the moment to work totally without saving my session
using hibernation.
We need hibernation back.
Regards

Steve Magoun (smagoun) on 2011-02-02
Changed in oem-priority:
importance: Undecided → High
Tom Wright (twright-tdw) wrote :

I do not think that hibernation should be disable by default; it is used by many and is the only sane choice to avoid data loss when the battery runs out. If OEMs do not want to enable it then they should be easily able to disable it but it should remain available for the rest of us. If hibernation is causing issues on some hardware then that should be worked on, not simply ignored; I believe that the level of annoyance when it does not works only serves to highlight how essential it it, rather than making the case for disabling it.

Stephen Warren (srwarren) wrote :

> One proposal from OEM is to keep hibernate enabled at the kernel
> level, retain an option in gnome-power-manager to put the system
> into hibernate on a critical battery event, and remove hibernate from
> the rest of the UI (the power menu + shutdown dialog).

That doesn't make a lot of sense to me. Hibernate either works well enough to be used or it doesn't. What it's used for doesn't affect how well it works.

If it works well enough to "save the day" in an emergency low-power situation, it works well enough for general use. Put another way, if it doesn't work well enough for general use, suddenly using it in an emergency low-power situation is only going to make that situation worse, by hanging or crashing during hibernate, or failing to resume anyway, and hence it doesn't help vs. a complete shutdown in that situation.

/me, who uses hibernate a lot, and was very glad it works perfectly on his new laptop under Maverick, with a few suspend/resume script tweaks, so I can save state an arbitrarily long amount of time not using the system and without it being plugged in.

David Kastrup (dak) wrote :

I have an IBM Thinkpad T41. For me, the screen under X11 is borked terminally after suspend. Suspend also would not be an option most of the time because when I stop working to freeze state, this can be for quite long, and I don't keep my power supply running while the computer is off -- a waste of energy.

The current policies in the GUI and, temporarily in the kernel, are a complete nuisance. Hibernation also refuses to work when using the appropriate ACPI button. Another nuisance.

If I need to hibernate in a hurry, having to switch to a virtual terminal, typing sudo hibernate and keying in my password is quite an aggravation. It also means that the system will come up without asking for a password. The "Suspend" entry in the power menu will, as explained, cause my screen to go bad. All that works in that case is switching to a text console and shutting down the computer (switching back to the X11 console does not work).

I don't understand what gains are there from disabling/hiding functionality. How developers can assume that they know the working options (and their relative merits and problems) better than the person working with the computer, is beyond me.

Who are we trying to protect? People that persist using a non-working way of shutting down their computer time after time, even though they see other options in the menu and keep breaking things in the same, non-working manner, time after time?

Nobody as stupid as that is protectable from his folly.

John Baptist (jepst79) wrote :

If we're having such problems with hibernation, I'd say there is some value to be had in considering shipping Ubuntu with TuxOnIce, which provides better performance and compatibility. It looks like it will never be fully integrated into the vanilla kernel, so it is up to distributions.

Martin Pitt (pitti) wrote :

Steve, thanks for the heads-up. I'm happy to re-enable it by default then, it's easy enough for the OEM team to disable it by placing a single file into /var/lib/polkit-1/...

Changed in policykit-desktop-privileges (Ubuntu Natty):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
Matt Price (matt-price) wrote :

Just echoing Johns (comment 315) here. There's a very reliable tuxonice ppa currently tracking maverick; I use it on all my machines and none of them currently has hibernation problems. The old argument against tuxoice was that the diff against the upstream kernel was too onerous to maintain. But if itworks, and upstream hibernation doesn't, it's not clear that this argument is really very compelling. Comments already demonstrate that hibernation is an essential feature for many people in many use cases, especially since suspend-to-ram is broken for many users.
ppa:
deb http://ppa.launchpad.net/tuxonice/tuxonice-testing/ubuntu maverick main
deb http://ppa.launchpad.net/tuxonice/ppa/ubuntu maverick main

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package policykit-desktop-privileges - 0.4

---------------
policykit-desktop-privileges (0.4) natty; urgency=low

  * Re-enable hibernation by default. It can be disabled by dropping a file
    into /etc/polkit-1/localauthority/ by OEMs if desired. (LP: #710796)
 -- Martin Pitt <email address hidden> Fri, 25 Feb 2011 12:16:02 +0100

Changed in policykit-desktop-privileges (Ubuntu Natty):
status: In Progress → Fix Released
Chris Van Hoof (vanhoof) on 2011-03-07
Changed in oem-priority:
status: New → Fix Released
Martin Pitt (pitti) wrote :

Note that in precise this will be disabled again, and be a wontfix. Please see bug 812394.

Changed in policykit-desktop-privileges (Ubuntu):
milestone: natty-alpha-3 → none
status: Fix Released → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers