Apt Daemon asks for root password instead of sudo authentication

Bug #661839 reported by Rich on 2010-10-16
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
policykit-1 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: aptdaemon

For a few weeks, some authentication, mostly seems related to Apt Daemon, has required me to authenticate using the root password, instead of asking for sudo authentication.

I have seen it in the following cases:
1) Installing software from the Software Center
2) To mount a drive

Recent install of Maverick, updated twice from Koala. All fresh updates.

Problem started before update to Maverick.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: aptdaemon 0.31+bzr506-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Oct 16 13:55:21 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/sbin/aptd
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcEnviron:

SourcePackage: aptdaemon

Rich (richardvallee) wrote :
Rich (richardvallee) wrote :

Oups. As indicated in the gathered info, the original install was Lynx. I forgot I had re-installed.

Sebastian Heinlein (glatzor) wrote :

Are you part of the admin group? This seems to be a general policykit bug or mis-configuration, since it also appears with mounting devices.

affects: aptdaemon (Ubuntu) → policykit-1 (Ubuntu)
Rich (richardvallee) wrote :

My groups are (lampadmin is my user)

lampadmin sudo www-data

After the Maverick upgrade I got the "Root Password" prompt for updates.
I found my userid wasn't on the "admin" line in /etc/group.
Putting it in fixed it.
I'd been in the admin group before, but I run a mixed NIS and local environment with overrides so perhaps the upgrade script got confused somewhere.

unmacaque (unmacaque) wrote :

I have the same installation history as the bug reporter, upgraded to Maverick from Lucid.

Regardless of being in admin group and having passwordless sudo enabled, I always get asked for a password when trying to install or remove packages via Software Center, whereas "sudo apt-get..." and Update Manager don't ask for a password.

A workaround is to edit the policykit action "org.debian.apt.install-or-remove-packages" and change "allow_active" from "auth_admin_keep" to "yes". However, everytime Software Center is updated, the workaround gets overwritten.

Rich (richardvallee) wrote :

Since adding my user to the "admin" group the problem seems resolved.

Unsure how the user was removed from it, but that looks like the cause.

unmacaque (unmacaque) wrote :

I have re-added my only user account to the admin group although it already was. Now, Update Manager also asks me for a password.

This can be reproduced when booting a Maverick live CD, creating a new user and adding him to the admin group. Then logout and login as the newly created user and try to install packages via Software Center. You will get asked for a password despite the "%admin ALL=(ALL) NOPASSWD: ALL" line in /etc/sudoers.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in policykit-1 (Ubuntu):
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

This might be related to bug 793792.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers