pkexec needs ability to retain user HOME and possibly other environment

Bug #189517 reported by David Balažic on 2008-02-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gparted (Ubuntu)
Wishlist
Unassigned
policykit-1 (Ubuntu)
Undecided
Unassigned

Bug Description

Launching gui applications with pkexec strips their environment bare and points the home directory to /root, causing the gnome file dialog to behave badly. It needs a way to preserve the user home the way sudo and gksu do.

Curtis Gedak (gedakc) wrote :

By default, GParted saves the gparted_details.htm file to the /root directory.

This directory exists directly under the top level directory "/".

Andreas Noteng (andreas-noteng) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in gparted (Ubuntu):
status: New → Incomplete
Jan Claeys (janc) wrote :

As Curtis explained: the default save location is the home directory of the user 'root' (because GParted is run as root), and the problem of the original reporter seems to be that he doesn't know how to navigate to that directory (which is not his fault, as it's not obvious for somebody new too Ubuntu/linux).

The real solution for such problems is not running GParted as root, but that would require a complete redesign of GParted...

Curtis: maybe offering to open the HTML page in the default browser could be useful too?
(Or maybe we can save the log to /var/log/* by default?)

Changed in gparted (Ubuntu):
status: Incomplete → Confirmed
Changed in gparted (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Phillip Susi (psusi) wrote :

Closing since this was just a case of user confusion.

Changed in gparted (Ubuntu):
status: Triaged → Invalid
David Balažic (xerces8) wrote :

It is not about the user, but the software, see image.

Left is the Save dialog from gparted, right the Open dialog from Firefox (most other programs have it the same, also the Save dialog in Firefox list the same Places)

(images taken on latest release: ubuntu 13.04 , gparted 0.12.1-2)

Changed in gparted (Ubuntu):
status: Invalid → New
Phillip Susi (psusi) on 2013-06-24
summary: - Open/save file dialog places wrong
+ pkexec needs ability to retain user HOME and possibly other environment
description: updated
Changed in gparted (Ubuntu):
status: New → Invalid
Changed in policykit-1 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers