Incorrect permissions on polkit-agent-helper-1

Bug #1767981 reported by Laura Czajkowski on 2018-04-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
policykit-1 (Ubuntu)
Undecided
Unassigned

Bug Description

I upgraded from 17.10 to 18.04, I ran
czajkowski@penny:~$ sudo do-release-upgrade
czajkowski@penny:~$ sudo apt update && sudo apt dist-upgrade
czajkowski@penny:~$ sudo apt install update-manager-core

Upgrade then started and about 4 mins the Error 1 image appeared, Incorrect permissions on /usr/lib/policykit-1/polkit-agent-helper-1(needs to be setuid root)

a few mins later the login appeared for me to enter my password, it would not recognise my password Error 2.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.17
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Mon Apr 30 10:21:49 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-12-20 (1226 days ago)
InstallationMedia: Ubuntu 14.04.1 LTS "Trusty Tahr" - Release amd64 (20140722.2)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: Upgraded to bionic on 2018-04-29 (0 days ago)

Laura Czajkowski (czajkowski) wrote :
Laura Czajkowski (czajkowski) wrote :
tags: added: artful2bionic
Brian Murray (brian-murray) wrote :

I'm sorry it is not clear to me but when did you see the error message? Was it during the release upgrade process, after you ran "do-release-upgrade" or was it when you did some apt operations after the upgrade completed successfully?

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Laura Czajkowski (czajkowski) wrote :

Hi Brian

sorry I wasn't clearer, it happened as soon after the upgrade gui was launched and then the dialogue box appeared over the text box that was updating in the background

Brian Murray (brian-murray) wrote :

I don't believe this has anything to do with the release upgrader, it just happened to be the process which caused you to notice that the permissions were incorrect.

affects: ubuntu-release-upgrader (Ubuntu) → policykit-1 (Ubuntu)
Changed in policykit-1 (Ubuntu):
status: Incomplete → New
summary: - Incorrect permissions on upgrade found for login
+ Incorrect permissions on polkit-agent-helper-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers