Unable to start polkit-gnome-authentication-agent-1

Bug #1411895 reported by Djordje Marjanovic
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
policykit-1 (Ubuntu)
Undecided
Unassigned

Bug Description

After update from Precise to Trusty, I am unable to perform administrative tasks through GUI (restart/shutdown, network management, mount USB disks, start Synaptics package manager, etc.)

Even though it is checked in Startup Applications, polkit-gnome-authentication-agent-1 is not running.

After attempting to manually start it, it displays the following error:

(polkit-gnome-authentication-agent-1:4759): polkit-gnome-1-WARNING **: Unable to determine the session we are in: No session for pid 4759

I am using LightDM as the display manager.

Description: Ubuntu 14.04.1 LTS
Release: 14.04
Kernel: 3.13.0-44-generic
Package: policykit-1: 0.105-4ubuntu2 (amd64)

Revision history for this message
Djordje Marjanovic (djordje-m) wrote :

I filed this bug because I have tried all known workarounds, but failed to resolve the problem:

- appended to /etc/pam.d/lightdm
       session required pam_loginuid.so
       session required pam_systemd.so

- ran 'sudo pam-auth-update --force'

- reinstalled policykit-1 and libpam packages

- reinstalled 'sudo' package

- removed Skype

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in policykit-1 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers