System Log will not launch

Bug #1034156 reported by Jorge Rama on 2012-08-07
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
policykit-1 (Ubuntu)
Wishlist
Unassigned

Bug Description

After updating to quantal my menu entry named System Log will not launch

After checking the menu entry properties I saw that the associated command was 'pkexec gnome-system-log'.

If I run this command at a terminal window, it will ask for my password and then it shows the gnome-system-log window as is supposed to.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: linux-image-3.5.0-8-generic 3.5.0-8.8
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.4-0ubuntu6
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: jorgehsrama 2173 F.... pulseaudio
Date: Tue Aug 7 22:14:04 2012
HibernationDevice: RESUME=UUID=8170e72c-3b1e-48b8-9dd3-f93f30791e6a
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
Lsusb:
 Bus 001 Device 004: ID 0011:7788
 Bus 001 Device 002: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC Webcam / CNF7129
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: ASUSTeK Computer Inc. K50IN
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 VESA VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-8-generic root=UUID=0a689cc1-8f39-4ff3-8297-878646ffed1b ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-8-generic N/A
 linux-backports-modules-3.5.0-8-generic N/A
 linux-firmware 1.88
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to quantal on 2012-07-28 (10 days ago)
dmi.bios.date: 09/21/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 218
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K50IN
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr218:bd09/21/2009:svnASUSTeKComputerInc.:pnK50IN:pvr1.0:rvnASUSTeKComputerInc.:rnK50IN:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr:
dmi.product.name: K50IN
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

Jorge Rama (jorgehsrama) wrote :
description: updated
Brad Figg (brad-figg) on 2012-08-07
Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Are you referring to the "System Log Viewer"?

Changed in linux (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
Jorge Rama (jorgehsrama) wrote :

Yes

affects: linux (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Low → Undecided
status: Confirmed → New
Omer Akram (om26er) on 2012-08-16
affects: unity (Ubuntu) → unity-lens-applications (Ubuntu)
Omer Akram (om26er) on 2012-08-16
no longer affects: unity-lens-applications
affects: unity-lens-applications (Ubuntu) → policykit-1 (Ubuntu)
Changed in policykit-1 (Ubuntu):
importance: Undecided → Wishlist
quiricada (raraland) wrote :

12.10 beta 2
gnome-session-fallback

from menu, cannot launch system log viewer

from terminal, 'pkexec gnome-system-log' launch correctly

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in policykit-1 (Ubuntu):
status: New → Confirmed
Marco Scannadinari (zheoffec) wrote :

Also affects me on a non-beta Quantal release. `pkexec gnome-system-log` and `gksu(do) gnome-system-log` works fine from terminal. Please fix!

Marco Scannadinari (zheoffec) wrote :

BTW I don't think this should be assigned to the wishlist as any new users have no idea that they should launch from the terminal, and would think that Ubuntu is a buggy system.

Launching gnome-system-log from the Dash produce the following message in .xsession-errors:
 Refusing to render service to dead parents.

It seems that orphans have not the right to ask for a password...

Bill Turner, wb4alm (wb4alm) wrote :

I do not understand assignment to "wishlist"...

I have always been able to launch from menu, now I can't...

...therefore this is not a "wishlist", but is a bug introduced with 12.04.1 and continued in 12.10

furthermore, the message in .xsession-errors: "Refusing to render service to dead parents." indicates that something is just plain wrong!

Jorge Rama (jorgehsrama) wrote :

This bug seems to have been fixed. I recently tried in my two systems (Ubuntu 12.10 32 bit and 64 bit) and System Log launches correclty after asking for the password.

Bill Turner, wb4alm (wb4alm) wrote :

I have "applied" all outstanding updates for my Ubuntu 12.10 system as of 12:57 (noon) 5 Dec 2012...

When system log is launched, no password prompt is made, no messages are displayed, etc.

Therefore the bug has still not been fixed.

(I can how ever run the program from a terminal session. - it jkust will not run when launched from the main menu.)

/s/ Bill Turner, wb4alm

Seems to works well in 13.04

Bill Turner, wb4alm (wb4alm) wrote :

Yes, syslog will start in 13.04, but the time and date stamps are still invisable unless you actually select (highlight) one or more lines. This means that it still is not as usuable as it should be.

/s/ Bill Turner, wb4alm

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers