Ubuntu

Kubuntu desktop missing dependency on polkit-kde-1

Reported by Gert van Dijk on 2011-10-04
This bug report is a duplicate of:  Bug #833058: Muon-updater doesn't ask for password. Edit Remove
72
This bug affects 15 people
Affects Status Importance Assigned to Milestone
policykit-1-gnome (Ubuntu)
Undecided
Unassigned
polkit-kde-1 (Ubuntu)
Undecided
Unassigned

Bug Description

After installing KDE on regular Ubuntu using "apt-get install kubuntu-desktop", I am not able to change any of the system settings requiring administrative privileges due to the lack of the installation of "polkit-kde-1". It will fail with an error as described here below with Muon when I expected to be shown a dialogue to enter my password.

Also other KDE software is affected. For example, when applying changes in Muon package manager, I get the error "This operation cannot continue since proper authorisation was not provided". Installing polkit-kde-1 solves this issue and a proper dialogue is opened to ask for the (sudo) password.

Steps to reproduce (example):
- Install regular Ubuntu
- Install "kubuntu-desktop" using apt-get
- During installation choose KDM as default login manager
- Log in in the KDE desktop
- Open (for example) System settings -> Login Screen. change Appearance, click the "Apply" button.

Expected result: An authorization dialogue shown to enter my password, after which the changed would be applied.

Actual result: Error dialogue: "This operation cannot continue since proper authorisation was not provided". None of the changes were applied.

After manual installation of polkit-kde-1, logging out and logging back in, the result is as expected.

My recommendation is to fix the dependencies/recommends of the KDE suite in Ubuntu in order to overcome this usability issue.

Ubuntu version: Oneiric Ocelot (11.10) fresh install, updated to date on 2011-10-04.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: kubuntu-desktop 1.239
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Tue Oct 4 19:38:05 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110930)
ProcEnviron:
 LANGUAGE=en_GB:en_US:en
 LANG=nl_NL.utf8
 SHELL=/bin/bash
SourcePackage: kubuntu-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Gert van Dijk (gertvdijk) wrote :
Jonathan Thomas (echidnaman) wrote :

The libqapt-runtime package (which handles package installation for Muon including authentication) depends on polkit-kde-1 or policykit-1-gnome, meaning that either package being installed handles the dependency. As long as the polkit-gnome-authentication-agent-1 process is running, the gnome polkit gui will work for this.

It seems, though, that the polkit-gnome-authentication-agent-1 service is restricted to auto-starting in gnome...
The KDE polkit auth agent service also only starts in KDE, too.

At first this would seem to be desirable, as to not have two authentication daemons running at once, but polkit takes care of this. Only one agent can be registered as the authentication agent, so attempting to start the KDE agent after the GNOME agent has started would just cause the KDE agent to quit since it could not register itself with polkit. This means that the OnlyShow=Gnome/KDE entry in the autostart files are unnecessary, and the frontends could be truly interchangeable if this was dropped, fulfilling the current assumptions that the packaging makes.

affects: kubuntu-meta (Ubuntu) → polkit-kde-1 (Ubuntu)
Jonathan Thomas (echidnaman) wrote :

(In the short-term adding the dependency for kubuntu-desktop would at least cover the usecase of GNOME user installing KDE via kubuntu-desktop, but it wouldn't cover a GNOME user installing a single KDE app that needs polkit)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in policykit-1-gnome (Ubuntu):
status: New → Confirmed
Changed in polkit-kde-1 (Ubuntu):
status: New → Confirmed
Kevin O'Brien (zwilnik) wrote :

I am having the same problem in trying to install software in Muon. But when I tried to install polkit-kde-1 on the command line I get the message that I already have the latest version.

Marek Mizanin (marek-mizanin) wrote :

I cannot install another software in kubuntu 11.10 due to "This operation cannot continue since proper authorisation was not provided". I think it stared after I canceled dialog which requested authorization for installing new software in Muon Software Center.

Marek Mizanin (marek-mizanin) wrote :

PC restart fixed my problem.

Andrea Gangemi (andrea-gangemi) wrote :

seem that i solved by simply installing polkit-kde1 by shell:
sudo apt-get install polkit-kde-1

JohnMilton (adam-x-gernhard) wrote :

I had the same problem, and as Andrea Gangemi stated : "sudo apt-get install polkit-kde-1" and then a reboot solved my problem.

Jim Wharton (jamesawharton) wrote :

When I try to install via sudo, apt reports that I already have the latest version. I rebooted as suggested, but I still get the same error.

César (cesar-pastorini) wrote :

This bug seems to affect the KDE by its shutdown/restart/logout services, once I can't do that through KDE.

Rael (rael-gc) wrote :

I installed Kubuntu LTS 12.04, and this bug affected me. I tried change configuration for Login Screen, and I was getting the permission error.

It was solved only installing polkit-kde-1 package.

This package should come in the default Kubuntu install, at least in the standalone install from CD/DVD.

Dima Ryazanov (dima-gmail) wrote :

I've been using Kubuntu for a while, and this started happening to me just today. I'm using 13.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers