Merge with Debian 0.101-2

Bug #777366 reported by Mathieu Trudel-Lapierre on 2011-05-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
policykit-1-gnome (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: policykit-1-gnome

Merge with Debian 0.101-2:

policykit-1-gnome (0.101-2) unstable; urgency=low

  * Upload to unstable.

policykit-1-gnome (0.101-1) experimental; urgency=low

  * New upstream release.
  * Update patches
    - Drop debian/patches/01-fix-autostart.patch, obsolete.
    - Drop debian/patches/03-po-pt_BR.patch, merged upstream.
    - Refresh debian/patches/02-select-default-user.patch to apply cleanly.
  * Switch from cdbs to dh.
  * Bump debhelper compatibility level to 8.
  * Install documentation using debian/policykit-1-gnome.docs.
  * Ship a copy of the old autostart file for the PolicyKit authentication
    agent. It was removed upstream in preparation for GNOME3 which starts its
    own authentication agent.

policykit-1-gnome (0.99-2) unstable; urgency=low

  [ Robert Ancell ]
  * Drop 03-dialog-focus.patch. PolicyKit does not allow non-root applications
    to set details (LP: #685655)

  [ Michael Biebl ]
  * Upload to unstable.

Related branches

Changed in policykit-1-gnome (Ubuntu):
status: New → In Progress
importance: Undecided → Wishlist
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Debdiff with Ubuntu 99-1ubuntu4

Changed in policykit-1-gnome (Ubuntu):
status: In Progress → Confirmed
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody

Debdiff with Debian 0.101-2

tags: added: patch
Martin Pitt (pitti) on 2011-05-16
Changed in policykit-1-gnome (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package policykit-1-gnome - 0.101-2ubuntu1

---------------
policykit-1-gnome (0.101-2ubuntu1) oneiric; urgency=low

  [ Mathieu Trudel-Lapierre ]
  * Merge with Debian unstable; remaining changes (LP: #777366):
    - 04-autorestart.patch: Add gnome session restart support to ensure we
      always have an authentication agent running. To be forwarded upstream.
    - 06-authentication-failure-string.patch: Improve error message displayed
      when authentication fails.
    - Tell the .desktop file for the authentication agent to auto-restart the
      agent in case of failure.
    - Use dh-autoreconf to reconfigure after applying patches, especially for
      04-autorestart.patch.
  * debian/patches/05-appindicator.patch: dropped, partly due to upstream
    dropping status icon support. This also fixes usability bug (LP: #550502).
  * debian/patches/04-autorestart.patch: refreshed to apply cleanly.

  [ Martin Pitt ]
  * debian/rules, debian/control: Build against GTK 3.

policykit-1-gnome (0.101-2) unstable; urgency=low

  * Upload to unstable.

policykit-1-gnome (0.101-1) experimental; urgency=low

  * New upstream release.
  * Update patches
    - Drop debian/patches/01-fix-autostart.patch, obsolete.
    - Drop debian/patches/03-po-pt_BR.patch, merged upstream.
    - Refresh debian/patches/02-select-default-user.patch to apply cleanly.
  * Switch from cdbs to dh.
  * Bump debhelper compatibility level to 8.
  * Install documentation using debian/policykit-1-gnome.docs.
  * Ship a copy of the old autostart file for the PolicyKit authentication
    agent. It was removed upstream in preparation for GNOME3 which starts its
    own authentication agent.

policykit-1-gnome (0.99-2) unstable; urgency=low

  [ Robert Ancell ]
  * Drop 03-dialog-focus.patch. PolicyKit does not allow non-root applications
    to set details (LP: #685655)

  [ Michael Biebl ]
  * Upload to unstable.
 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 16 May 2011 15:15:29 +0200

Changed in policykit-1-gnome (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers