Ubuntu

relocation error in poedit binary

Reported by Tiago Hillebrandt on 2010-07-28
80
This bug affects 16 people
Affects Status Importance Assigned to Milestone
poedit (Ubuntu)
Medium
Unassigned
Nominated for Lucid by manuna

Bug Description

I'm using the Maverick Meerkat and the system is up-to-date (July, 27). I got the following error when tried to start the application:

$ poedit
poedit: relocation error: poedit: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

affects: ubuntu → poedit (Ubuntu)
description: updated
Václav Slavík (vslavik) wrote :

This means that Poedit was compiled against wxWidgets version newer than what is installed on the system where you try to run it. This may be because you downgraded wxGTK package(s), because the poedit package has incorrect dependencies (allowing older wxGTK version to satisfy them) or there was some other mistake when packaging it.

summary: - poedit crashes at startup
+ relocation error in poedit binary
Sergey Basalaev (sbasalaev) wrote :

You need to downgrade libwxbase2.8-0

Václav Slavík (vslavik) wrote :

This error happens when libwxbase2.8 is older than it should be, downgrading usually *causes* it, not fixes...

Desperados (lfrosini) wrote :

I have the same problem.

2010-07-30 05:20 keltezéssel, Serguey Basalaev írta:
> You need to downgrade libwxbase2.8-0
>
>
They will be cleared by the downgrade:

audacity
damnvid
dvdstyler
filezilla
libwxbase2.8-0
libwxgtk2.8-0
libwxsvg0
poedit
python-wxgtk2.8
python-wxtools
python-wxversion
rapidsvn
svn-workbench...

csola

Sergey Basalaev (sbasalaev) wrote :

Well, I'm using lucid and downgrading libwxbase2.8-0 from 2.8.10.1-0ubuntu1.1 to 2.8.10.1-0ubuntu1 solved the problem.

Sergey Basalaev (sbasalaev) wrote :

Problem itself appeared after upgrading wxWidgets

Václav Slavík (vslavik) wrote :

That the only explanation I can think of is that 2.8.10.1-0ubuntu1 was incorrectly compiled without version info, but ubuntu1.1 was fixed. But the presence of "WXU_2.8" in that error indicates otherwise: that version-script is used. But that's even more weird, because it should read "WXU_2.8.5" (see e.g. bug #412772).

Looking at the actual packages, it appears to be the case. Here's the symbol in ubuntu1.1 version:

$ objdump -T /usr/lib/libwx_baseu-2.8.so.0.6.0 | grep _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_
000e5cb0 g DF .text 0000014b WXU_2.8.5 _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_

That's what it should be and how wxWidgets developers intended it. If you look at the older ubuntu1 version of wxbase, though, it's broken:

$ objdump -T /usr/lib/libwx_baseu-2.8.so.0.6.0 | grep _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_
000e5e00 g DF .text 0000014b WXU_2.8 _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_

In fact, somebody removed *all* 2.8.x versioned symbols in ubuntu1. How that feat was accomplished, I have no idea. But now that that screwup was corrected in ubuntu1.1, apps compiled against ubuntu1 will break. The only fix I can think of is for Ubuntu to rebuild *all* packages dependent on wxWidgets *and* make them depend on ubuntu1.1 version of wxWidgets packages. Because there's no way this bug affects Poedit only.

yxmline (yxmline) wrote :

Recompile poedit with libwxbase2.8-0 from 2.8.10.1-0ubuntu1.1 to 2.8.10.1-0ubuntu1

csola48 (mail-csordaslaszlo) wrote :

2010-08-02 01:42 keltezéssel, yxmline írta:
> Recompile poedit with libwxbase2.8-0 from 2.8.10.1-0ubuntu1.1 to
> 2.8.10.1-0ubuntu1
>
>
Pls. whereby? :(

Kamus (kamus) on 2010-08-04
Changed in poedit (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed

pgadmin3 and codelite are also affected by this error (bug 610975) I'm adding a task to the other report and mark this one as duplicate.

Changed in poedit (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers