podbrowser depends on Gtk2::Ex::PodViewer 0.16, but 0.14 in Gutsy

Bug #122392 reported by Jeffrey Ratcliffe
6
Affects Status Importance Assigned to Milestone
gscan2pdf
Invalid
Undecided
Unassigned
gscan2pdf (Ubuntu)
Low
Emmet Hikory
libgtk2-ex-podviewer-perl (Ubuntu)
Low
Emmet Hikory
podbrowser (Ubuntu)
Medium
Emmet Hikory

Bug Description

Binary package hint: podbrowser

Installed podbrowser, started it from the command line:

Gtk2::Ex::PodViewer version 0.16 required--this is only version 0.14 at /usr/bin/podbrowser line 13.
BEGIN failed--compilation aborted at /usr/bin/podbrowser line 13.

Revision history for this message
Jeffrey Ratcliffe (jeffreyratcliffe) wrote :

I guess this also means that dependencies are defined wrongly in the packaging.

Revision history for this message
Arthur Loiret (arthur.loiret) wrote :

libgtk2-ex-podviewer-perl 0.17 uploaded on REVU: http://revu.tauware.de/details.py?upid=5797
podviewer uploaded on REVU: http://revu.tauware.de/details.py?upid=5796

Revision history for this message
Emmet Hikory (persia) wrote :

Thanks for your work on this. Could you please attach the diff of the debian directories to this bug, to aid reviewing? Either interdiff of the diff.gz files, or diff -urN of the unpacked debian/ directories would be welcome. I've unsubscribed ubuntu-universe-sponsors pending this additional information.

Changed in podbrowser:
assignee: nobody → arthur.loiret
status: New → Incomplete
Revision history for this message
Arthur Loiret (arthur.loiret) wrote :

Hello, here is a diff between the debian/ dirs of libgtk2-ex-podviewer-perl 0.14 and 0.17 (upgraded package)

Revision history for this message
Arthur Loiret (arthur.loiret) wrote :

And here is a debdiff for podbrowser_0.10-0ubuntu2.

Thanks Emmet.

Emmet Hikory (persia)
Changed in podbrowser:
assignee: arthur.loiret → persia
importance: Undecided → Medium
status: Incomplete → In Progress
Revision history for this message
Emmet Hikory (persia) wrote :

Thanks for these. Both look really clean. Please avoid using REVU where a debdiff is sufficient. When using REVU for new upstream versions, please include a comment pointing to the bug. Before the new ibgtk2-ex-podviewer-perl is uploaded, would you mind checking to see if gscan2pdf also needs an update? Separately, podbrowser seems to have already been updated: does it need another refresh, or is it good now?

Changed in podbrowser:
assignee: persia → arthur.loiret
Changed in libgtk2-ex-podviewer-perl:
assignee: nobody → arthur.loiret
importance: Undecided → Low
status: New → In Progress
Revision history for this message
Jeffrey Ratcliffe (jeffreyratcliffe) wrote : Re: [Bug 122392] Re: podbrowser depends on Gtk2::Ex::PodViewer 0.16, but 0.14 in Gutsy

On 09/07/07, Emmet Hikory <email address hidden> wrote:
> ibgtk2-ex-podviewer-perl is uploaded, would you mind checking to see if
> gscan2pdf also needs an update? Separately, podbrowser seems to have

I am the author of gscan2pdf. I've just tested podviewer 0.17 (used by
gscan2pdf for displaying the help page) and everything seems fine.

Regards

Jeff Ratcliffe

Revision history for this message
Arthur Loiret (arthur.loiret) wrote :

I'me sorry Emmet but as I've just changed my mail address so I can't put comments on REVU for now. I've upgraded gscan2pdf, thanks a lot Jeff for your feedback ;-)

About podbrowser: the package is already good, but I'd rather specify the version of libgtk2-ex-podviewer-perl in the Depends, do you want me to do the same thing for gscan2pdf ?

Here is a diff of gscan2pdf debian directories.

Thank you for your time, have a nice day.

Arthur.

Revision history for this message
Emmet Hikory (persia) wrote :

Fixed upstream (see upstream comment below).

Changed in podbrowser:
assignee: arthur.loiret → persia
Changed in libgtk2-ex-podviewer-perl:
assignee: arthur.loiret → persia
Changed in gscan2pdf:
assignee: nobody → persia
importance: Undecided → Low
status: New → In Progress
status: New → Fix Released
Revision history for this message
Emmet Hikory (persia) wrote :

All uploaded. Thanks for the investigation and solution.

Changed in libgtk2-ex-podviewer-perl:
status: In Progress → Fix Committed
Changed in podbrowser:
status: In Progress → Fix Committed
Changed in gscan2pdf:
status: In Progress → Fix Committed
Revision history for this message
Arthur Loiret (arthur.loiret) wrote :

libgtk2-ex-podviewer-perl (0.17-0ubuntu1) gutsy; urgency=low

  * New upstream release
  * Fix Depends of podbrowser (LP: #122392)
  * Update Maintainer field to match Debian-Maintainer-Spec

 -- Arthur Loiret <email address hidden> Wed, 27 Jun 2007 22:11:08 +0200

Changed in libgtk2-ex-podviewer-perl:
status: Fix Committed → Fix Released
Revision history for this message
Jeffrey Ratcliffe (jeffreyratcliffe) wrote :

The log says failed to build
(http://launchpadlibrarian.net/8339947/buildlog_ubuntu-gutsy-i386.libgtk2-ex-podviewer-perl_0.17-0ubuntu1_FAILEDTOBUILD.txt.gz):

make[1]: Entering directory `/build/buildd/libgtk2-ex-podviewer-perl-0.17'
make[1]: *** No rule to make target `distclean'. Stop.
make[1]: Leaving directory `/build/buildd/libgtk2-ex-podviewer-perl-0.17'
make: [clean-unpatched] Error 2 (ignored)
dh_clean build-stamp install-stamp
 debian/rules build
dpatch apply-all
#dpatch call-all -a=pkg-info >patch-stamp #I don't understand this one.
echo patched > patch-stamp
dh_testdir
/usr/bin/perl Makefile.PL INSTALLDIRS=vendor
MakeMaker FATAL: prerequisites not found (Locale::gettext not installed)

               Please install these modules first and rerun 'perl Makefile.PL'.
make: *** [build-stamp] Error 9
******************************************************************************
Build finished at 20070709-1457
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/libgtk2-ex-podviewer-perl-0.17

But the same is true of the other (Feisty, Edgy, etc.) builds of podviewer.

Revision history for this message
Jeffrey Ratcliffe (jeffreyratcliffe) wrote :

*DISCLAIMER* I am a bit of a newbie at packaging - just packaging my
own app for the last 9 months. But:

I downloaded libgtk2-ex-podviewer-perl_0.17-0ubuntu1.dsc
libgtk2-ex-podviewer-perl_0.17.orig.tar.gz and
libgtk2-ex-podviewer-perl_0.17-0ubuntu1.diff.gz from Launchpad, then:

$ dpkg-source -x libgtk2-ex-podviewer-perl_0.17-0ubuntu1.dsc
$ cd libgtk2-ex-podviewer-perl-0.17/
$ debuild

[snip]

Now running lintian...
E: libgtk2-ex-podviewer-perl_0.17-0ubuntu1_i386.changes:
bad-distribution-in-changes-file gutsy
W: libgtk2-ex-podviewer-perl source: out-of-date-standards-version
3.6.2 (current is 3.7.2)

[snip]

That is a minor point. But the resulting package installed fine. I
then downloaded the new podbrowser_0.10-0ubuntu2_all.deb from
launchpad and installed it. The dependencies are still incomplete. I
get:

$ podbrowser
Can't locate Gtk2/Ex/PrintDialog.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at /usr/bin/podbrowser line 15.
BEGIN failed--compilation aborted at /usr/bin/podbrowser line 15.

I can't find this packaged anywhere for Debian.

Changed in podbrowser:
status: Fix Committed → Fix Released
Changed in gscan2pdf:
status: Fix Committed → Fix Released
status: Fix Released → Invalid
Revision history for this message
Jeffrey Ratcliffe (jeffreyratcliffe) wrote :

On 09/07/2007, Arthur Loiret <email address hidden> wrote:
> Here is a diff of gscan2pdf debian directories.

I've just filed bug 137908 asking for gscan2pdf 0.9.16-1, now in
Debian, to be synced.

https://bugs.launchpad.net/ubuntu/+source/gscan2pdf/+bug/137908

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers