HP DeskJet 7xxC, 820C or 1000C does not work out of the box

Bug #52814 reported by Pascal De Vuyst on 2006-07-12
74
Affects Status Importance Assigned to Milestone
cdebconf (Ubuntu)
Medium
Unassigned
pnm2ppa (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: pnm2ppa

Several people have reported that their HP DeskJet 710C, 712C, 720C, 722C, 820C or 1000C did not work in Ubuntu.

I searched for the cause for this problem by debugging foomatic-rip and looking at the command line that is generated:

renderer command: gs -q -dNOPAUSE -dPARANOIDSAFER -dBATCH -r600 -sDEVICE=ppmraw
 -sOutputFile=- - | pnm2ppa -v 1000 -B 2 -t 10 -b 150 -l 10 -r 10 -x 160 -y 50
-i - -o -

We see that the model is selected with v switch depending on the PPD we used, in this case -v 1000 (meaning HP DeskJet 1000C).

pnm2ppa is a filter converting pnm images to ppa data for a specific printer model.

I did some tests with pnm2ppa filter using a pnm image and found what the problem is, see table and explanation below.

Command that I used to test:
$ pnm2ppa -v 1000 -B 2 -t 10 -b 150 -l 10 -r 10 -x 160 -y 50 -i ~/Desktop/test.pnm -o ~/Desktop/test-v1000.ppa

/etc/pnm2ppa.conf: version 0 | version 710,712,720,722,820,1000 | version <unknown>
=======================================
no -v | empty ppa file | ppa output for 7xx*, 820 or 1000 | no ppa file
-v 710,712,720,722,820,1000 | ppa output for 7xx*, 820 or 1000 | no ppa file

* The generated ppa output for 710, 712, 720 and 722 is identical

The problem is that the Ubuntu package pnm2ppa has a default configuration /etc/pnm2ppa.conf that contains a blanc version line (version <unknown> in the table). This results in no ppa output being generated so nothing is printed. Therefore the default /etc/pnm2ppa.conf should be altered to contain version 0 or version <modelnumber>, enabling the above mentioned printer models to work out of the box, without initial user configuration, with the foomatic PPDs. The default upstream pnm2ppa.conf contains a version 0 line. Please change this so these printers work out of the box, which is the expected behaviour.

I'm going to mark the different bugs reported for this problem as duplicates of this one.

More readable table with pnm2ppa test results.

Confirmed by duplicates.

Changed in pnm2ppa:
status: Unconfirmed → Confirmed
Ante Karamatić (ivoks) wrote :

Great job Pascal! Thank you.

Could owners/reporters of these bugs try commenting out version line, so that:

version
#version 720 # 710, 712, 722 also acceptable
#version 820
#version 1000

becomes:

#version
#version 720 # 710, 712, 722 also acceptable
#version 820
#version 1000

in /etc/pnm2ppa.conf. After this change, try to print and report results.

Thank you.

Changed in pnm2ppa:
importance: Untriaged → Medium
Ante Karamatić (ivoks) wrote :

When I install pnm2ppa in dapper, I get "version 710" as default. Hm...?

Commenting out the version line (#version) makes pnm2ppa generate ppa output for 7xx, I forgot to add that in my test result table. Commenting out the version line was reported to be working by hansen12345 in bug #37660.

Ante wrote:
> When I install pnm2ppa in dapper, I get "version 710" as default. Hm...?

pnm2ppa is installed by default in dapper, it is a dependency of meta package ubuntu-desktop.
But you have an interesting point here, I did:
$ sudo apt-get install --reinstall pnm2ppa
and after reinstallation my /etc/pnm2ppa.conf also contains "version 710" by default.

My original /etc/pnm2ppa.conf after dapper installation contained "version " causing printers not to work. So there appears to be another cause for this problem...
Could it be that there is a problem with ubuntu installer causing misconfiguration of pnm2ppa package, how do we find out?

On Thu, 13 Jul 2006 19:27:24 -0000
Pascal De Vuyst <email address hidden> wrote:

> pnm2ppa is installed by default in dapper, it is a dependency of meta
> package ubuntu-desktop. But you have an interesting point here, I did:
> $ sudo apt-get install --reinstall pnm2ppa
> and after reinstallation my /etc/pnm2ppa.conf also contains "version
> 710" by default.

Same happend to me :/

> My original /etc/pnm2ppa.conf after dapper installation contained
> "version " causing printers not to work. So there appears to be
> another cause for this problem... Could it be that there is a problem
> with ubuntu installer causing misconfiguration of pnm2ppa package,
> how do we find out?

This is why I'm delaying patch for this, since pnm2ppa isn't broken,
but something other is.

--
Ante Karamatic | 0xD3BDA225 | 0x0A4A0161
<email address hidden> | <email address hidden> | ivoks.blogspot.com
"Tomorrow is my day off, so please stay off the powder!"

Ante,

I just installed Edgy Knot 1.
The problem seems to be solved in Edgy, /etc/pnm2ppa.conf now contains "version 710" by default.
I did some research and think the problem was solved in debconf 1.5.0, see this upstream debian bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=355251
According to the changelog Colin Watson seems to have applied this change, Colin can you confirm my assumption?

kbm (keithmantell) wrote :

Hi,

Just to let you know that my HP 720C has stopped working and has been replaced. (The replacement Epson Stylus CX6600 installed fine!)

So no more bugs from me on this topic.

Bas v.d. Wiel (bas-kompasmedia) wrote :

Same goes for me. Fixed the pnm2ppa.conf to istate 'version 710' instead of just 'version' and all problems were gone, using a DeskJet 710C.

Joe Lynch (joe-e-lynch) wrote :

Hmm, I've tried all of this (commenting out the version line, using version 0, using version 712) on my Hp Deskjet 712c printer, but then again I'm not quite sure that I have the same error. All the jobs I print are completed, just nothing comes out of the printer. Does anyone know why this happens??

@Joe

I don't think you have the same problem as described here.

You better file a support request here: https://launchpad.net/distros/ubuntu/+tickets

Feel free to subscribe me to your support request so I can assist you in finding a solution. If it turns out to be a bug we can still create a bug report for it.

Colin Watson,
I believe this bug was fixed in debconf 1.5.0, can you confirm this?
Can we mark this bug "fix released" for Edgy?

Colin Watson (cjwatson) wrote :

Pascal, I'm afraid that this has absolutely nothing to do with that debconf bug. Try again.

Colin Watson (cjwatson) wrote :

The problem here is that there is no Default for the pnm2ppa/printer_model template. debconf's Noninteractive frontend handles a select question with no default by picking the first one; cdebconf doesn't do this (which I think is arguably a cdebconf bug, so I've opened a cdebconf task on this bug). The practical effect of this is that installs from the desktop CD will generate a correct pnm2ppa.conf, since debconf is used to build the live filesystem, while installs from the alternate install CD will not, since debconf passes everything through to cdebconf there.

You can and should work around this problem in pnm2ppa by supplying a Default, like this:

 Template: pnm2ppa/printer_model
 Type: select
 Choices: 710, 712, 720, 722, 820, 1000
+Default: 710
 _Description: What model of HP Deskjet printer do you use?
  The pnm2ppa printer filter behaves differently depending upon which HP
  DeskJet model you use. Choose your model of printer for the default
  configuration file /etc/pnm2ppa.conf.

Changed in cdebconf:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

pnm2ppa (1.12-14ubuntu1) edgy; urgency=low

  * Supply a Default for pnm2ppa/printer_model (closes: Malone #52814).

 -- Colin Watson <email address hidden> Mon, 16 Oct 2006 11:19:29 +0100

Changed in pnm2ppa:
assignee: nobody → kamion
status: Confirmed → Fix Released
xtknight (xt-knight) wrote :

Well, I'm having other troubles getting my Deskjet 722C to work out of the box. It looks like the pnm2ppa conf file problem was fixed, but my printer is not detected at all in Edgy! Turns out I had to do 'sudo modprobe ppdev' before I did 'gksu gnome-cups-add'. Then, it finally detected my local parallel port printer.

xtknight, what you observed is bug #29050. Please report your problem there.

Changed in cdebconf:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions