SRU pmdk into Bionic

Bug #1781269 reported by Andreas Hasenack on 2018-07-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pmdk (Ubuntu)
Undecided
Andreas Hasenack
Bionic
Undecided
Unassigned

Bug Description

[Impact]
The support for Intel NVDIMM technology requires both kernel and userspace components. The kernel components have landed in 4.15 and are available in Bionic. In order for users to take advantage of NVDIMMs in their deployments, the following userspace packages are also needed in Bionic:

ndctl -- Utility library for managing the libnvdimm (non-volatile memory device) sub-system in the Linux kernel.
Upstream project: https://github.com/pmem/ndctl

PMDK -- persistent memory toolkit
Upstream project: https://github.com/pmem/pmdk/

This SRU is about pmdk; ndctl is being handled in bug #1781268. Both should be accepted at the same time.

This SRU falls under the hardware enablement category.

[Test Case]
* Install pmdk-tools
sudo apt install pmdk-tools

* download the three dep8 test scripts:
wget https://git.launchpad.net/~usd-import-team/ubuntu/+source/pmdk/plain/debian/tests/daxio-version https://git.launchpad.net/~usd-import-team/ubuntu/+source/pmdk/plain/debian/tests/manage-pools https://git.launchpad.net/~usd-import-team/ubuntu/+source/pmdk/plain/debian/tests/rpmemd-version

* execute them and verify exit status, which should be zero:
sh ./daxio-version; echo $?
sh ./manage-pools; echo $?
sh ./rpmemd-version; echo $?

More detailed testing can be executed if the appropriate hardware is available.

[Regression Potential]
These are NEW packages for bionic. They were accepted into the archive after a lengthy review. They are lintian clear, with appropriate overrides or an explanation in README.source.

These packages include libraries, which could inadvertently become new dependencies. If a package has support for pmdk, for example, but it was always disabled because there was no pmdk in the archive, it could now be inadvertently enabled merely by having the lib*-dev package(s) installed.

Similarly, code paths in existing packages that would never have been traversed because of the lack of pmdk support, now could be exposed.

[Other Info]
Since the package doesn't exist in bionic, I don't think I can make an MP.

Here is the branch that represents the bionic source package, though:
https://code.launchpad.net/~ahasenack/ubuntu/+source/pmdk/+git/pmdk/+ref/bionic-pmdk. It's just cosmic with a changelog update for this sru.

You should be able to build a source package from that. Alternatively, you can download it from ppa:canonical-server/nvdimm, but the packages there have a ~ppaN suffix, so keep that in mind.

The git master branch at https://git.launchpad.net/~ahasenack/ubuntu/+source/pmdk/log/?h=master shows all the work that was put into this package to make it suitable for Ubuntu inclusion.
The bug at https://bugs.launchpad.net/bugs/1752378 also contains a lengthy history and discussions about some of the finer details, and is linked to from files in debian/* where further explanation was necessary about some behavior.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pmdk (Ubuntu):
status: New → Confirmed
description: updated
Changed in pmdk (Ubuntu):
milestone: ubuntu-18.04.1 → bionic-updates
description: updated
summary: - SRU into Bionic
+ SRU pmdk into Bionic
description: updated
Robie Basak (racb) wrote :

Sponsored. Now in Bionic NEW.

Hello Andreas, or anyone else affected,

Accepted pmdk into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pmdk/1.4.1-0ubuntu1~18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pmdk (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Michael Reed (mreed8855) wrote :

I have executed the tests after installing the packages and the tests all passed

ubuntu@R740xd-nvme-57:~/tests/pmdk_test$ sh ./daxio-version; echo $?
+ dpkg-query -f ${Version}\n -W pmdk-tools
+ cut -d - -f 1
+ pkg_version=1.4.1
+ echo pmdk-tools package version: 1.4.1
pmdk-tools package version: 1.4.1
+ daxio -V
+ daxio_version=1.4.1
+ echo daxio version: 1.4.1
daxio version: 1.4.1
+ [ 1.4.1 = 1.4.1 ]
+ echo Version match, OK
Version match, OK
0

ubuntu@R740xd-nvme-57:~/tests/pmdk_test$ sh ./manage-pools; echo $?
Testing pool type blk
Pool create
Pool info
Pool check
Pool remove

Testing pool type log
Pool create
Pool info
Pool check
Pool remove

Testing pool type obj
Pool create
Pool info
Pool check
Pool remove

Tests succeeded.
0

ubuntu@R740xd-nvme-57:~/tests/pmdk_test$ sh ./rpmemd-version; echo $?
+ dpkg-query -f ${Version}\n -W pmdk-tools
+ cut -d - -f 1
+ pkg_version=1.4.1
+ echo pmdk-tools package version: 1.4.1
pmdk-tools package version: 1.4.1
+ rpmemd -V
+ cut -d -f 3
+ rpmemd_version=1.4.1
+ echo rpmemd version: 1.4.1
rpmemd version: 1.4.1
+ [ 1.4.1 = 1.4.1 ]
+ echo Version match, OK
Version match, OK
0

Łukasz Zemczak (sil2100) wrote :

Thanks Michael! Is there any other testing you want to perform on the packages? Since the verification-done-bionic tags haven't been set yet.

Andreas Hasenack (ahasenack) wrote :

I got access to hardware, will take it for a spin there and report back.

Brian Murray (brian-murray) wrote :

Andreas - Have you gotten a chance to test this?

Andreas Hasenack (ahasenack) wrote :

Not yet, the maas server over there is offline (these machines are behind a vpn) and that means I'll have to use the virtual console to install ubuntu on them, over a vpn. I just came back from post-sprint pto, and I have it on my list for today or tomorrow. Probably tomorrow, given the beta release testing going on right now.

Andreas Hasenack (ahasenack) wrote :

I got access to the hardware, but to be honest I'm not sure what to test specifically in the case of pmdk. I used it mostly for ndctl smoke testing, for bug #1781268. I suppose the testconfig.sh file in src/test can be tweaked for the real hardware case, but I don't have that info at the moment. I believe the DEP8 tests as executed as part of this SRU are good enough.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pmdk - 1.4.1-0ubuntu1~18.04.1

---------------
pmdk (1.4.1-0ubuntu1~18.04.1) bionic; urgency=medium

  * Backport to bionic (LP: #1781269)

 -- Andreas Hasenack <email address hidden> Fri, 03 Aug 2018 11:02:48 -0300

Changed in pmdk (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for pmdk has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in pmdk (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers