wacom intuos 3 not working after resume -- Must unplug and plug in the device

Bug #961255 reported by Philip Guyton on 2012-03-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pm-utils (Ubuntu)
Low
Unassigned

Bug Description

After a suspend resume cycle in 12.04 beta 1 fully updated as of 21 March Wacom Intuos 3 stylus doesn't work.

Works find when plugged in live and when already plugged in on power up and when unplugged and plugged in again whilst system is on. But if left plugged in and suspend resume cycle takes place then although the wacom module is still loaded afterwards and the "System Settings" "Wacom Graphics Tablet" section shows the tablet as plugged in the stylus (I only have a stylus) is non functional, ie no X cursor effect.

Entered as bug agains pm-utils as not sure where to put it and that is where I found the fix.

Exchanging the
# SUSPEND_MODULES=""
for
SUSPEND_MODULES="wacom"
in /usr/lib/pm-utils/default fixes the issue. Then pen is fully working over suspend resume cycle. Tested multiple cycles with mypaint open during the suspend resumes and styles works for X pointer movement and pressure after the resumes.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: pm-utils 1.4.1-9 [modified: usr/lib/pm-utils/defaults]
ProcVersionSignature: Ubuntu 3.2.0-19.31-generic 3.2.12
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 21 14:47:01 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: pm-utils
UpgradeStatus: Upgraded to precise on 2012-03-14 (7 days ago)

Philip Guyton (phil-lxnet) wrote :

Still in effect for precise final

Changed in pm-utils (Ubuntu):
status: New → Confirmed

The suggested fix worked for me.

Changed in pm-utils (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
summary: - wacom intuos 3 not working after resume -- with fix
+ wacom intuos 3 not working after resume -- Must unplug and plug in the
+ device
Ulysses Fnord (artao) wrote :

This fixed it for me as well. I'm running Kubuntu 12.04 and have an Intuos 2, not 3. Still, I was having the exact same problem, and this fixed it. Thanks. This has been irritating me for some time now.
I'm rather curious why it happens?

Ulysses Fnord (artao) wrote :

I take it back. It did NOT fix it. It seemed to, but now it won't work when I hotplug it.

Ulysses Fnord (artao) wrote :

ok. ... um ... this is somewhat insane now ..... ..... it DOES come back after sleep>wake .... it does NOT come back after hot-unplug>plug .... but then when i sleep>wake the machine, it DOES comes back. .... something is very very wrong here, and I have NO idea how to troubleshoot it.
I guess I just leave it plugged in then, for now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers